]> git.pld-linux.org Git - packages/gwget.git/blob - gwget.spec
- updated gettext BR
[packages/gwget.git] / gwget.spec
1 #
2 # Conditional build:
3 %bcond_with     epiphany        # don't build epiphany extension
4 #
5 %define epiphany_version        3.0
6 #
7 Summary:        A download manager for GNOME
8 Summary(pl.UTF-8):      Zarządca pobierania plików dla GNOME
9 Name:           gwget
10 Version:        1.0.4
11 Release:        6
12 License:        GPL v2+
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gwget/1.0/%{name}-%{version}.tar.bz2
15 # Source0-md5:  b65ebc752cad068e747ae6ef45fafdcc
16 Patch0:         epiphany-230.patch
17 Patch1:         %{name}-libnotify.patch
18 Patch2:         epiphany-30.patch
19 URL:            http://www.gnome.org/projects/gwget/
20 BuildRequires:  GConf2-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  dbus-glib-devel >= 0.73
24 %{?with_epiphany:BuildRequires: epiphany-devel >= 3.0.0}
25 BuildRequires:  gettext-tools
26 BuildRequires:  gtk+2-devel >= 2:2.10.10
27 BuildRequires:  intltool >= 0.35.5
28 BuildRequires:  libgnomeui-devel >= 2.18.1
29 BuildRequires:  libnotify-devel >= 0.4.0
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpmbuild(macros) >= 1.197
33 Requires(post,preun):   GConf2
34 Requires:       libgnomeui >= 2.18.1
35 Requires:       wget >= 1.10
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Gwget is a download manager for GNOME.
40
41 %description -l pl.UTF-8
42 Gwget to zarządca pobierania plików dla GNOME.
43
44 %package -n epiphany-extension-gwget
45 Summary:        Epiphany extension - gwget
46 Summary(pl.UTF-8):      Rozszerzenie dla Epiphany - gwget
47 Group:          X11/Applications/Networking
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       epiphany >= 2.24.0
50
51 %description -n epiphany-extension-gwget
52 Epiphany extension that uses gwget to download files.
53
54 %description -n epiphany-extension-gwget -l pl.UTF-8
55 Rozszerzenie dla Epiphany wykorzystujące gwget do pobierania plików.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62
63 %build
64 %{__intltoolize}
65 %{__libtoolize} --install
66 %{__aclocal}
67 %{__autoconf}
68 %{__automake}
69 %configure \
70         --disable-schemas-install \
71         %{?with_epiphany: --with-epiphany-version=%{epiphany_version}} \
72         %{!?with_epiphany: --disable-epiphany-extension}
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT \
80         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
81
82 rm -rf $RPM_BUILD_ROOT%{_includedir}/gwget
83
84 %if %{with epiphany}
85 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{epiphany_version}/extensions/*.{a,la}
86 %endif
87
88 %find_lang %{name}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 %gconf_schema_install gwget.schemas
95
96 %preun
97 %gconf_schema_uninstall gwget.schemas
98
99 %files -f %{name}.lang
100 %defattr(644,root,root,755)
101 %doc AUTHORS ChangeLog NEWS README THANKS TODO
102 %attr(755,root,root) %{_bindir}/*
103 %{_datadir}/%{name}
104 %{_datadir}/dbus-1/services/org.gnome.gwget.service
105 %{_desktopdir}/*.desktop
106 %{_pixmapsdir}/*.png
107 %{_sysconfdir}/gconf/schemas/gwget.schemas
108
109 %if %{with epiphany}
110 %files -n epiphany-extension-gwget
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/epiphany/%{epiphany_version}/extensions/libgwgetextension.so*
113 %{_libdir}/epiphany/%{epiphany_version}/extensions/gwget.xml
114 %endif
This page took 0.079611 seconds and 4 git commands to generate.