]> git.pld-linux.org Git - packages/gvfs.git/blob - gvfs.spec
organize bcond based filelists together
[packages/gvfs.git] / gvfs.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # docs building and packaging
4 %bcond_without  afc     # AFC backend
5 %bcond_without  afp     # AFP support
6 %bcond_without  archive # archive support
7 %bcond_without  avahi   # DNS-SD / Avahi support
8 %bcond_without  bluray  # bluray metadata support
9 %bcond_without  cdda    # CDDA backend
10 %bcond_without  fuse    # FUSE support
11 %bcond_without  goa     # GOA backend
12 %bcond_with     gdu     # GDU (Gnome Disk Utility) volume monitor
13 %bcond_without  gphoto2 # gphoto2 support
14 %bcond_without  gtk     # GTK+
15 %bcond_without  gudev   # gudev support (if disabled, HAL could be used)
16 %bcond_without  http    # HTTP/DAV backend
17 %bcond_with     keyring # GNOME Keyring support
18 %bcond_without  mtp     # MTP support
19 %bcond_without  obexftp # ObexFTP backend
20 %bcond_without  samba   # SMB support
21 %bcond_without  systemd # libsystemd-login support
22 %bcond_without  udev    # udev support (needed also for gphoto2, mtp, udisks2)
23 %bcond_without  udisks2 # libudisks2 support
24
25 %if %{without gudev}
26 %undefine       with_gphoto2
27 %undefine       with_mtp
28 %undefine       with_udisks2
29 %endif
30
31 %ifarch s390 s390x
32 %undefine       with_afc
33 %endif
34
35 Summary:        gvfs - userspace virtual filesystem
36 Summary(pl.UTF-8):      gvfs - wirtualny system plików w przestrzeni użytkownika
37 Name:           gvfs
38 Version:        1.18.3
39 Release:        5
40 License:        LGPL v2+
41 Group:          Libraries
42 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.18/%{name}-%{version}.tar.xz
43 # Source0-md5:  3620baa478f1748bd32d2f47bcbe30d0
44 Patch0:         set_attributes_from_info-v1.patch
45 URL:            https://live.gnome.org/gvfs
46 BuildRequires:  autoconf >= 2.64
47 BuildRequires:  automake >= 1:1.11.1
48 %{?with_avahi:BuildRequires:    avahi-devel >= 0.6.22}
49 %{?with_avahi:BuildRequires:    avahi-glib-devel >= 0.6.22}
50 %{?with_obexftp:BuildRequires:  bluez-libs-devel >= 4.0}
51 %{?with_cdda:BuildRequires:     cdparanoia-III-devel >= 1:10}
52 BuildRequires:  dbus-devel
53 %{?with_obexftp:BuildRequires:  dbus-glib-devel}
54 %{?with_doc:BuildRequires:      docbook-dtd42-xml}
55 %{?with_doc:BuildRequires:      docbook-style-xsl}
56 %{?with_obexftp:BuildRequires:  expat-devel >= 1.95}
57 BuildRequires:  gettext-devel
58 BuildRequires:  glib2-devel >= 1:2.38.0
59 %{?with_gdu:BuildRequires:      gnome-disk-utility-devel >= 3.0.2}
60 %{?with_goa:BuildRequires:      gnome-online-accounts-devel >= 3.8.0}
61 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.0}
62 BuildRequires:  intltool >= 0.40.0
63 %{?with_archive:BuildRequires:  libarchive-devel >= 3.0.22}
64 %{?with_bluray:BuildRequires:   libbluray-devel}
65 %{?with_cdda:BuildRequires:     libcdio-paranoia-devel >= 0.78.2}
66 %{?with_fuse:BuildRequires:     libfuse-devel >= 2.8.0}
67 BuildRequires:  libgcrypt-devel >= 1.2.2
68 %{?with_gphoto2:BuildRequires:  libgphoto2-devel >= 2.5.0}
69 %{?with_afc:BuildRequires:      libimobiledevice-devel >= 1.1.5}
70 %{?with_mtp:BuildRequires:      libmtp-devel >= 1.1.6}
71 %{?with_afc:BuildRequires:      libplist-devel >= 0.15}
72 %{?with_keyring:BuildRequires:  libsecret-devel}
73 %{?with_samba:BuildRequires:    libsmbclient-devel >= 3.0}
74 %{?with_http:BuildRequires:     libsoup-gnome-devel >= 2.34.0}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_http:BuildRequires:     libxml2-devel >= 1:2.6.31}
77 %{?with_doc:BuildRequires:      libxslt-progs}
78 BuildRequires:  pkgconfig
79 BuildRequires:  rpmbuild(macros) >= 1.592
80 %{?with_systemd:BuildRequires:  systemd-devel >= 44}
81 BuildRequires:  tar >= 1:1.22
82 %{?with_udev:BuildRequires:     udev-devel >= 1:138}
83 %{?with_gudev:BuildRequires:    udev-glib-devel >= 001}
84 %{?with_udisks2:BuildRequires:  udisks2-devel >= 1.97.0}
85 BuildRequires:  xz
86 Requires(post,postun):  glib2 >= 1:2.38.0
87 Requires:       %{name}-libs = %{version}-%{release}
88 %{?with_avahi:Requires: avahi-glib >= 0.6.22}
89 %{?with_cdda:Requires:  cdparanoia-III-libs >= 1:10}
90 %{?with_cdda:Requires:  libcdio-paranoia >= 0.78.2}
91 Requires:       libplist >= 0.15
92 Requires:       libsoup-gnome >= 2.34.0
93 Requires:       libxml2 >= 1:2.6.31
94 Requires:       udev-libs >= 1:138
95 %{?with_udisks2:Requires:       udisks2 >= 1.97.0}
96 %{?with_afc:Suggests:   %{name}-afc}
97 %{?with_afp:Suggests:   %{name}-afp}
98 %{?with_archive:Suggests:       %{name}-archive}
99 %{?with_fuse:Suggests:  %{name}-fuse}
100 %{?with_goa:Suggests:   %{name}-goa}
101 %{?with_gphoto2:Suggests:       %{name}-gphoto2}
102 %{?with_mtp:Suggests:   %{name}-mtp}
103 %{?with_samba:Suggests: %{name}-smb}
104 %{?with_obexftp:Suggests:       obex-data-server >= 0.4}
105 Obsoletes:      gnome-mount <= 0.8
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %define         _libexecdir     %{_libdir}/%{name}
109
110 %description
111 gvfs is a userspace virtual filesystem where mount runs as a separate
112 processes which you talk to via D-BUS. It contains a gio module that
113 seamlessly adds gvfs support to all applications using the gio API.
114
115 %description -l pl.UTF-8
116 gvfs to wirtualny system plik w przestrzeni użytkownika. Montowanie w
117 nim działa jako oddzielny proces, z którym komunikacja odbywa się
118 przez D-BUS. Zawiera moduł gio dodający w sposób przezroczysty obsługę
119 gfvs-a do wszystkich aplikacji używających API gio.
120
121 %package libs
122 Summary:        gvfs libraries
123 Summary(pl.UTF-8):      Biblioteki gvfs
124 Group:          Libraries
125 Requires:       glib2 >= 1:2.38.0
126
127 %description libs
128 gvfs libraries.
129
130 %description libs -l pl.UTF-8
131 Biblioteki gvfs.
132
133 %package devel
134 Summary:        Header files for gvfs library
135 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gvfs
136 Group:          Development/Libraries
137 Requires:       %{name}-libs = %{version}-%{release}
138 Requires:       glib2-devel >= 1:2.38.0
139
140 %description devel
141 Header files for gvfs library.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe biblioteki gvfs.
145
146 %package afc
147 Summary:        AFC support for gvfs
148 Summary(pl.UTF-8):      Obsługa AFC dla gvfs
149 Group:          Libraries
150 Requires:       %{name} = %{version}-%{release}
151 Requires:       libimobiledevice >= 1.1.5
152 Requires:       usbmuxd
153
154 %description afc
155 This package provides support for reading files on mobile devices
156 including phones and music players to applications using gvfs.
157
158 %description afc -l pl.UTF-8
159 Ten pakiet zapewnia obsługę odczytu plików na urządzeniach
160 przenośnych, w tym telefonach i odtwarzaczach muzyki dla aplikacji
161 wykorzystujących gvfs.
162
163 %package afp
164 Summary:        AFP support for gvfs
165 Summary(pl.UTF-8):      Obsługa AFP dla gvfs
166 Group:          Libraries
167 Requires:       %{name} = %{version}-%{release}
168
169 %description afp
170 This package provides support for reading and writing files on Mac OS
171 X and original Mac OS network shares via Apple Filing Protocol to
172 applications using gvfs.
173
174 %description afp -l pl.UTF-8
175 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
176 sieciowych Mac OS X oraz oryginalnego Mac OS poprzez Apple Filing
177 Protocol dla aplikacji wykorzystujących gvfs.
178
179 %package archive
180 Summary:        Archiving support for gvfs
181 Summary(pl.UTF-8):      Obsługa archiwów dla gvfs
182 Group:          Libraries
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       libarchive >= 3.0.22
185
186 %description archive
187 This package provides support for accessing files inside Zip and Tar
188 archives, as well as ISO images, to applications using gvfs.
189
190 %description archive -l pl.UTF-8
191 Ten pakiet zapewnia dostęp do plików wewnątrz archiwów Zip i Tar oraz
192 obrazów ISO dla aplikacji wykorzystujących gvfs.
193
194 %package fuse
195 Summary:        FUSE support for gvfs
196 Summary(pl.UTF-8):      Obsługa FUSE dla gvfs
197 Group:          Libraries
198 Requires:       %{name} = %{version}-%{release}
199 Requires:       libfuse
200
201 %description fuse
202 This package provides support for applications not using gio to access
203 the gvfs filesystems.
204
205 %description fuse -l pl.UTF-8
206 Ten pakiet zapewnia obsługę aplikacji nie używających gio do dostępu
207 do systemów plików gvfs.
208
209 %package goa
210 Summary:        GOA support for gvfs
211 Summary(pl.UTF-8):      Obsługa GOA dla gvfs
212 Group:          Libraries
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       gnome-online-accounts-libs >= 3.8.0
215
216 %description goa
217 This package provides seamless integration with gnome-online-accounts
218 file services.
219
220 %description goa -l pl.UTF-8
221 Ten pakiet zapewnia przezroczystą integrację z usługami plikowymi
222 gnome-online-accounts.
223
224 %package gphoto2
225 Summary:        gphoto2 support for gvfs
226 Summary(pl.UTF-8):      Obsługa gphoto2 dla gvfs
227 Group:          Libraries
228 Requires:       %{name} = %{version}-%{release}
229
230 %description gphoto2
231 This package provides support for reading and writing files on PTP
232 based cameras (Picture Transfer Protocol) and MTP based media players
233 (Media Transfer Protocol) to applications using gvfs.
234
235 %description gphoto2 -l pl.UTF-8
236 Ten pakiet zapewnia obsługę odczytu i zapisu plików na aparatach
237 obsługujących protokół PTP (Picture Transfer Protocol) oraz
238 odtwarzaczach multimedialnych obsługujących protokół MTP (Media
239 Transfer Protocol) dla aplikacji wykorzystujących gvfs.
240
241 %package mtp
242 Summary:        MTP support for gvfs
243 Summary(pl.UTF-8):      Obsługa MTP dla gvfs
244 Group:          Libraries
245 Requires:       %{name} = %{version}-%{release}
246 Requires:       libmtp >= 1.1.6
247
248 %description mtp
249 This package provides support for reading and writing files on MTP
250 based devices (Media Transfer Protocol) to applications using gvfs.
251
252 %description mtp -l pl.UTF-8
253 Ten pakiet zapewnia obsługę odczytu i zapisu plików na urządzeniach
254 obsługujących protokół MTP (Media Transfer Protocol) dla aplikacji
255 wykorzystujących gvfs.
256
257 %package smb
258 Summary:        Windows fileshare support for gvfs
259 Summary(pl.UTF-8):      Obsługa udziałów sieciowych Windows dla gvfs
260 Group:          Libraries
261 Requires:       %{name} = %{version}-%{release}
262
263 %description smb
264 This package provides support for reading and writing files on Windows
265 shares (SMB) to applications using gvfs.
266
267 %description smb -l pl.UTF-8
268 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
269 sieciowych Windows (SMB) dla aplikacji wykorzystujących gvfs.
270
271 %package -n bash-completion-gvfs
272 Summary:        bash-completion for gvfs
273 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gvfs
274 Group:          Applications/Shells
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       bash-completion >= 2
277
278 %description -n bash-completion-gvfs
279 This package provides bash-completion for gvfs.
280
281 %description -n bash-completion-gvfs -l pl.UTF-8
282 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gvfs.
283
284 %prep
285 %setup -q
286 %patch0 -p1
287
288 %build
289 %{__intltoolize}
290 %{__libtoolize}
291 %{__aclocal}
292 %{__autoconf}
293 %{__autoheader}
294 %{__automake}
295 %configure \
296         SSH_PROGRAM=/usr/bin/ssh \
297         %{__enable_disable afc} \
298         %{__enable_disable afp} \
299         %{__enable_disable archive} \
300         %{__enable_disable avahi} \
301         %{__enable_disable bluray} \
302         %{__enable_disable cdda} \
303         %{__enable_disable doc documentation} \
304         %{__enable_disable fuse} \
305         %{__enable_disable gdu} \
306         %{__enable_disable goa} \
307         %{__enable_disable gphoto2} \
308         %{__enable_disable gtk} \
309         %{__enable_disable gudev} \
310         %{__enable_disable http} \
311         %{__enable_disable keyring} \
312         %{__enable_disable mtp libmtp} \
313         %{__enable_disable obexftp} \
314         %{__enable_disable samba} \
315         %{__enable_disable systemd libsystemd-login} \
316         %{__enable_disable udev} \
317         %{__enable_disable udisks2} \
318         --disable-hal \
319         --disable-silent-rules
320
321 %{__make}
322
323 %install
324 rm -rf $RPM_BUILD_ROOT
325 %{__make} install \
326         DESTDIR=$RPM_BUILD_ROOT
327
328 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.la
329
330 %find_lang gvfs
331
332 %clean
333 rm -rf $RPM_BUILD_ROOT
334
335 %post
336 %glib_compile_schemas
337 umask 022
338 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
339 # Reload .mount files:
340 killall -USR1 gvfsd >/dev/null 2>&1 || :
341
342 %postun
343 if [ "$1" = "0" ]; then
344         %glib_compile_schemas
345 fi
346 umask 022
347 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
348 exit 0
349
350 %post   libs -p /sbin/ldconfig
351 %postun libs -p /sbin/ldconfig
352
353 # Reload .mount files when single subpackage is installed:
354 %post afc
355 killall -USR1 gvfsd >/dev/null 2>&1 || :
356
357 %post archive
358 killall -USR1 gvfsd >/dev/null 2>&1 || :
359
360 %post goa
361 killall -USR1 gvfsd >/dev/null 2>&1 || :
362
363 %post gphoto2
364 killall -USR1 gvfsd >/dev/null 2>&1 || :
365
366 %post mtp
367 killall -USR1 gvfsd >/dev/null 2>&1 || :
368
369 %post smb
370 killall -USR1 gvfsd >/dev/null 2>&1 || :
371
372 %files -f gvfs.lang
373 %defattr(644,root,root,755)
374 %doc AUTHORS ChangeLog NEWS README TODO
375 %attr(755,root,root) %{_bindir}/gvfs-cat
376 %attr(755,root,root) %{_bindir}/gvfs-copy
377 %attr(755,root,root) %{_bindir}/gvfs-info
378 %attr(755,root,root) %{_bindir}/gvfs-less
379 %attr(755,root,root) %{_bindir}/gvfs-ls
380 %attr(755,root,root) %{_bindir}/gvfs-mime
381 %attr(755,root,root) %{_bindir}/gvfs-mkdir
382 %attr(755,root,root) %{_bindir}/gvfs-monitor-dir
383 %attr(755,root,root) %{_bindir}/gvfs-monitor-file
384 %attr(755,root,root) %{_bindir}/gvfs-mount
385 %attr(755,root,root) %{_bindir}/gvfs-move
386 %attr(755,root,root) %{_bindir}/gvfs-open
387 %attr(755,root,root) %{_bindir}/gvfs-rename
388 %attr(755,root,root) %{_bindir}/gvfs-rm
389 %attr(755,root,root) %{_bindir}/gvfs-save
390 %attr(755,root,root) %{_bindir}/gvfs-set-attribute
391 %attr(755,root,root) %{_bindir}/gvfs-trash
392 %attr(755,root,root) %{_bindir}/gvfs-tree
393 %attr(755,root,root) %{_libdir}/gio/modules/libgioremote-volume-monitor.so
394 %attr(755,root,root) %{_libdir}/gio/modules/libgvfsdbus.so
395 %dir %{_libexecdir}
396 %attr(755,root,root) %{_libexecdir}/gvfsd
397 %attr(755,root,root) %{_libexecdir}/gvfsd-burn
398 %attr(755,root,root) %{_libexecdir}/gvfsd-computer
399 %attr(755,root,root) %{_libexecdir}/gvfsd-ftp
400 %attr(755,root,root) %{_libexecdir}/gvfsd-localtest
401 %attr(755,root,root) %{_libexecdir}/gvfsd-metadata
402 %attr(755,root,root) %{_libexecdir}/gvfsd-network
403 %attr(755,root,root) %{_libexecdir}/gvfsd-sftp
404 %attr(755,root,root) %{_libexecdir}/gvfsd-trash
405 %{_datadir}/dbus-1/services/gvfs-daemon.service
406 %{_datadir}/dbus-1/services/gvfs-metadata.service
407 %dir %{_datadir}/gvfs
408 %dir %{_datadir}/gvfs/mounts
409 %dir %{_datadir}/gvfs/remote-volume-monitors
410 %{_datadir}/gvfs/mounts/burn.mount
411 %{_datadir}/gvfs/mounts/computer.mount
412 %{_datadir}/gvfs/mounts/ftp.mount
413 %{_datadir}/gvfs/mounts/localtest.mount
414 %{_datadir}/gvfs/mounts/network.mount
415 %{_datadir}/gvfs/mounts/sftp.mount
416 %{_datadir}/gvfs/mounts/trash.mount
417 %{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml
418
419 # cdda
420 %if %{with cdda}
421 %attr(755,root,root) %{_libexecdir}/gvfsd-cdda
422 %{_datadir}/gvfs/mounts/cdda.mount
423 %endif
424
425 # http
426 %if %{with http}
427 %attr(755,root,root) %{_libexecdir}/gvfsd-dav
428 %attr(755,root,root) %{_libexecdir}/gvfsd-http
429 %{_datadir}/gvfs/mounts/http.mount
430 %{_datadir}/gvfs/mounts/dav.mount
431 %{?with_avahi:%{_datadir}/gvfs/mounts/dav+sd.mount}
432 %endif
433
434 # obexftp
435 %if %{with obexftp}
436 %attr(755,root,root) %{_libexecdir}/gvfsd-obexftp
437 %{_datadir}/gvfs/mounts/obexftp.mount
438 %endif
439
440 # gtk
441 %if %{with gtk}
442 %attr(755,root,root) %{_libexecdir}/gvfsd-recent
443 %{_datadir}/gvfs/mounts/recent.mount
444 %endif
445
446 # udisks2
447 %if %{with udisks2}
448 %attr(755,root,root) %{_libexecdir}/gvfs-udisks2-volume-monitor
449 %{_datadir}/dbus-1/services/org.gtk.Private.UDisks2VolumeMonitor.service
450 %{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor
451 %endif
452
453 # avahi
454 %if %{with avahi}
455 %attr(755,root,root) %{_libexecdir}/gvfsd-dnssd
456 %{_datadir}/gvfs/mounts/dns-sd.mount
457 %{_datadir}/GConf/gsettings/gvfs-dns-sd.convert
458 %{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml
459 %endif
460
461 %if %{with doc}
462 %{_mandir}/man1/gvfs-*.1*
463 %{_mandir}/man1/gvfsd.1*
464 %{_mandir}/man1/gvfsd-metadata.1*
465 %{_mandir}/man7/gvfs.7*
466 %endif
467
468 %files libs
469 %defattr(644,root,root,755)
470 %attr(755,root,root) %{_libdir}/libgvfscommon.so.*.*.*
471 %attr(755,root,root) %ghost %{_libdir}/libgvfscommon.so.0
472
473 %files devel
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_libdir}/libgvfscommon.so
476 %{_libdir}/libgvfscommon.la
477 %{_includedir}/gvfs-client
478
479 %if %{with afc}
480 %files afc
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{_libexecdir}/gvfs-afc-volume-monitor
483 %attr(755,root,root) %{_libexecdir}/gvfsd-afc
484 %{_datadir}/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service
485 %{_datadir}/gvfs/mounts/afc.mount
486 %{_datadir}/gvfs/remote-volume-monitors/afc.monitor
487 %endif
488
489 %if %{with afp}
490 %files afp
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_libexecdir}/gvfsd-afp
493 %attr(755,root,root) %{_libexecdir}/gvfsd-afp-browse
494 %{_datadir}/gvfs/mounts/afp-browse.mount
495 %{_datadir}/gvfs/mounts/afp.mount
496 %endif
497
498 %if %{with archive}
499 %files archive
500 %defattr(644,root,root,755)
501 %attr(755,root,root) %{_libexecdir}/gvfsd-archive
502 %{_datadir}/gvfs/mounts/archive.mount
503 %endif
504
505 %if %{with fuse}
506 %files fuse
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_libexecdir}/gvfsd-fuse
509 %if %{with doc}
510 %{_mandir}/man1/gvfsd-fuse.1*
511 %endif
512 %if %{with systemd}
513 # FIXME: reusing USE_LIBSYSTEMD_LOGIN as systemd has no universal header or pkg-config file
514 %{systemdtmpfilesdir}/gvfsd-fuse-tmpfiles.conf
515 %endif
516 %endif
517
518 %if %{with goa}
519 %files goa
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_libexecdir}/gvfs-goa-volume-monitor
522 %{_datadir}/dbus-1/services/org.gtk.Private.GoaVolumeMonitor.service
523 %{_datadir}/gvfs/remote-volume-monitors/goa.monitor
524 %endif
525
526 %if %{with gphoto2}
527 %files gphoto2
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libexecdir}/gvfs-gphoto2-volume-monitor
530 %attr(755,root,root) %{_libexecdir}/gvfsd-gphoto2
531 %{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service
532 %{_datadir}/gvfs/mounts/gphoto2.mount
533 %{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
534 %endif
535
536 %if %{with mtp}
537 %files mtp
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_libexecdir}/gvfs-mtp-volume-monitor
540 %attr(755,root,root) %{_libexecdir}/gvfsd-mtp
541 %{_datadir}/dbus-1/services/org.gtk.Private.MTPVolumeMonitor.service
542 %{_datadir}/gvfs/mounts/mtp.mount
543 %{_datadir}/gvfs/remote-volume-monitors/mtp.monitor
544 %endif
545
546 %if %{with samba}
547 %files smb
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libexecdir}/gvfsd-smb
550 %attr(755,root,root) %{_libexecdir}/gvfsd-smb-browse
551 %{_datadir}/gvfs/mounts/smb-browse.mount
552 %{_datadir}/gvfs/mounts/smb.mount
553 %{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml
554 %{_datadir}/GConf/gsettings/gvfs-smb.convert
555 %endif
556
557 %files -n bash-completion-gvfs
558 %defattr(644,root,root,755)
559 %{_datadir}/bash-completion/completions/gvfs
This page took 0.084678 seconds and 3 git commands to generate.