]> git.pld-linux.org Git - packages/gvfs.git/blob - gvfs.spec
- enabled keyring support
[packages/gvfs.git] / gvfs.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # docs building and packaging
4 %bcond_without  afc     # AFC backend
5 %bcond_without  afp     # AFP support
6 %bcond_without  archive # archive support
7 %bcond_without  avahi   # DNS-SD / Avahi support
8 %bcond_without  bluray  # bluray metadata support
9 %bcond_without  cdda    # CDDA backend
10 %bcond_without  fuse    # FUSE support
11 %bcond_without  goa     # GOA backend
12 %bcond_with     gdu     # GDU (Gnome Disk Utility) volume monitor (3.0.2 <= v < 3.4)
13 %bcond_without  gphoto2 # gphoto2 support
14 %bcond_without  gtk     # GTK+
15 %bcond_without  gudev   # gudev support (if disabled, HAL could be used)
16 %bcond_without  http    # HTTP/DAV backend
17 %bcond_without  keyring # GNOME Keyring support in gvfs and udisks plugin
18 %bcond_without  mtp     # MTP support
19 %bcond_without  obexftp # ObexFTP backend
20 %bcond_without  samba   # SMB support
21 %bcond_without  systemd # libsystemd-login support
22 %bcond_without  udev    # udev support (needed also for gphoto2, mtp, udisks2)
23 %bcond_without  udisks2 # libudisks2 support
24
25 %if %{without gudev}
26 %undefine       with_gphoto2
27 %undefine       with_mtp
28 %undefine       with_udisks2
29 %endif
30
31 %ifarch s390 s390x
32 %undefine       with_afc
33 %endif
34
35 Summary:        gvfs - userspace virtual filesystem
36 Summary(pl.UTF-8):      gvfs - wirtualny system plików w przestrzeni użytkownika
37 Name:           gvfs
38 Version:        1.20.0
39 Release:        2
40 License:        LGPL v2+
41 Group:          Libraries
42 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.20/%{name}-%{version}.tar.xz
43 # Source0-md5:  5c19d31f61af35ca7da3413a1db46bb0
44 Patch0:         set_attributes_from_info-v1.patch
45 URL:            https://live.gnome.org/gvfs
46 BuildRequires:  autoconf >= 2.64
47 BuildRequires:  automake >= 1:1.11.1
48 %{?with_avahi:BuildRequires:    avahi-devel >= 0.6.22}
49 %{?with_avahi:BuildRequires:    avahi-glib-devel >= 0.6.22}
50 %{?with_obexftp:BuildRequires:  bluez-libs-devel >= 4.0}
51 %{?with_cdda:BuildRequires:     cdparanoia-III-devel >= 1:10}
52 BuildRequires:  dbus-devel
53 %{?with_obexftp:BuildRequires:  dbus-glib-devel}
54 %{?with_doc:BuildRequires:      docbook-dtd42-xml}
55 %{?with_doc:BuildRequires:      docbook-style-xsl}
56 %{?with_obexftp:BuildRequires:  expat-devel >= 1.95}
57 BuildRequires:  gettext-devel
58 BuildRequires:  glib2-devel >= 1:2.38.0
59 %{?with_gdu:BuildRequires:      gnome-disk-utility-devel >= 3.0.2}
60 %{?with_gdu:BuildRequires:      gnome-disk-utility-devel < 3.4}
61 %{?with_goa:BuildRequires:      gnome-online-accounts-devel >= 3.8.0}
62 %{?with_gtk:BuildRequires:      gtk+3-devel >= 3.0}
63 BuildRequires:  intltool >= 0.40.0
64 %{?with_archive:BuildRequires:  libarchive-devel >= 3.0.22}
65 %{?with_bluray:BuildRequires:   libbluray-devel}
66 %{?with_cdda:BuildRequires:     libcdio-paranoia-devel >= 0.78.2}
67 %{?with_fuse:BuildRequires:     libfuse-devel >= 2.8.0}
68 BuildRequires:  libgcrypt-devel >= 1.2.2
69 %{?with_gphoto2:BuildRequires:  libgphoto2-devel >= 2.5.0}
70 %{?with_afc:BuildRequires:      libimobiledevice-devel >= 1.1.5}
71 %{?with_mtp:BuildRequires:      libmtp-devel >= 1.1.6}
72 %{?with_afc:BuildRequires:      libplist-devel >= 0.15}
73 %{?with_keyring:BuildRequires:  libsecret-devel}
74 %{?with_samba:BuildRequires:    libsmbclient-devel >= 3.0}
75 %{?with_http:BuildRequires:     libsoup-devel >= 2.42.0}
76 BuildRequires:  libtool >= 2:2.2
77 %{?with_http:BuildRequires:     libxml2-devel >= 1:2.6.31}
78 %{?with_doc:BuildRequires:      libxslt-progs}
79 BuildRequires:  pkgconfig
80 BuildRequires:  rpmbuild(macros) >= 1.592
81 %{?with_systemd:BuildRequires:  systemd-devel >= 44}
82 BuildRequires:  tar >= 1:1.22
83 %{?with_udev:BuildRequires:     udev-devel >= 1:138}
84 %{?with_gudev:BuildRequires:    udev-glib-devel >= 001}
85 %{?with_udisks2:BuildRequires:  udisks2-devel >= 1.97.0}
86 BuildRequires:  xz
87 Requires(post,postun):  glib2 >= 1:2.38.0
88 %{?with_avahi:Requires: avahi-glib >= 0.6.22}
89 %{?with_cdda:Requires:  cdparanoia-III-libs >= 1:10}
90 %{?with_cdda:Requires:  libcdio-paranoia >= 0.78.2}
91 Requires:       libplist >= 0.15
92 Requires:       libsoup >= 2.42.0
93 Requires:       libxml2 >= 1:2.6.31
94 Requires:       udev-libs >= 1:138
95 %{?with_udisks2:Requires:       udisks2 >= 1.97.0}
96 %{?with_afc:Suggests:   %{name}-afc}
97 %{?with_afp:Suggests:   %{name}-afp}
98 %{?with_archive:Suggests:       %{name}-archive}
99 %{?with_fuse:Suggests:  %{name}-fuse}
100 %{?with_goa:Suggests:   %{name}-goa}
101 %{?with_gphoto2:Suggests:       %{name}-gphoto2}
102 %{?with_mtp:Suggests:   %{name}-mtp}
103 %{?with_samba:Suggests: %{name}-smb}
104 %{?with_obexftp:Suggests:       obex-data-server >= 0.4}
105 Obsoletes:      gnome-mount <= 0.8
106 Obsoletes:      gvfs-libs < 1.20.0
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define         _libexecdir     %{_libdir}/%{name}
110
111 %description
112 gvfs is a userspace virtual filesystem where mount runs as a separate
113 processes which you talk to via D-BUS. It contains a gio module that
114 seamlessly adds gvfs support to all applications using the gio API.
115
116 %description -l pl.UTF-8
117 gvfs to wirtualny system plik w przestrzeni użytkownika. Montowanie w
118 nim działa jako oddzielny proces, z którym komunikacja odbywa się
119 przez D-BUS. Zawiera moduł gio dodający w sposób przezroczysty obsługę
120 gfvs-a do wszystkich aplikacji używających API gio.
121
122 %package devel
123 Summary:        Header files for gvfs library
124 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gvfs
125 Group:          Development/Libraries
126 Requires:       glib2-devel >= 1:2.38.0
127
128 %description devel
129 Header files for gvfs library.
130
131 %description devel -l pl.UTF-8
132 Pliki nagłówkowe biblioteki gvfs.
133
134 %package afc
135 Summary:        AFC support for gvfs
136 Summary(pl.UTF-8):      Obsługa AFC dla gvfs
137 Group:          Libraries
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       libimobiledevice >= 1.1.5
140 Requires:       usbmuxd
141
142 %description afc
143 This package provides support for reading files on mobile devices
144 including phones and music players to applications using gvfs.
145
146 %description afc -l pl.UTF-8
147 Ten pakiet zapewnia obsługę odczytu plików na urządzeniach
148 przenośnych, w tym telefonach i odtwarzaczach muzyki dla aplikacji
149 wykorzystujących gvfs.
150
151 %package afp
152 Summary:        AFP support for gvfs
153 Summary(pl.UTF-8):      Obsługa AFP dla gvfs
154 Group:          Libraries
155 Requires:       %{name} = %{version}-%{release}
156
157 %description afp
158 This package provides support for reading and writing files on Mac OS
159 X and original Mac OS network shares via Apple Filing Protocol to
160 applications using gvfs.
161
162 %description afp -l pl.UTF-8
163 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
164 sieciowych Mac OS X oraz oryginalnego Mac OS poprzez Apple Filing
165 Protocol dla aplikacji wykorzystujących gvfs.
166
167 %package archive
168 Summary:        Archiving support for gvfs
169 Summary(pl.UTF-8):      Obsługa archiwów dla gvfs
170 Group:          Libraries
171 Requires:       %{name} = %{version}-%{release}
172 Requires:       libarchive >= 3.0.22
173
174 %description archive
175 This package provides support for accessing files inside Zip and Tar
176 archives, as well as ISO images, to applications using gvfs.
177
178 %description archive -l pl.UTF-8
179 Ten pakiet zapewnia dostęp do plików wewnątrz archiwów Zip i Tar oraz
180 obrazów ISO dla aplikacji wykorzystujących gvfs.
181
182 %package fuse
183 Summary:        FUSE support for gvfs
184 Summary(pl.UTF-8):      Obsługa FUSE dla gvfs
185 Group:          Libraries
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       libfuse
188
189 %description fuse
190 This package provides support for applications not using gio to access
191 the gvfs filesystems.
192
193 %description fuse -l pl.UTF-8
194 Ten pakiet zapewnia obsługę aplikacji nie używających gio do dostępu
195 do systemów plików gvfs.
196
197 %package goa
198 Summary:        GOA support for gvfs
199 Summary(pl.UTF-8):      Obsługa GOA dla gvfs
200 Group:          Libraries
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       gnome-online-accounts-libs >= 3.8.0
203
204 %description goa
205 This package provides seamless integration with gnome-online-accounts
206 file services.
207
208 %description goa -l pl.UTF-8
209 Ten pakiet zapewnia przezroczystą integrację z usługami plikowymi
210 gnome-online-accounts.
211
212 %package gphoto2
213 Summary:        gphoto2 support for gvfs
214 Summary(pl.UTF-8):      Obsługa gphoto2 dla gvfs
215 Group:          Libraries
216 Requires:       %{name} = %{version}-%{release}
217
218 %description gphoto2
219 This package provides support for reading and writing files on PTP
220 based cameras (Picture Transfer Protocol) and MTP based media players
221 (Media Transfer Protocol) to applications using gvfs.
222
223 %description gphoto2 -l pl.UTF-8
224 Ten pakiet zapewnia obsługę odczytu i zapisu plików na aparatach
225 obsługujących protokół PTP (Picture Transfer Protocol) oraz
226 odtwarzaczach multimedialnych obsługujących protokół MTP (Media
227 Transfer Protocol) dla aplikacji wykorzystujących gvfs.
228
229 %package mtp
230 Summary:        MTP support for gvfs
231 Summary(pl.UTF-8):      Obsługa MTP dla gvfs
232 Group:          Libraries
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       libmtp >= 1.1.6
235
236 %description mtp
237 This package provides support for reading and writing files on MTP
238 based devices (Media Transfer Protocol) to applications using gvfs.
239
240 %description mtp -l pl.UTF-8
241 Ten pakiet zapewnia obsługę odczytu i zapisu plików na urządzeniach
242 obsługujących protokół MTP (Media Transfer Protocol) dla aplikacji
243 wykorzystujących gvfs.
244
245 %package smb
246 Summary:        Windows fileshare support for gvfs
247 Summary(pl.UTF-8):      Obsługa udziałów sieciowych Windows dla gvfs
248 Group:          Libraries
249 Requires:       %{name} = %{version}-%{release}
250
251 %description smb
252 This package provides support for reading and writing files on Windows
253 shares (SMB) to applications using gvfs.
254
255 %description smb -l pl.UTF-8
256 Ten pakiet zapewnia obsługę odczytu i zapisu plików na udziałach
257 sieciowych Windows (SMB) dla aplikacji wykorzystujących gvfs.
258
259 %package -n bash-completion-gvfs
260 Summary:        bash-completion for gvfs
261 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gvfs
262 Group:          Applications/Shells
263 Requires:       %{name} = %{version}-%{release}
264 Requires:       bash-completion >= 2
265
266 %description -n bash-completion-gvfs
267 This package provides bash-completion for gvfs.
268
269 %description -n bash-completion-gvfs -l pl.UTF-8
270 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gvfs.
271
272 %prep
273 %setup -q
274 %patch0 -p1
275
276 %build
277 %{__intltoolize}
278 %{__libtoolize}
279 %{__aclocal}
280 %{__autoconf}
281 %{__autoheader}
282 %{__automake}
283 %configure \
284         SSH_PROGRAM=/usr/bin/ssh \
285         %{__enable_disable afc} \
286         %{__enable_disable afp} \
287         %{__enable_disable archive} \
288         %{__enable_disable avahi} \
289         %{__enable_disable bluray} \
290         %{__enable_disable cdda} \
291         %{__enable_disable doc documentation} \
292         %{__enable_disable fuse} \
293         %{__enable_disable gdu} \
294         %{__enable_disable goa} \
295         %{__enable_disable gphoto2} \
296         %{__enable_disable gtk} \
297         %{__enable_disable gudev} \
298         %{__enable_disable http} \
299         %{__enable_disable keyring} \
300         %{__enable_disable mtp libmtp} \
301         %{__enable_disable obexftp} \
302         %{__enable_disable samba} \
303         %{__enable_disable systemd libsystemd-login} \
304         %{__enable_disable udev} \
305         %{__enable_disable udisks2} \
306         --disable-hal \
307         --disable-silent-rules
308
309 %{__make}
310
311 %install
312 rm -rf $RPM_BUILD_ROOT
313 %{__make} install \
314         DESTDIR=$RPM_BUILD_ROOT
315
316 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{gio/modules,gvfs}/*.la
317
318 %find_lang gvfs
319
320 %clean
321 rm -rf $RPM_BUILD_ROOT
322
323 %post
324 %glib_compile_schemas
325 umask 022
326 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
327 # Reload .mount files:
328 killall -USR1 gvfsd >/dev/null 2>&1 || :
329
330 %postun
331 if [ "$1" = "0" ]; then
332         %glib_compile_schemas
333 fi
334 umask 022
335 %{_bindir}/gio-querymodules %{_libdir}/gio/modules
336 exit 0
337
338 # Reload .mount files when single subpackage is installed:
339 %post afc
340 killall -USR1 gvfsd >/dev/null 2>&1 || :
341
342 %post archive
343 killall -USR1 gvfsd >/dev/null 2>&1 || :
344
345 %post goa
346 killall -USR1 gvfsd >/dev/null 2>&1 || :
347
348 %post gphoto2
349 killall -USR1 gvfsd >/dev/null 2>&1 || :
350
351 %post mtp
352 killall -USR1 gvfsd >/dev/null 2>&1 || :
353
354 %post smb
355 %glib_compile_schemas
356 killall -USR1 gvfsd >/dev/null 2>&1 || :
357
358 %postun smb
359 if [ "$1" = "0" ]; then
360         %glib_compile_schemas
361 fi
362
363 %files -f gvfs.lang
364 %defattr(644,root,root,755)
365 %doc AUTHORS ChangeLog NEWS README TODO
366 %attr(755,root,root) %{_bindir}/gvfs-cat
367 %attr(755,root,root) %{_bindir}/gvfs-copy
368 %attr(755,root,root) %{_bindir}/gvfs-info
369 %attr(755,root,root) %{_bindir}/gvfs-less
370 %attr(755,root,root) %{_bindir}/gvfs-ls
371 %attr(755,root,root) %{_bindir}/gvfs-mime
372 %attr(755,root,root) %{_bindir}/gvfs-mkdir
373 %attr(755,root,root) %{_bindir}/gvfs-monitor-dir
374 %attr(755,root,root) %{_bindir}/gvfs-monitor-file
375 %attr(755,root,root) %{_bindir}/gvfs-mount
376 %attr(755,root,root) %{_bindir}/gvfs-move
377 %attr(755,root,root) %{_bindir}/gvfs-open
378 %attr(755,root,root) %{_bindir}/gvfs-rename
379 %attr(755,root,root) %{_bindir}/gvfs-rm
380 %attr(755,root,root) %{_bindir}/gvfs-save
381 %attr(755,root,root) %{_bindir}/gvfs-set-attribute
382 %attr(755,root,root) %{_bindir}/gvfs-trash
383 %attr(755,root,root) %{_bindir}/gvfs-tree
384 %attr(755,root,root) %{_libdir}/gio/modules/libgioremote-volume-monitor.so
385 %attr(755,root,root) %{_libdir}/gio/modules/libgvfsdbus.so
386 %dir %{_libexecdir}
387 %attr(755,root,root) %{_libexecdir}/gvfsd
388 %attr(755,root,root) %{_libexecdir}/gvfsd-burn
389 %attr(755,root,root) %{_libexecdir}/gvfsd-computer
390 %attr(755,root,root) %{_libexecdir}/gvfsd-ftp
391 %attr(755,root,root) %{_libexecdir}/gvfsd-localtest
392 %attr(755,root,root) %{_libexecdir}/gvfsd-metadata
393 %attr(755,root,root) %{_libexecdir}/gvfsd-network
394 %attr(755,root,root) %{_libexecdir}/gvfsd-sftp
395 %attr(755,root,root) %{_libexecdir}/gvfsd-trash
396 %attr(755,root,root) %{_libexecdir}/libgvfscommon.so
397 %attr(755,root,root) %{_libexecdir}/libgvfsdaemon.so
398 %{_datadir}/dbus-1/services/gvfs-daemon.service
399 %{_datadir}/dbus-1/services/gvfs-metadata.service
400 %dir %{_datadir}/gvfs
401 %dir %{_datadir}/gvfs/mounts
402 %dir %{_datadir}/gvfs/remote-volume-monitors
403 %{_datadir}/gvfs/mounts/burn.mount
404 %{_datadir}/gvfs/mounts/computer.mount
405 %{_datadir}/gvfs/mounts/ftp.mount
406 %{_datadir}/gvfs/mounts/localtest.mount
407 %{_datadir}/gvfs/mounts/network.mount
408 %{_datadir}/gvfs/mounts/sftp.mount
409 %{_datadir}/gvfs/mounts/trash.mount
410 %{_datadir}/glib-2.0/schemas/org.gnome.system.gvfs.enums.xml
411
412 # cdda
413 %if %{with cdda}
414 %attr(755,root,root) %{_libexecdir}/gvfsd-cdda
415 %{_datadir}/gvfs/mounts/cdda.mount
416 %endif
417
418 # http
419 %if %{with http}
420 %attr(755,root,root) %{_libexecdir}/gvfsd-dav
421 %attr(755,root,root) %{_libexecdir}/gvfsd-http
422 %{_datadir}/gvfs/mounts/http.mount
423 %{_datadir}/gvfs/mounts/dav.mount
424 %{?with_avahi:%{_datadir}/gvfs/mounts/dav+sd.mount}
425 %endif
426
427 # obexftp
428 %if %{with obexftp}
429 %attr(755,root,root) %{_libexecdir}/gvfsd-obexftp
430 %{_datadir}/gvfs/mounts/obexftp.mount
431 %endif
432
433 # gtk
434 %if %{with gtk}
435 %attr(755,root,root) %{_libexecdir}/gvfsd-recent
436 %{_datadir}/gvfs/mounts/recent.mount
437 %endif
438
439 # udisks2
440 %if %{with udisks2}
441 %attr(755,root,root) %{_libexecdir}/gvfs-udisks2-volume-monitor
442 %{_datadir}/dbus-1/services/org.gtk.Private.UDisks2VolumeMonitor.service
443 %{_datadir}/gvfs/remote-volume-monitors/udisks2.monitor
444 %endif
445
446 # avahi
447 %if %{with avahi}
448 %attr(755,root,root) %{_libexecdir}/gvfsd-dnssd
449 %{_datadir}/gvfs/mounts/dns-sd.mount
450 %{_datadir}/GConf/gsettings/gvfs-dns-sd.convert
451 %{_datadir}/glib-2.0/schemas/org.gnome.system.dns_sd.gschema.xml
452 %endif
453
454 %if %{with doc}
455 %{_mandir}/man1/gvfs-*.1*
456 %{_mandir}/man1/gvfsd.1*
457 %{_mandir}/man1/gvfsd-metadata.1*
458 %{_mandir}/man7/gvfs.7*
459 %endif
460
461 %files devel
462 %defattr(644,root,root,755)
463 %{_includedir}/gvfs-client
464
465 %if %{with afc}
466 %files afc
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_libexecdir}/gvfs-afc-volume-monitor
469 %attr(755,root,root) %{_libexecdir}/gvfsd-afc
470 %{_datadir}/dbus-1/services/org.gtk.Private.AfcVolumeMonitor.service
471 %{_datadir}/gvfs/mounts/afc.mount
472 %{_datadir}/gvfs/remote-volume-monitors/afc.monitor
473 %endif
474
475 %if %{with afp}
476 %files afp
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_libexecdir}/gvfsd-afp
479 %attr(755,root,root) %{_libexecdir}/gvfsd-afp-browse
480 %{_datadir}/gvfs/mounts/afp-browse.mount
481 %{_datadir}/gvfs/mounts/afp.mount
482 %endif
483
484 %if %{with archive}
485 %files archive
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_libexecdir}/gvfsd-archive
488 %{_datadir}/gvfs/mounts/archive.mount
489 %endif
490
491 %if %{with fuse}
492 %files fuse
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_libexecdir}/gvfsd-fuse
495 %if %{with doc}
496 %{_mandir}/man1/gvfsd-fuse.1*
497 %endif
498 %if %{with systemd}
499 # FIXME: reusing USE_LIBSYSTEMD_LOGIN as systemd has no universal header or pkg-config file
500 %{systemdtmpfilesdir}/gvfsd-fuse-tmpfiles.conf
501 %endif
502 %endif
503
504 %if %{with goa}
505 %files goa
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_libexecdir}/gvfs-goa-volume-monitor
508 %{_datadir}/dbus-1/services/org.gtk.Private.GoaVolumeMonitor.service
509 %{_datadir}/gvfs/remote-volume-monitors/goa.monitor
510 %endif
511
512 %if %{with gphoto2}
513 %files gphoto2
514 %defattr(644,root,root,755)
515 %attr(755,root,root) %{_libexecdir}/gvfs-gphoto2-volume-monitor
516 %attr(755,root,root) %{_libexecdir}/gvfsd-gphoto2
517 %{_datadir}/dbus-1/services/org.gtk.Private.GPhoto2VolumeMonitor.service
518 %{_datadir}/gvfs/mounts/gphoto2.mount
519 %{_datadir}/gvfs/remote-volume-monitors/gphoto2.monitor
520 %endif
521
522 %if %{with mtp}
523 %files mtp
524 %defattr(644,root,root,755)
525 %attr(755,root,root) %{_libexecdir}/gvfs-mtp-volume-monitor
526 %attr(755,root,root) %{_libexecdir}/gvfsd-mtp
527 %{_datadir}/dbus-1/services/org.gtk.Private.MTPVolumeMonitor.service
528 %{_datadir}/gvfs/mounts/mtp.mount
529 %{_datadir}/gvfs/remote-volume-monitors/mtp.monitor
530 %endif
531
532 %if %{with samba}
533 %files smb
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libexecdir}/gvfsd-smb
536 %attr(755,root,root) %{_libexecdir}/gvfsd-smb-browse
537 %{_datadir}/gvfs/mounts/smb-browse.mount
538 %{_datadir}/gvfs/mounts/smb.mount
539 %{_datadir}/glib-2.0/schemas/org.gnome.system.smb.gschema.xml
540 %{_datadir}/GConf/gsettings/gvfs-smb.convert
541 %endif
542
543 %files -n bash-completion-gvfs
544 %defattr(644,root,root,755)
545 %{_datadir}/bash-completion/completions/gvfs
This page took 0.058586 seconds and 3 git commands to generate.