]> git.pld-linux.org Git - packages/gupnp.git/blob - gupnp.spec
- updated to 0.20.3
[packages/gupnp.git] / gupnp.spec
1 #
2 # Conditional build:
3 %bcond_without  vala    # Vala API
4 #
5 Summary:        UPnP library based on GObject and libsoup
6 Summary(pl.UTF-8):      Biblioteka UPnP oparta na bibliotekach GObject i libsoup
7 Name:           gupnp
8 # note: 0.20.x is stable, 0.21.x unstable
9 Version:        0.20.3
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gupnp/0.20/%{name}-%{version}.tar.xz
14 # Source0-md5:  b727f0dae0711825e8cdd01616973b86
15 URL:            http://gupnp.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  docbook-dtd44-xml
20 BuildRequires:  glib2-devel >= 1:2.26.0
21 BuildRequires:  gobject-introspection-devel >= 1.36.0
22 BuildRequires:  gssdp-devel >= 0.13.0
23 BuildRequires:  gtk-doc >= 1.0
24 BuildRequires:  libsoup-devel >= 2.28.2
25 BuildRequires:  libtool >= 2:2.2
26 BuildRequires:  libuuid-devel >= 1.36
27 BuildRequires:  libxml2-devel >= 1:2.6.30
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  tar >= 1:1.22
31 %{?with_vala:BuildRequires:     vala >= 2:0.20}
32 %{?with_vala:BuildRequires:     vala-gssdp >= 0.13.0}
33 BuildRequires:  xz
34 Requires:       glib2 >= 1:2.26.0
35 Requires:       gssdp >= 0.13.0
36 Requires:       libsoup >= 2.28.2
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 GUPnP is an object-oriented open source framework for creating UPnP
41 devices and control points, written in C using GObject and libsoup.
42 The GUPnP API is intended to be easy to use, efficient and flexible.
43
44 %description -l pl.UTF-8
45 GUPnp to zorientowany obiektowo, mający otwarte źródła szkielet do
46 tworzenia urządzeń i punktów sterujących UPnP, napisany w C z użyciem
47 bibliotek GObject i libsoup. API GUPnp ma być łatwe w użyciu, wydajne
48 i elastyczne.
49
50 %package devel
51 Summary:        Header files for gupnp
52 Summary(pl.UTF-8):      Pliki nagłówkowe gupnp
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       glib2-devel >= 1:2.26.0
56 Requires:       gssdp-devel >= 0.13.0
57 Requires:       libsoup-devel >= 2.28.2
58 Requires:       libuuid-devel >= 1.36
59 Requires:       libxml2-devel >= 1:2.6.30
60
61 %description devel
62 This package contains header files for the Linux SDK for UPnP Devices
63 (gupnp).
64
65 %description devel -l pl.UTF-8
66 Ten pakiet zawiera pliki nagłówkowe dla linuksowego pakietu
67 programistycznego do urządzeń UPnP (gupnp).
68
69 %package static
70 Summary:        Static gupnp libraries
71 Summary(pl.UTF-8):      Statyczne biblioteki gupnp
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static gupnp libraries.
77
78 %description static -l pl.UTF-8
79 Statyczne biblioteki gupnp.
80
81 %package apidocs
82 Summary:        gupnp API documentation
83 Summary(pl.UTF-8):      Dokumentacja API gupnp
84 Group:          Documentation
85 Requires:       gtk-doc-common
86
87 %description apidocs
88 gupnp API documentation.
89
90 %description apidocs -l pl.UTF-8
91 Dokumentacja API gupnp.
92
93 %package -n vala-gupnp
94 Summary:        Vala API for gupnp library
95 Summary(pl.UTF-8):      API języka Vala dla biblioteki gupnp
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Requires:       vala >= 2:0.20
99 Requires:       vala-gssdp >= 0.13.0
100
101 %description -n vala-gupnp
102 Vala API for gupnp library.
103
104 %description -n vala-gupnp -l pl.UTF-8
105 API języka Vala dla biblioteki gupnp.
106
107 %prep
108 %setup -q
109
110 %build
111 %{__gtkdocize}
112 %{__libtoolize}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         --disable-silent-rules \
119         --enable-gtk-doc \
120         --with-html-dir=%{_gtkdocdir} \
121         --with-context-manager=network-manager
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog NEWS README
142 %attr(755,root,root) %{_bindir}/gupnp-binding-tool
143 %attr(755,root,root) %{_libdir}/libgupnp-1.0.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libgupnp-1.0.so.4
145 %{_libdir}/girepository-1.0/GUPnP-1.0.typelib
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/libgupnp-1.0.so
150 %{_datadir}/gir-1.0/GUPnP-1.0.gir
151 %{_includedir}/gupnp-1.0
152 %{_pkgconfigdir}/gupnp-1.0.pc
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libgupnp-1.0.a
157
158 %files apidocs
159 %defattr(644,root,root,755)
160 %{_gtkdocdir}/gupnp
161
162 %if %{with vala}
163 %files -n vala-gupnp
164 %defattr(644,root,root,755)
165 %{_datadir}/vala/vapi/gupnp-1.0.deps
166 %{_datadir}/vala/vapi/gupnp-1.0.vapi
167 %endif
This page took 0.077041 seconds and 3 git commands to generate.