]> git.pld-linux.org Git - SPECS.git/blob - gtksourceviewmm3.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / gtksourceviewmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # don't generate documentation with doxygen
4 %bcond_without  static_libs     # static library
5
6 Summary:        A C++ binding of GtkSourceView3
7 Summary(pl.UTF-8):      Wiązania C++ dla GtkSourceView3
8 Name:           gtksourceviewmm3
9 Version:        3.18.0
10 Release:        1
11 License:        LGPL v2+
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceviewmm/3.18/gtksourceviewmm-%{version}.tar.xz
14 # Source0-md5:  f00bc014a01299c77e1ebf7b932aad9b
15 URL:            http://www.gnome.org/projects/gtksourceviewmm/
16 BuildRequires:  atkmm-devel >= 1.6
17 BuildRequires:  autoconf >= 2.62
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  cairomm-devel >= 1.0
20 %{?with_apidocs:BuildRequires:  doxygen}
21 BuildRequires:  glibmm-devel >= 2.46.1
22 BuildRequires:  gtkmm3-devel >= 3.18.0
23 BuildRequires:  gtksourceview3-devel >= 3.18.0
24 BuildRequires:  libsigc++-devel
25 BuildRequires:  libtool
26 BuildRequires:  mm-common >= 0.9.8
27 BuildRequires:  pangomm-devel >= 1.4
28 BuildRequires:  pkgconfig
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       glibmm >= 2.46.1
32 Requires:       gtkmm3 >= 3.18.0
33 Requires:       gtksourceview3 >= 3.18.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 GtkSourceViewMM3 is a C++ binding of GtkSourceView3, an extension to
38 the text widget included in GTK+ 3.x adding syntax highlighting and
39 other features typical for a source file editor.
40
41 %description -l pl.UTF-8
42 GtkSourceViewMM3 to wiązania C++ dla GtkSourceView3 - rozszerzenia
43 tekstowego widgetu będącego częścią GTK+ 3.x, dodającego kolorowanie
44 składni oraz inne właściwości typowe dla edytora kodu źródłowego.
45
46 %package devel
47 Summary:        Header files for GtkSourceViewMM3 library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GtkSourceViewMM3
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       glibmm-devel >= 2.46.1
52 Requires:       gtkmm3-devel >= 3.18.0
53 Requires:       gtksourceview3-devel >= 3.18.0
54
55 %description devel
56 Header files for GtkSourceViewMM3 library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki GtkSourceViewMM3.
60
61 %package static
62 Summary:        Static GtkSourceViewMM3 library
63 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceViewMM3
64 Group:          X11/Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static GtkSourceViewMM3 library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka GtkSourceViewMM3.
72
73 %package apidocs
74 Summary:        GtkSourceViewMM3 API documentation
75 Summary(pl.UTF-8):      Dokumentacja API GtkSourceViewMM3
76 Group:          Documentation
77 BuildArch:      noarch
78
79 %description apidocs
80 GtkSourceViewMM3 API documentation.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API GtkSourceViewMM3.
84
85 %prep
86 %setup -q -n gtksourceviewmm-%{version}
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I build
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         %{__enable_disable apidocs documentation} \
96         --disable-silent-rules \
97         %{?with_static_libs:--enable-static}
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog NEWS README
116 %attr(755,root,root) %{_libdir}/libgtksourceviewmm-3.0.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libgtksourceviewmm-3.0.so.0
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libgtksourceviewmm-3.0.so
122 %{_libdir}/gtksourceviewmm-3.0
123 %{_includedir}/gtksourceviewmm-3.0
124 %{_pkgconfigdir}/gtksourceviewmm-3.0.pc
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libgtksourceviewmm-3.0.a
130 %endif
131
132 %if %{with apidocs}
133 %files apidocs
134 %defattr(644,root,root,755)
135 %{_datadir}/devhelp/books/gtksourceviewmm-3.0
136 %{_docdir}/gtksourceviewmm-3.0
137 %endif
This page took 0.221381 seconds and 3 git commands to generate.