]> git.pld-linux.org Git - packages/gtkmm3.git/blob - gtkmm3.spec
- updated to 3.24.9
[packages/gtkmm3.git] / gtkmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         atkmm_ver       2.24.2
6 %define         glibmm_ver      2.54.0
7 %define         gtk3_ver        3.24.0
8 %define         pangomm_ver     2.38.2
9 Summary:        A C++ interface for the GTK+ (a GUI library for X)
10 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
11 Name:           gtkmm3
12 Version:        3.24.9
13 Release:        1
14 License:        LGPL v2+
15 Group:          X11/Libraries
16 Source0:        https://download.gnome.org/sources/gtkmm/3.24/gtkmm-%{version}.tar.xz
17 # Source0-md5:  47871a7973e186c1189b2145b507de15
18 URL:            https://www.gtkmm.org/
19 BuildRequires:  atkmm-devel >= %{atkmm_ver}
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake >= 1:1.11
22 BuildRequires:  cairomm-devel >= 1.12.0
23 BuildRequires:  doxygen >= 1:1.8.9
24 BuildRequires:  gdk-pixbuf2-devel >= 2.36.0
25 BuildRequires:  glibmm-devel >= %{glibmm_ver}
26 BuildRequires:  graphviz
27 BuildRequires:  gtk+3-devel >= %{gtk3_ver}
28 BuildRequires:  libepoxy-devel >= 1.2
29 BuildRequires:  libsigc++-devel
30 BuildRequires:  libstdc++-devel >= 6:4.7
31 BuildRequires:  libtool >= 2:2.0
32 BuildRequires:  libxslt-progs
33 BuildRequires:  mm-common >= 0.9.10
34 BuildRequires:  pangomm-devel >= %{pangomm_ver}
35 BuildRequires:  perl-base >= 1:5.6.0
36 BuildRequires:  pkgconfig
37 BuildRequires:  rpm-build >= 4.6
38 BuildRequires:  rpmbuild(macros) >= 1.752
39 BuildRequires:  tar >= 1:1.22
40 BuildRequires:  xz
41 Requires:       atkmm >= %{atkmm_ver}
42 Requires:       cairomm >= 1.12.0
43 Requires:       gdk-pixbuf2 >= 2.36.0
44 Requires:       glibmm >= %{glibmm_ver}
45 Requires:       gtk+3 >= %{gtk3_ver}
46 Requires:       pangomm >= %{pangomm_ver}
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
51 library. The interface provides a convenient interface for C++
52 programmers to create GUIs with GTK+'s flexible object-oriented
53 framework. Features include type safe callbacks, widgets that are
54 extensible using inheritance and over 110 classes that can be freely
55 combined to quickly create complex user interfaces.
56
57 %description -l pl.UTF-8
58 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
59 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
60 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
61
62 %package devel
63 Summary:        gtkmm and gdkmm header files
64 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
65 Group:          X11/Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       atkmm-devel >= %{atkmm_ver}
68 Requires:       cairomm-devel >= 1.12.0
69 Requires:       gdk-pixbuf2-devel >= 2.36.0
70 Requires:       glibmm-devel >= %{glibmm_ver}
71 Requires:       gtk+3-devel >= %{gtk3_ver}
72 Requires:       libstdc++-devel >= 6:4.6
73 Requires:       pangomm-devel >= %{pangomm_ver}
74
75 %description devel
76 Header files for gtkmm library.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe biblioteki gtkmm.
80
81 %package static
82 Summary:        gtkmm and gdkmm static libraries
83 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
84 Group:          X11/Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 gtkmm and gdkmm static libraries.
89
90 %description static -l pl.UTF-8
91 Biblioteki statyczne gtkmm i gdkmm.
92
93 %package apidocs
94 Summary:        Reference documentation for gtkmm and gdkmm
95 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
96 Group:          Documentation
97 Requires:       devhelp
98 BuildArch:      noarch
99
100 %description apidocs
101 Reference documentation for gtkmm and gdkmm.
102
103 %description apidocs -l pl.UTF-8
104 Szczegółowa dokumentacja gtkmm i gdkmm.
105
106 %prep
107 %setup -q -n gtkmm-%{version}
108
109 # missing in release tarball, not needed for Linux
110 mkdir win32_installer
111 touch win32_installer/filelist.am \
112         win32_installer/gtkmm-installer.nsi.in
113
114 %build
115 mm-common-prepare --copy --force
116 %{__libtoolize}
117 %{__aclocal} -I build
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 %configure \
122         --enable-maintainer-mode \
123         --disable-silent-rules \
124         %{?with_static_libs:--enable-static}
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc ChangeLog NEWS README.md
145 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
147 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
153 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
154 %{_libdir}/gdkmm-3.0
155 %{_libdir}/gtkmm-3.0
156 %{_includedir}/gdkmm-3.0
157 %{_includedir}/gtkmm-3.0
158 %{_pkgconfigdir}/gdkmm-3.0.pc
159 %{_pkgconfigdir}/gtkmm-3.0.pc
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libgdkmm-3.0.a
165 %{_libdir}/libgtkmm-3.0.a
166 %endif
167
168 %files apidocs
169 %defattr(644,root,root,755)
170 %{_docdir}/gtkmm-3.0
171 %{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.114513 seconds and 3 git commands to generate.