]> git.pld-linux.org Git - SPECS.git/blob - gtkmm.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / gtkmm.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        A C++ interface for the GTK+ (a GUI library for X)
6 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
7 Name:           gtkmm
8 Version:        2.24.5
9 Release:        1
10 License:        LGPL v2+
11 Group:          X11/Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.24/%{name}-%{version}.tar.xz
13 # Source0-md5:  6c59ae8bbff48fad9132f23af347acf1
14 URL:            http://www.gtkmm.org/
15 BuildRequires:  atkmm-devel >= 2.22.2
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  cairomm-devel >= 1.6.3
19 BuildRequires:  glibmm-devel >= 2.28.0
20 BuildRequires:  gtk+2-devel >= 2:2.24.0
21 BuildRequires:  libsigc++-devel
22 BuildRequires:  libstdc++-devel >= 5:3.3.1
23 BuildRequires:  libtool >= 2:1.4d-3
24 BuildRequires:  mm-common >= 0.9.8
25 BuildRequires:  pangomm-devel >= 2.28.0
26 BuildRequires:  perl-base >= 1:5.6.0
27 BuildRequires:  pkgconfig
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 Requires:       atkmm >= 2.22.2
31 Requires:       cairomm >= 1.6.3
32 Requires:       glibmm >= 2.28.0
33 Requires:       gtk+2 >= 2:2.24.0
34 Requires:       pangomm >= 2.28.0
35 Obsoletes:      Gtk--
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
40 library. The interface provides a convenient interface for C++
41 programmers to create GUIs with GTK+'s flexible object-oriented
42 framework. Features include type safe callbacks, widgets that are
43 extensible using inheritance and over 110 classes that can be freely
44 combined to quickly create complex user interfaces.
45
46 %description -l pl.UTF-8
47 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
48 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
49 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
50
51 %package devel
52 Summary:        gtkmm and gdkmm header files
53 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       atkmm-devel >= 2.22.2
57 Requires:       glibmm-devel >= 2.28.0
58 Requires:       gtk+2-devel >= 2:2.24.0
59 Requires:       pangomm-devel >= 2.28.0
60
61 %description devel
62 Header files for gtkmm library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki gtkmm.
66
67 %package static
68 Summary:        gtkmm and gdkmm static libraries
69 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
70 Group:          X11/Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 gtkmm and gdkmm static libraries.
75
76 %description static -l pl.UTF-8
77 Biblioteki statyczne gtkmm i gdkmm.
78
79 %package apidocs
80 Summary:        Reference documentation for gtkmm and gdkmm
81 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
82 Group:          Documentation
83 Requires:       devhelp
84 Obsoletes:      gtkmm-doc
85 BuildArch:      noarch
86
87 %description apidocs
88 Reference documentation for gtkmm and gdkmm.
89
90 %description apidocs -l pl.UTF-8
91 Szczegółowa dokumentacja gtkmm i gdkmm.
92
93 %prep
94 %setup -q
95
96 %build
97 %{__libtoolize}
98 %{__aclocal} -I build
99 %{__autoconf}
100 %{__autoheader}
101 %{__automake}
102 %configure \
103         %{?with_static_libs:--enable-static}
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog NEWS PORTING README
124 %attr(755,root,root) %{_libdir}/libgdkmm-2.4.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-2.4.so.1
126 %attr(755,root,root) %{_libdir}/libgtkmm-2.4.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-2.4.so.1
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libgdkmm-2.4.so
132 %attr(755,root,root) %{_libdir}/libgtkmm-2.4.so
133 %{_libdir}/gdkmm-2.4
134 %{_libdir}/gtkmm-2.4
135 %{_includedir}/gdkmm-2.4
136 %{_includedir}/gtkmm-2.4
137 %{_pkgconfigdir}/gdkmm-2.4.pc
138 %{_pkgconfigdir}/gtkmm-2.4.pc
139
140 %if %{with static_libs}
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libgdkmm-2.4.a
144 %{_libdir}/libgtkmm-2.4.a
145 %endif
146
147 %files apidocs
148 %defattr(644,root,root,755)
149 %{_docdir}/gtkmm-2.4
150 %{_datadir}/devhelp/books/gtkmm-2.4
This page took 1.021592 seconds and 3 git commands to generate.