]> git.pld-linux.org Git - packages/gtk-vnc.git/blob - gtk-vnc.spec
- updated to 0.4.2
[packages/gtk-vnc.git] / gtk-vnc.spec
1 Summary:        A GTK+ widget for VNC clients
2 Summary(pl.UTF-8):      Widget GTK+ dla klientów VNC
3 Name:           gtk-vnc
4 Version:        0.4.2
5 Release:        1
6 License:        LGPL v2
7 Group:          X11/Libraries
8 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtk-vnc/0.4/%{name}-%{version}.tar.bz2
9 # Source0-md5:  68fdeb71844c49d5d5ab4f32cbc8bddb
10 Patch0:         %{name}-codegen.patch
11 URL:            http://live.gnome.org/gtk-vnc
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.10
14 BuildRequires:  cyrus-sasl-devel
15 BuildRequires:  gettext-devel
16 BuildRequires:  gnome-common
17 BuildRequires:  gnutls-devel >= 1.4.0
18 BuildRequires:  gobject-introspection-devel >= 0.9.4
19 BuildRequires:  gtk+2-devel >= 2:2.18.0
20 BuildRequires:  intltool >= 0.40.0
21 BuildRequires:  libtool
22 BuildRequires:  perl-Text-CSV
23 BuildRequires:  pkgconfig
24 BuildRequires:  python-devel >= 1:2.4
25 BuildRequires:  python-pygtk-devel >= 2:2.0.0
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 gtk-vnc is a VNC viewer widget for GTK+. It is built using coroutines
32 allowing it to be completely asynchronous while remaining single
33 threaded.
34
35 %description -l pl.UTF-8
36 gtk-vnc to widget przeglądarki VNC dla GTK+. Jest skonstruowany z
37 użyciem korutyn, dzięki czemu mogą być w pełni asynchroniczne
38 pozostając jednowątkowymi.
39
40 %package devel
41 Summary:        Header files for gtk-vnc library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gtk-vnc
43 Group:          X11/Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       gnutls-devel >= 1.4.0
46 Requires:       gtk+2-devel >= 2:2.18.0
47
48 %description devel
49 Header files for gtk-vnc library.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe biblioteki gtk-vnc.
53
54 %package static
55 Summary:        Static gtk-vnc library
56 Summary(pl.UTF-8):      Statyczna biblioteka gtk-vnc
57 Group:          X11/Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static gtk-vnc library.
62
63 %description static -l pl.UTF-8
64 Statyczna biblioteka gtk-vnc.
65
66 %package -n python-gtk-vnc
67 Summary:        Python bindings for the gtk-vnc library
68 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki gtk-vnc
69 Group:          Libraries/Python
70 Requires:       %{name} = %{version}-%{release}
71 %requires_eq    python-libs
72
73 %description -n python-gtk-vnc
74 A module allowing use of the GTK+ VNC widget from Python.
75
76 %description -n python-gtk-vnc -l pl.UTF-8
77 Moduł pozwalający na używanie widgetu GTK+ VNC z poziomu Pythona.
78
79 %package tools
80 Summary:        Command line tools for VNC
81 Summary(pl.UTF-8):      Narzędzia linii poleceń dla VNC
82 Group:          Applications/Networking
83 Requires:       %{name} = %{version}-%{release}
84
85 %description tools
86 Command line utilities for interacting with VNC servers.
87
88 %description tools -l pl.UTF-8
89 Narzędzia linii poleceń do interakcji z serwerami VNC.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 %{__libtoolize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --enable-static \
103         --disable-silent-rules
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} -j1 install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
113         $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
114
115 install examples/gvncviewer.{c,js} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
116 install examples/gvncviewer.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
117
118 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
119
120 %find_lang %{name}
121
122 %clean
123 rm -fr $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc AUTHORS ChangeLog NEWS README
131 %attr(755,root,root) %{_libdir}/libgtk-vnc-1.0.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libgtk-vnc-1.0.so.0
133 %attr(755,root,root) %{_libdir}/libgvnc-1.0.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libgvnc-1.0.so.0
135 %{_libdir}/girepository-1.0/GVnc-1.0.typelib
136 %{_libdir}/girepository-1.0/GtkVnc-1.0.typelib
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libgtk-vnc-1.0.so
141 %attr(755,root,root) %{_libdir}/libgvnc-1.0.so
142 %{_libdir}/libgtk-vnc-1.0.la
143 %{_libdir}/libgvnc-1.0.la
144 %{_includedir}/%{name}-1.0
145 %{_includedir}/gvnc-1.0
146 %{_datadir}/gir-1.0/GVnc-1.0.gir
147 %{_datadir}/gir-1.0/GtkVnc-1.0.gir
148 %{_pkgconfigdir}/%{name}-1.0.pc
149 %{_pkgconfigdir}/gvnc-1.0.pc
150 %{_examplesdir}/%{name}-%{version}
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libgtk-vnc-1.0.a
155 %{_libdir}/libgvnc-1.0.a
156
157 %files -n python-gtk-vnc
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{py_sitedir}/gtkvnc.so
160 %{_examplesdir}/python-%{name}-%{version}
161
162 %files tools
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/gvnccapture
165 %{_mandir}/man1/gvnccapture.1*
This page took 0.149417 seconds and 4 git commands to generate.