]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- up to version 0.8.1
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl):    GStreamer - biblioteki ¶rodowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.8.1
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.8/%{name}-%{version}.tar.bz2
9 # Source0-md5:  154c95169f343b53f15cc5a124ef673d
10 Patch0:         %{name}-without_ps_pdf.patch
11 Patch1:         %{name}-docs.patch
12 URL:            http://gstreamer.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  ghostscript
18 BuildRequires:  glib2-devel >= 1:2.4.0
19 BuildRequires:  gtk-doc >= 1.0
20 BuildRequires:  libtool
21 BuildRequires:  libxml2-devel >= 2.4.17
22 BuildRequires:  nasm
23 BuildRequires:  perl-base
24 BuildRequires:  pkgconfig
25 BuildRequires:  popt-devel >= 1.6.3
26 BuildRequires:  transfig
27 BuildRequires:  xmlto
28 Requires(post): /sbin/ldconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _gstlibdir      %{_libdir}/gstreamer-0.8
32 %define         _gstincludedir  %{_includedir}/gstreamer-0.8
33 %define         _gstcachedir    %{_var}/cache/gstreamer
34
35 %description
36 GStreamer is a streaming-media framework, based on graphs of filters
37 which operate on media data. Applications using this library can do
38 anything from real-time sound processing to playing videos, and just
39 about anything else media-related. Its plugin-based architecture means
40 that new data types or processing capabilities can be added simply by
41 installing new plugins.
42
43 %description -l pl
44 GStreamer to ¶rodowisko obróbki danych strumieniowych, bazuj±ce na
45 grafie filtrów operuj±cych na danych medialnych. Aplikacje u¿ywaj±ce
46 tej biblioteki mog± robiæ wszystko od przetwarzania d¼wiêku w czasie
47 rzeczywistym, do odtwarzania filmów i czegokolwiek innego zwi±zego z
48 mediami. Architektura bazuj±ca na wtyczkach pozwala na ³atwe dodawanie
49 nowych typów danych lub mo¿liwo¶ci obróbki.
50
51 %package devel
52 Summary:        Include files for GStreamer streaming-media framework
53 Summary(pl):    Pliki nag³ówkowe do ¶rodowiska obróbki strumieni GStreamer
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       glib2-devel >= 1:2.4.0
57 Requires:       libxml2-devel >= 2.4.17
58 Requires:       popt-devel >= 1.6.3
59
60 %description devel
61 This package contains the includes files necessary to develop
62 applications and plugins for GStreamer.
63
64 %description devel -l pl
65 Ten pakiet zawiera pliki nag³ówkowe potrzebne do rozwijania aplikacji
66 i wtyczek do GStreamera.
67
68 %package static
69 Summary:        GStreamer static libraries
70 Summary(pl):    Biblioteki statyczne GStreamer
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static versions of GStreamer libraries.
76
77 %description static -l pl
78 Statyczne wersje bibliotek GStreamer.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84
85 %build
86 intltoolize --copy --force
87 %{__gettextize}
88 %{__libtoolize}
89 %{__aclocal} -I common/m4
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93
94 %configure \
95         --program-suffix="" \
96 %ifarch i586 i686 athlon
97         --enable-fast-stack-trash \
98 %else
99         --disable-fast-stack-trash \
100 %endif
101         --enable-glib2 \
102         --enable-libmmx \
103         --enable-atomic \
104         --disable-examples \
105         --disable-tests \
106         --disable-debug \
107         --disable-debug-color \
108         --enable-docs-build \
109         --with-html-dir=%{_gtkdocdir} \
110         --with-cachedir=%{_gstcachedir}
111         
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT{%{_gstcachedir},%{_docdir}/%{name}-devel-%{version}}
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 touch $RPM_BUILD_ROOT%{_gstcachedir}/registry.xml
122
123 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
124         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
125
126 %find_lang %{name} --all-name --with-gnome
127
128 # no static modules and *.la for them - shut up check files
129 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 /sbin/ldconfig
136 %{_bindir}/gst-register --gst-registry=%{_gstcachedir}/registry.xml > /dev/null 2> /dev/null
137
138 %postun -p /sbin/ldconfig
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README TODO
143 %attr(755,root,root) %{_bindir}/*
144 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
145 %dir %{_gstlibdir}
146 %attr(755,root,root) %{_gstlibdir}/*.so
147 %dir %{_gstcachedir}
148 %ghost %{_gstcachedir}/registry.xml
149 %{_mandir}/man1/*
150
151 %files devel
152 %defattr(644,root,root,755)
153 %doc DEVEL
154 %attr(755,root,root) %{_libdir}/lib*.so
155 %{_libdir}/lib*.la
156 %{_gstincludedir}
157 %{_gtkdocdir}/*
158 %{_pkgconfigdir}/*
159 %{_aclocaldir}/*
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/lib*.a
This page took 0.038115 seconds and 4 git commands to generate.