]> git.pld-linux.org Git - packages/gstreamer.git/blob - gstreamer.spec
- macros.gstreamer moved to rpm.spec
[packages/gstreamer.git] / gstreamer.spec
1 Summary:        GStreamer Streaming-media framework runtime
2 Summary(pl.UTF-8):      GStreamer - biblioteki środowiska do obróbki strumieni
3 Name:           gstreamer
4 Version:        0.10.22
5 Release:        2
6 License:        LGPL v2+
7 Group:          Libraries
8 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/%{name}-%{version}.tar.bz2
9 # Source0-md5:  35dd8598837af4074753afe5b59e8ef2
10 Source1:        %{name}-rpmdeps.sh
11 Patch0:         %{name}-without_ps_pdf.patch
12 Patch1:         %{name}-eps.patch
13 Patch2:         %{name}-inspect-rpm-format.patch
14 URL:            http://gstreamer.net/
15 BuildRequires:  autoconf >= 2.52
16 BuildRequires:  automake >= 1.6
17 BuildRequires:  bison >= 1.35
18 BuildRequires:  check >= 0.9.3-2
19 BuildRequires:  docbook-utils >= 0.6.10
20 BuildRequires:  flex
21 BuildRequires:  gettext-devel >= 0.11.5
22 BuildRequires:  glib2-devel >= 1:2.12.0
23 BuildRequires:  gtk-doc >= 1.6
24 BuildRequires:  libtool >= 1.4
25 BuildRequires:  libxml2-devel >= 1:2.6.26
26 BuildRequires:  nasm
27 BuildRequires:  perl-base
28 BuildRequires:  pkgconfig >= 1:0.9.0
29 BuildRequires:  popt-devel >= 1.6.3
30 # not sure it is a right place for this BR
31 BuildRequires:  python-PyXML
32 BuildRequires:  transfig
33 BuildRequires:  xmlto
34 Requires:       glib2 >= 1:2.12.0
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         vmajor          %(echo %{version} | cut -d. -f1,2)
38 %define         _gstlibdir      %{_libdir}/gstreamer-%{vmajor}
39 %define         _gstincludedir  %{_includedir}/gstreamer-%{vmajor}
40
41 %define         rpmlibdir       /usr/lib/rpm
42
43 %description
44 GStreamer is a streaming-media framework, based on graphs of filters
45 which operate on media data. Applications using this library can do
46 anything from real-time sound processing to playing videos, and just
47 about anything else media-related. Its plugin-based architecture means
48 that new data types or processing capabilities can be added simply by
49 installing new plugins.
50
51 %description -l pl.UTF-8
52 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
53 grafie filtrów operujących na danych medialnych. Aplikacje używające
54 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
55 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
56 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
57 nowych typów danych lub możliwości obróbki.
58
59 %package devel
60 Summary:        Include files for GStreamer streaming-media framework
61 Summary(pl.UTF-8):      Pliki nagłówkowe do środowiska obróbki strumieni GStreamer
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       glib2-devel >= 1:2.12.0
65 Requires:       libxml2-devel >= 1:2.6.26
66 Requires:       popt-devel >= 1.6.3
67
68 %description devel
69 This package contains the includes files necessary to develop
70 applications and plugins for GStreamer.
71
72 %description devel -l pl.UTF-8
73 Ten pakiet zawiera pliki nagłówkowe potrzebne do rozwijania aplikacji
74 i wtyczek do GStreamera.
75
76 %package static
77 Summary:        GStreamer static libraries
78 Summary(pl.UTF-8):      Biblioteki statyczne GStreamer
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static versions of GStreamer libraries.
84
85 %description static -l pl.UTF-8
86 Statyczne wersje bibliotek GStreamer.
87
88 %package apidocs
89 Summary:        GStreamer API documentation
90 Summary(pl.UTF-8):      Dokumentacja API Gstreamera
91 Group:          Documentation
92 Requires:       gtk-doc-common
93
94 %description apidocs
95 GStreamer API documentation.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API Gstreamera.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105
106 %build
107 # po/Makefile.in.in is modified
108 #{__gettextize}
109 %{__libtoolize}
110 %{__aclocal} -I common/m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --disable-examples \
116         --disable-pspdf \
117         --disable-tests \
118         --enable-docbook \
119         --enable-gtk-doc \
120         --with-html-dir=%{_gtkdocdir}
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT{%{_docdir}/%{name}-devel-%{version},%{rpmlibdir}}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install %{SOURCE1} $RPM_BUILD_ROOT%{rpmlibdir}/gstreamerdeps.sh
132
133 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-{%{vmajor},%{version}}
134 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/{manual,pwg} \
135         $RPM_BUILD_ROOT%{_docdir}/%{name}-devel-%{version}
136
137 %find_lang %{name} --all-name --with-gnome
138
139 # no static modules and *.la for them - shut up check files
140 rm -f $RPM_BUILD_ROOT%{_gstlibdir}/lib*.{la,a}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README TODO
151 %attr(755,root,root) %{_bindir}/gst-*
152 %attr(755,root,root) %{_libdir}/libgstbase-0.10.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libgstbase-0.10.so.0
154 %attr(755,root,root) %{_libdir}/libgstcheck-0.10.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libgstcheck-0.10.so.0
156 %attr(755,root,root) %{_libdir}/libgstcontroller-0.10.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libgstcontroller-0.10.so.0
158 %attr(755,root,root) %{_libdir}/libgstdataprotocol-0.10.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libgstdataprotocol-0.10.so.0
160 %attr(755,root,root) %{_libdir}/libgstnet-0.10.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/libgstnet-0.10.so.0
162 %attr(755,root,root) %{_libdir}/libgstreamer-0.10.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libgstreamer-0.10.so.0
164 %dir %{_gstlibdir}
165 %attr(755,root,root) %{_gstlibdir}/libgstcoreelements.so
166 %attr(755,root,root) %{_gstlibdir}/libgstcoreindexers.so
167 %{_mandir}/man1/gst-*.1*
168
169 %files devel
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_libdir}/libgstbase-0.10.so
172 %attr(755,root,root) %{_libdir}/libgstcheck-0.10.so
173 %attr(755,root,root) %{_libdir}/libgstcontroller-0.10.so
174 %attr(755,root,root) %{_libdir}/libgstdataprotocol-0.10.so
175 %attr(755,root,root) %{_libdir}/libgstnet-0.10.so
176 %attr(755,root,root) %{_libdir}/libgstreamer-0.10.so
177 %{_libdir}/libgstbase-0.10.la
178 %{_libdir}/libgstcheck-0.10.la
179 %{_libdir}/libgstcontroller-0.10.la
180 %{_libdir}/libgstdataprotocol-0.10.la
181 %{_libdir}/libgstnet-0.10.la
182 %{_libdir}/libgstreamer-0.10.la
183 %{_docdir}/%{name}-devel-%{version}
184 %{_gstincludedir}
185 %{_pkgconfigdir}/gstreamer-0.10.pc
186 %{_pkgconfigdir}/gstreamer-base-0.10.pc
187 %{_pkgconfigdir}/gstreamer-check-0.10.pc
188 %{_pkgconfigdir}/gstreamer-controller-0.10.pc
189 %{_pkgconfigdir}/gstreamer-dataprotocol-0.10.pc
190 %{_pkgconfigdir}/gstreamer-net-0.10.pc
191 %{_aclocaldir}/gst-element-check-0.10.m4
192 %attr(755,root,root) %{rpmlibdir}/gstreamerdeps.sh
193
194 %files static
195 %defattr(644,root,root,755)
196 %{_libdir}/libgstbase-0.10.a
197 %{_libdir}/libgstcheck-0.10.a
198 %{_libdir}/libgstcontroller-0.10.a
199 %{_libdir}/libgstdataprotocol-0.10.a
200 %{_libdir}/libgstnet-0.10.a
201 %{_libdir}/libgstreamer-0.10.a
202
203 %files apidocs
204 %defattr(644,root,root,755)
205 %{_gtkdocdir}/gstreamer-0.10
206 %{_gtkdocdir}/gstreamer-libs-0.10
207 %{_gtkdocdir}/gstreamer-plugins-0.10
This page took 0.041181 seconds and 4 git commands to generate.