]> git.pld-linux.org Git - packages/gstreamer-plugins-ugly.git/blob - gstreamer-plugins-ugly.spec
- updated to 1.18.4, uses meson and hotdoc now
[packages/gstreamer-plugins-ugly.git] / gstreamer-plugins-ugly.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  amr             # AMR-NB/AMR-WB plugins
5 %bcond_without  cdio            # cdio plugin
6 %bcond_without  sid             # sid plugin
7
8 %define         gstname         gst-plugins-ugly
9 %define         gstmver         1.0
10 %define         gst_ver         1.18.4
11 %define         gstpb_ver       1.18.4
12
13 Summary:        Ugly GStreamer Streaming-media framework plugins
14 Summary(pl.UTF-8):      Brzydkie wtyczki do środowiska obróbki strumieni GStreamer
15 Name:           gstreamer-plugins-ugly
16 Version:        1.18.4
17 Release:        1
18 License:        LGPL v2+
19 Group:          Libraries
20 Source0:        https://gstreamer.freedesktop.org/src/gst-plugins-ugly/%{gstname}-%{version}.tar.xz
21 # Source0-md5:  e5fbd9a8a05632cfb9d0afd0ad856d52
22 URL:            https://gstreamer.freedesktop.org/
23 BuildRequires:  docbook-dtd412-xml
24 BuildRequires:  gettext-tools >= 0.17
25 BuildRequires:  glib2-devel >= 1:2.44.0
26 BuildRequires:  gstreamer-devel >= %{gst_ver}
27 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_ver}
28 %{?with_apidocs:BuildRequires:  hotdoc >= 0.11.0}
29 BuildRequires:  meson >= 0.48
30 BuildRequires:  ninja >= 1.5
31 BuildRequires:  orc-devel >= 0.4.16
32 BuildRequires:  pkgconfig >= 1:0.9.0
33 BuildRequires:  python3 >= 1:3.2
34 BuildRequires:  rpm-build >= 4.6
35 BuildRequires:  rpmbuild(macros) >= 1.736
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 ##
39 ## plugins
40 ##
41 BuildRequires:  a52dec-libs-devel
42 %{?with_cdio:BuildRequires:     libcdio-devel >= 0.76}
43 BuildRequires:  libdvdread-devel >= 0.5.0
44 BuildRequires:  libmpeg2-devel >= 0.5.1
45 %{?with_sid:BuildRequires:      libsidplay-devel >= 1.36.57}
46 # ABI 120
47 BuildRequires:  libx264-devel >= 0.1.3-1.20111212_2245.1
48 %{?with_amr:BuildRequires:      opencore-amr-devel >= 0.1.3}
49 Requires:       glib2 >= 1:2.44.0
50 Requires:       gstreamer >= %{gst_ver}
51 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
52 Requires:       orc >= 0.4.16
53 Obsoletes:      gstreamer-asf < 0.10
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         gstlibdir       %{_libdir}/gstreamer-%{gstmver}
57
58 %description
59 GStreamer is a streaming-media framework, based on graphs of filters
60 which operate on media data. Applications using this library can do
61 anything from real-time sound processing to playing videos, and just
62 about anything else media-related. Its plugin-based architecture means
63 that new data types or processing capabilities can be added simply by
64 installing new plugins.
65
66 %description -l pl.UTF-8
67 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
68 grafie filtrów operujących na danych medialnych. Aplikacje używające
69 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
70 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związego z
71 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
72 nowych typów danych lub możliwości obróbki.
73
74 %package apidocs
75 Summary:        Ugly GStreamer streaming-media framework plugins API documentation
76 Summary(pl.UTF-8):      Dokumentacja API brzydkich wtyczek środowiska obróbki strumieni GStreamer
77 Group:          Documentation
78 BuildArch:      noarch
79
80 %description apidocs
81 Ugly GStreamer streaming-media framework plugins API documentation.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API brzydkich wtyczek środowiska obróbki strumieni
85 GStreamer.
86
87 ##
88 ## Plugins
89 ##
90
91 %package -n gstreamer-a52dec
92 Summary:        GStreamer VOB decoder plugin
93 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca VOB
94 Group:          Libraries
95 Requires:       gstreamer >= %{gst_ver}
96 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
97
98 %description -n gstreamer-a52dec
99 Plugin for decoding of VOB files.
100
101 %description -n gstreamer-a52dec -l pl.UTF-8
102 Wtyczka dekodująca pliki VOB.
103
104 %package -n gstreamer-amrnb
105 Summary:        GStreamer AMR-NB decoder plugin
106 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca pliki AMR-NB
107 Group:          Libraries
108 Requires:       gstreamer >= %{gst_ver}
109 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
110 Requires:       opencore-amr >= 0.1.3
111
112 %description -n gstreamer-amrnb
113 Plugin for decoding of AMR-NB files.
114
115 %description -n gstreamer-amrnb -l pl.UTF-8
116 Wtyczka dekodująca pliki AMR-NB.
117
118 %package -n gstreamer-amrwb
119 Summary:        GStreamer AMR-WB decoder plugin
120 Summary(pl.UTF-8):      Wtyczka do GStreamera dekodująca pliki AMR-WB
121 Group:          Libraries
122 Requires:       gstreamer >= %{gst_ver}
123 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
124 Requires:       opencore-amr >= 0.1.3
125
126 %description -n gstreamer-amrwb
127 Plugin for decoding of AMR-WB files.
128
129 %description -n gstreamer-amrwb -l pl.UTF-8
130 Wtyczka dekodująca pliki AMR-WB.
131
132 %package -n gstreamer-cdio
133 Summary:        GStreamer plugin for CD audio input using libcdio
134 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca płyty CD-Audio przy użyciu libcdio
135 Group:          Libraries
136 Requires:       gstreamer >= %{gst_ver}
137 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
138 Requires:       libcdio >= 0.76
139 # for NLS
140 Requires:       %{name} = %{version}-%{release}
141
142 %description -n gstreamer-cdio
143 Plugin for playing audio tracks using libcdio under GStreamer.
144
145 %description -n gstreamer-cdio -l pl.UTF-8
146 Wtyczka do odtwarzania ścieżek dźwiękowych pod GStreamerem za pomocą
147 libcdio.
148
149 %package -n gstreamer-dvdread
150 Summary:        GStreamer plugin for DVD playback
151 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca DVD
152 Group:          Libraries
153 # for NLS
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       gstreamer >= %{gst_ver}
156 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
157 Requires:       libdvdread >= 0.5.0
158 Obsoletes:      gstreamer-libdvdread < 0.11
159
160 %description -n gstreamer-dvdread
161 GStreamer plugin for DVD playback.
162
163 %description -n gstreamer-dvdread -l pl.UTF-8
164 Wtyczka odtwarzająca DVD do GStreamera.
165
166 %package -n gstreamer-mpeg
167 Summary:        GStreamer plugins for MPEG video playback
168 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca obraz MPEG
169 Group:          Libraries
170 Requires:       gstreamer >= %{gst_ver}
171 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
172 Requires:       libmpeg2 >= 0.5.1
173
174 %description -n gstreamer-mpeg
175 Plugins for playing MPEG videos.
176
177 %description -n gstreamer-mpeg -l pl.UTF-8
178 Wtyczki do odtwarzania obrazu MPEG.
179
180 %package -n gstreamer-sid
181 Summary:        GStreamer Sid C64 music plugin
182 Summary(pl.UTF-8):      Wtyczka do GStreamera odtwarzająca muzykę Sid C64
183 Group:          Libraries
184 Requires:       gstreamer >= %{gst_ver}
185 Requires:       gstreamer-plugins-base >= %{gstpb_ver}
186 Requires:       libsidplay >= 1.36.57
187
188 %description -n gstreamer-sid
189 Plugin for playback of C64 SID format music files.
190
191 %description -n gstreamer-sid -l pl.UTF-8
192 Wtyczka do odtwarzania plików z muzyką w formacie C64 SID.
193
194 %package -n gstreamer-x264
195 Summary:        GStreamer x264 encoder plugin
196 Summary(pl.UTF-8):      Wtyczka do GStreamera kodująca przy użyciu biblioteki x264
197 Group:          Libraries
198 Requires:       gstreamer >= %{gst_ver}
199 Requires:       gstreamer-plugins-base >= %{gst_ver}
200
201 %description -n gstreamer-x264
202 GStreamer x264 encoder plugin.
203
204 %description -n gstreamer-x264 -l pl.UTF-8
205 Wtyczka do GStreamera kodująca przy użyciu biblioteki x264.
206
207 %prep
208 %setup -q -n %{gstname}-%{version}
209
210 %build
211 %meson build \
212         --default-library=shared \
213         %{!?with_amr:-Damrnb=disabled} \
214         %{!?with_amr:-Damrwbdec=disabled} \
215         %{!?with_cdio:-Dcdio=disabled} \
216         %{!?with_apidocs:-Ddoc=disabled} \
217         %{!?with_sid:-Dsidplay=disabled}
218
219 %ninja_build -C build
220
221 %if %{with apidocs}
222 cd build/docs
223 for config in *-doc.json ; do
224         LC_ALL=C.UTF-8 hotdoc run --conf-file "$config"
225 done
226 %endif
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230
231 %ninja_install -C build
232
233 %if %{with apidocs}
234 install -d $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
235 cp -pr build/docs/*-doc $RPM_BUILD_ROOT%{_docdir}/gstreamer-%{gstmver}
236 %endif
237
238 %find_lang %{gstname}-%{gstmver}
239
240 %clean
241 rm -rf $RPM_BUILD_ROOT
242
243 %files -f %{gstname}-%{gstmver}.lang
244 %defattr(644,root,root,755)
245 %doc AUTHORS ChangeLog NEWS README RELEASE
246 %attr(755,root,root) %{gstlibdir}/libgstasf.so
247 %attr(755,root,root) %{gstlibdir}/libgstdvdlpcmdec.so
248 %attr(755,root,root) %{gstlibdir}/libgstdvdsub.so
249 %attr(755,root,root) %{gstlibdir}/libgstrealmedia.so
250 %attr(755,root,root) %{gstlibdir}/libgstxingmux.so
251 %{_datadir}/gstreamer-%{gstmver}/presets
252
253 %if %{with apidocs}
254 %files apidocs
255 %defattr(644,root,root,755)
256 %{_docdir}/gstreamer-%{gstmver}/a52dec-doc
257 %{_docdir}/gstreamer-%{gstmver}/amrnb-doc
258 %{_docdir}/gstreamer-%{gstmver}/amrwbdec-doc
259 %{_docdir}/gstreamer-%{gstmver}/asf-doc
260 %{_docdir}/gstreamer-%{gstmver}/cdio-doc
261 %{_docdir}/gstreamer-%{gstmver}/dvdlpcmdec-doc
262 %{_docdir}/gstreamer-%{gstmver}/dvdread-doc
263 %{_docdir}/gstreamer-%{gstmver}/dvdsub-doc
264 %{_docdir}/gstreamer-%{gstmver}/mpeg2dec-doc
265 %{_docdir}/gstreamer-%{gstmver}/realmedia-doc
266 %{_docdir}/gstreamer-%{gstmver}/sid-doc
267 %{_docdir}/gstreamer-%{gstmver}/x264-doc
268 %{_docdir}/gstreamer-%{gstmver}/xingmux-doc
269 %endif
270
271 ##
272 ## Plugins
273 ##
274
275 %files -n gstreamer-a52dec
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{gstlibdir}/libgsta52dec.so
278
279 %if %{with amr}
280 %files -n gstreamer-amrnb
281 %defattr(644,root,root,755)
282 %attr(755,root,root) %{gstlibdir}/libgstamrnb.so
283
284 %files -n gstreamer-amrwb
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{gstlibdir}/libgstamrwbdec.so
287 %endif
288
289 %if %{with cdio}
290 %files -n gstreamer-cdio
291 %defattr(644,root,root,755)
292 %attr(755,root,root) %{gstlibdir}/libgstcdio.so
293 %endif
294
295 %files -n gstreamer-dvdread
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{gstlibdir}/libgstdvdread.so
298
299 %files -n gstreamer-mpeg
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{gstlibdir}/libgstmpeg2dec.so
302
303 %if %{with sid}
304 %files -n gstreamer-sid
305 %defattr(644,root,root,755)
306 %attr(755,root,root) %{gstlibdir}/libgstsid.so
307 %endif
308
309 %files -n gstreamer-x264
310 %defattr(644,root,root,755)
311 %attr(755,root,root) %{gstlibdir}/libgstx264.so
This page took 0.072622 seconds and 3 git commands to generate.