]> git.pld-linux.org Git - packages/gstreamer-libav.git/blob - gstreamer-libav.spec
- updated dependencies
[packages/gstreamer-libav.git] / gstreamer-libav.spec
1 #
2 # Conditional build:
3 %bcond_without  gpl             # GPL licensed components
4 %bcond_without  vdpau           # build libav without VDPAU support
5 %bcond_with     system_ffmpeg   # system ffmpeg (note: upstream does not accept bugs with system ffmpeg)
6
7 %define         gstname gst-libav
8 %define         gst_major_ver   1.0
9 %define         gst_req_ver     1.14.4
10 %define         gstpb_req_ver   1.14.4
11 %define         ffmpeg_ver      3.4.2
12
13 %include        /usr/lib/rpm/macros.gstreamer
14 Summary:        GStreamer Streaming-media framework plug-in using libav
15 Summary(pl.UTF-8):      Wtyczka do środowiska obróbki strumieni GStreamer używająca libav
16 Name:           gstreamer-libav
17 Version:        1.14.4
18 Release:        1
19 %if %{with gpl}
20 License:        GPL v2+
21 %else
22 License:        LGPL v2+
23 %endif
24 Group:          Libraries
25 Source0:        https://gstreamer.freedesktop.org/src/gst-libav/%{gstname}-%{version}.tar.xz
26 # Source0-md5:  58342db11dbb201a66a62577dcf7bab5
27 Patch0:         link.patch
28 URL:            https://gstreamer.freedesktop.org/
29 BuildRequires:  autoconf >= 2.69
30 BuildRequires:  automake >= 1:1.14
31 BuildRequires:  glib2-devel >= 1:2.40.0
32 BuildRequires:  gstreamer-devel >= %{gst_req_ver}
33 BuildRequires:  gstreamer-plugins-base-devel >= %{gstpb_req_ver}
34 BuildRequires:  gtk-doc >= 1.12
35 BuildRequires:  libtool >= 2:2.2.6
36 BuildRequires:  orc-devel >= 0.4.16
37 BuildRequires:  pkgconfig >= 1:0.9.0
38 BuildRequires:  python >= 2.1
39 BuildRequires:  rpmbuild(macros) >= 1.470
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  xz
42 %if %{with system_ffmpeg}
43 # libavformat,libavcodec >= 57,libavutil,libswscale needed
44 BuildRequires:  ffmpeg-devel >= %{ffmpeg_ver}
45 %else
46 # libav dependencies
47 BuildRequires:  bzip2-devel
48 BuildRequires:  libvdpau-devel
49 BuildRequires:  xorg-lib-libX11-devel
50 %if %{with vdpau}
51 BuildRequires:  xorg-lib-libXvMC-devel
52 %endif
53 BuildRequires:  xz-devel
54 BuildRequires:  zlib-devel
55 %ifarch %{ix86} %{x8664}
56 BuildRequires:  yasm
57 %endif
58 %endif
59 Requires:       glib2 >= 1:2.40.0
60 Requires:       gstreamer >= %{gst_req_ver}
61 Requires:       gstreamer-plugins-base >= %{gstpb_req_ver}
62 %if %{with system_ffmpeg}
63 Requires:       ffmpeg-libs >= %{ffmpeg_ver}
64 %endif
65 Requires:       orc >= 0.4.16
66 Obsoletes:      gstreamer-ffmpeg
67 Obsoletes:      gstreamer-real
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %description
71 GStreamer is a streaming-media framework, based on graphs of filters
72 which operate on media data. Applications using this library can do
73 anything from real-time sound processing to playing videos, and just
74 about anything else media-related. Its plugin-based architecture means
75 that new data types or processing capabilities can be added simply by
76 installing new plug-ins.
77
78 This plugin contains the libav codecs, containing codecs for most
79 popular multimedia formats.
80
81 %description -l pl.UTF-8
82 GStreamer to środowisko obróbki danych strumieniowych, bazujące na
83 grafie filtrów operujących na danych medialnych. Aplikacje używające
84 tej biblioteki mogą robić wszystko od przetwarzania dźwięku w czasie
85 rzeczywistym, do odtwarzania filmów i czegokolwiek innego związanego z
86 mediami. Architektura bazująca na wtyczkach pozwala na łatwe dodawanie
87 nowych typów danych lub możliwości obróbki.
88
89 Wtyczka ta zawiera kodeki libav, potrafiące zdekodować
90 najpopularniejsze formaty multimedialne.
91
92 %package apidocs
93 Summary:        API documentation for GStreamer libav plugin
94 Summary(pl.UTF-8):      Dokumentacja API do wtyczki GStreamera libav
95 Group:          Documentation
96 Requires:       gtk-doc-common
97 %if "%{_rpmversion}" >= "5"
98 BuildArch:      noarch
99 %endif
100
101 %description apidocs
102 API documentation for GStreamer libav plugin.
103
104 %description apidocs -l pl.UTF-8
105 Dokumentacja API do wtyczki GStreamera libav.
106
107 %prep
108 %setup -q -n %{gstname}-%{version}
109 %patch0 -p1
110
111 %build
112 %{__libtoolize}
113 %{__aclocal} -I m4 -I common/m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117
118 LIBAV_OPTS="%{?with_vdpau:--enable-vdpau}"
119 %ifarch x32
120 LIBAV_OPTS="$LIBAV_OPTS --disable-asm"
121 %endif
122 %configure \
123         CPPFLAGS="%{rpmcppflags}" \
124         %{?with_system_ffmpeg:--with-system-libav} \
125         --with-libav-extra-configure="$LIBAV_OPTS" \
126         %{?with_gpl:--enable-gpl} \
127         --disable-silent-rules \
128         --disable-static \
129         --with-html-dir=%{_gtkdocdir}
130
131 # V=1 is for libav (--disable-silent-rules affects only main gst-libav sources)
132 %{__make} \
133         V=1
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{gst_major_ver}/*.la
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog NEWS README TODO
149 %attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstlibav.so
150 # disabled in (upstream) 1.2.0 until someone fixes it
151 #%attr(755,root,root) %{_libdir}/gstreamer-%{gst_major_ver}/libgstavscale.so
152
153 %files apidocs
154 %defattr(644,root,root,755)
155 %{_gtkdocdir}/gst-libav-plugins-1.0
This page took 0.054736 seconds and 3 git commands to generate.