]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- updated to 0.0.10
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  gss     # without GSSAPI mechanism
4 %bcond_without  krbv5   # without KERBEROS_V5 mechanism
5 %bcond_without  ntlm    # without NTLM mechanism
6 #
7 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
8 Summary(pl):    GNU SASL - implementacja Simple Authentication and Security Layer
9 Name:           gsasl
10 Version:        0.0.10
11 Release:        1
12 License:        GPL
13 Group:          Libraries
14 Source0:        http://josefsson.org/gsasl/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  82cbcdb210e911f77ae82cf91ceee088
16 Patch0:         %{name}-info.patch
17 URL:            http://www.gnu.org/software/gsasl/
18 BuildRequires:  autoconf >= 2.58
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel >= 0.12.1
21 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
22 BuildRequires:  gtk-doc >= 1.1
23 BuildRequires:  libgcrypt-devel >= 1.1.42
24 BuildRequires:  libidn-devel >= 0.1.0
25 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.1}
26 BuildRequires:  libtool
27 # alternatively, krb5 or heimdal could be used for GSSAPI and KERBEROS_V5
28 %{?with_krbv5:BuildRequires:    shishi-devel >= 0.0.0}
29 BuildRequires:  texinfo
30 Requires(post,postun):  /sbin/ldconfig
31 Obsoletes:      libgsasl
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 GNU SASL is an implementation of the Simple Authentication and
36 Security Layer framework and a few common SASL mechanisms. SASL is
37 used by network servers (e.g., IMAP, SMTP) to request authentication
38 from clients, and in clients to authenticate against servers.
39
40 GNU SASL contains a library (`libgsasl'), a command line utility
41 (`gsasl') to access the library from the shell, and a manual. The
42 library includes support for the SASL framework (with authentication
43 functions and application data privacy and integrity functions) and at
44 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
45 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
46
47 The library is portable because it does not do network communication
48 by itself, but rather leaves it up to the calling application. The
49 library is flexible with regards to the authorization infrastructure
50 used, as it utilizes callbacks into the application to decide whether
51 an user is authorized or not.
52
53 %description -l pl
54 GNU SASL to implementacja szkieletu Simple Authentication and Security
55 Layer (prostej warstwy uwierzytelniania i bezpieczeñstwa) oraz kilku
56 popularnych mechanizmów SASL. SASL jest u¿ywane przez serwery sieciowe
57 (np. IMAP i SMTP) do ¿±dania uwierzytelnienia od klientów oraz w
58 klientach do uwierzytelniania wzglêdem serwerów.
59
60 GNU SASL zawiera bibliotekê (libgsasl), narzêdzie dzia³aj±ce z linii
61 poleceñ (gsasl) pozwalaj±ce na korzystanie z biblioteki z poziomu
62 pow³oki oraz dokumentacjê. Biblioteka ma obs³ugê szkieletu SASL (z
63 funkcjami uwierzytelniaj±cymi oraz zapewniaj±cymi prywatno¶æ i
64 spójno¶æ danych aplikacji) oraz przynajmniej czê¶ciow± obs³ugê
65 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
66 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
67
68 Biblioteka jest przeno¶na, poniewa¿ sama nie korzysta z komunikacji
69 sieciowej, pozostawiaj±c to wywo³uj±cej j± aplikacji. Biblioteka jest
70 elastyczna ze wzglêdu na u¿ywan± infrastrukturê uwierzytelniania,
71 poniewa¿ korzysta z callbacków w aplikacji przy decydowaniu, czy
72 u¿ytkownik jest autoryzowany.
73
74 %package devel
75 Summary:        Header files for GNU SASL library
76 Summary(pl):    Pliki nag³ówkowe biblioteki GNU SASL
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}
79 #Requires:      gtk-doc-common
80 %{?with_gss:Requires:   gss-devel >= 0.0.0}
81 Requires:       libgcrypt-devel >= 1.1.42
82 Requires:       libidn-devel >= 0.1.0
83 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.1}
84 %{?with_krbv5:Requires: shishi-devel >= 0.0.0}
85 Obsoletes:      libgsasl-devel
86
87 %description devel
88 Header files for GNU SASL library.
89
90 %description devel -l pl
91 Pliki nag³ówkowe biblioteki GNU SASL.
92
93 %package static
94 Summary:        Static GNU SASL library
95 Summary(pl):    Statyczna biblioteka GNU SASL
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}
98 Obsoletes:      libgsasl-static
99
100 %description static
101 Static GNU SASL library.
102
103 %description static -l pl
104 Statyczna biblioteka GNU SASL.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109
110 # grrr, 2.59 not released yet
111 # and they use some hacked version which is broken with pdksh, so we must rebuild
112 %{__perl} -pi -e 's/(AC_PREREQ)\(2\.59\)/$1(2.58)/' configure.ac
113
114 %build
115 %{__gettextize}
116 %{__libtoolize}
117 %{__aclocal} -I m4
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 %configure \
122         %{!?with_gss:--disable-gssapi} \
123         %{!?with_krbv5:--disable-kerberos_v5} \
124         %{!?with_ntlm:--disable-ntlm} \
125         --enable-gtk-doc \
126         --with-html-dir=%{_gtkdocdir}
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %find_lang %{name}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 /sbin/ldconfig
143 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
144
145 %postun
146 /sbin/ldconfig
147 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc ANNOUNCE AUTHORS ChangeLog NEWS README* THANKS
152 %attr(755,root,root) %{_bindir}/gsasl
153 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
154 %{_mandir}/man1/gsasl.1*
155 %{_infodir}/*.info*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libgsasl.so
160 %{_libdir}/libgsasl.la
161 %{_includedir}/gsasl.h
162 %{_pkgconfigdir}/libgsasl.pc
163 %{_mandir}/man3/*.3*
164 # reference in HTML format is not installed now
165 #%{_gtkdocdir}/gsasl
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libgsasl.a
This page took 0.038869 seconds and 4 git commands to generate.