]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- up to 0.2.11
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  gss     # without GSSAPI mechanism
4 %bcond_without  krbv5   # without KERBEROS_V5 mechanism
5 %bcond_without  ntlm    # without NTLM mechanism
6 #
7 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
8 Summary(pl):    GNU SASL - implementacja Simple Authentication and Security Layer
9 Name:           gsasl
10 Version:        0.2.11
11 Release:        1
12 License:        GPL
13 Group:          Libraries
14 Source0:        http://josefsson.org/gsasl/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  87cf57326e46ec22abb7582dd652c0d4
16 Patch0:         %{name}-info.patch
17 URL:            http://www.gnu.org/software/gsasl/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake >= 1:1.9
20 BuildRequires:  gettext-devel >= 0.14.1
21 BuildRequires:  gnutls-devel >= 1.2.0
22 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
23 BuildRequires:  gtk-doc >= 1.1
24 BuildRequires:  libgcrypt-devel >= 1.1.42
25 BuildRequires:  libidn-devel >= 0.1.0
26 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
27 BuildRequires:  libtool >= 2:1.5
28 # alternatively, krb5 or heimdal could be used for GSSAPI and KERBEROS_V5
29 %{?with_krbv5:BuildRequires:    shishi-devel >= 0.0.0}
30 BuildRequires:  texinfo
31 Requires(post,postun):  /sbin/ldconfig
32 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
33 Obsoletes:      libgsasl
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 GNU SASL is an implementation of the Simple Authentication and
38 Security Layer framework and a few common SASL mechanisms. SASL is
39 used by network servers (e.g., IMAP, SMTP) to request authentication
40 from clients, and in clients to authenticate against servers.
41
42 GNU SASL contains a library (`libgsasl'), a command line utility
43 (`gsasl') to access the library from the shell, and a manual. The
44 library includes support for the SASL framework (with authentication
45 functions and application data privacy and integrity functions) and at
46 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
47 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
48
49 The library is portable because it does not do network communication
50 by itself, but rather leaves it up to the calling application. The
51 library is flexible with regards to the authorization infrastructure
52 used, as it utilizes callbacks into the application to decide whether
53 an user is authorized or not.
54
55 %description -l pl
56 GNU SASL to implementacja szkieletu Simple Authentication and Security
57 Layer (prostej warstwy uwierzytelniania i bezpieczeñstwa) oraz kilku
58 popularnych mechanizmów SASL. SASL jest u¿ywane przez serwery sieciowe
59 (np. IMAP i SMTP) do ¿±dania uwierzytelnienia od klientów oraz w
60 klientach do uwierzytelniania wzglêdem serwerów.
61
62 GNU SASL zawiera bibliotekê (libgsasl), narzêdzie dzia³aj±ce z linii
63 poleceñ (gsasl) pozwalaj±ce na korzystanie z biblioteki z poziomu
64 pow³oki oraz dokumentacjê. Biblioteka ma obs³ugê szkieletu SASL (z
65 funkcjami uwierzytelniaj±cymi oraz zapewniaj±cymi prywatno¶æ i
66 spójno¶æ danych aplikacji) oraz przynajmniej czê¶ciow± obs³ugê
67 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
68 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
69
70 Biblioteka jest przeno¶na, poniewa¿ sama nie korzysta z komunikacji
71 sieciowej, pozostawiaj±c to wywo³uj±cej j± aplikacji. Biblioteka jest
72 elastyczna ze wzglêdu na u¿ywan± infrastrukturê uwierzytelniania,
73 poniewa¿ korzysta z callbacków w aplikacji przy decydowaniu, czy
74 u¿ytkownik jest autoryzowany.
75
76 %package devel
77 Summary:        Header files for GNU SASL library
78 Summary(pl):    Pliki nag³ówkowe biblioteki GNU SASL
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 %{?with_gss:Requires:   gss-devel >= 0.0.0}
82 Requires:       libgcrypt-devel >= 1.1.42
83 Requires:       libidn-devel >= 0.1.0
84 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
85 %{?with_krbv5:Requires: shishi-devel >= 0.0.0}
86 Obsoletes:      libgsasl-devel
87
88 %description devel
89 Header files for GNU SASL library.
90
91 %description devel -l pl
92 Pliki nag³ówkowe biblioteki GNU SASL.
93
94 %package static
95 Summary:        Static GNU SASL library
96 Summary(pl):    Statyczna biblioteka GNU SASL
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Obsoletes:      libgsasl-static
100
101 %description static
102 Static GNU SASL library.
103
104 %description static -l pl
105 Statyczna biblioteka GNU SASL.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110
111 %build
112 %{__gettextize}
113 %{__libtoolize}
114 %{__aclocal} -I m4 -I gl/m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         --enable-gtk-doc \
120         %{!?with_gss:--disable-gssapi} \
121         %{!?with_krbv5:--disable-kerberos_v5} \
122         %{!?with_ntlm:--disable-ntlm} \
123         --with-html-dir=%{_gtkdocdir} \
124         --with-libgcrypt
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 # libgsasl for lib, gsasl for app
135 %find_lang %{name} --all-name
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 /sbin/ldconfig
142 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
143
144 %postun
145 /sbin/ldconfig
146 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README* THANKS
151 %attr(755,root,root) %{_bindir}/gsasl
152 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
153 %{_mandir}/man1/gsasl.1*
154 %{_infodir}/*.info*
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libgsasl.so
159 %{_libdir}/libgsasl.la
160 %{_includedir}/gsasl*.h
161 %{_pkgconfigdir}/libgsasl.pc
162 %{_mandir}/man3/*.3*
163 %{_gtkdocdir}/gsasl
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libgsasl.a
This page took 0.046493 seconds and 4 git commands to generate.