]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- updated to 0.2.6, updated pl.po-update patch
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  gss     # without GSSAPI mechanism
4 %bcond_without  krbv5   # without KERBEROS_V5 mechanism
5 %bcond_without  ntlm    # without NTLM mechanism
6 #
7 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
8 Summary(pl):    GNU SASL - implementacja Simple Authentication and Security Layer
9 Name:           gsasl
10 Version:        0.2.6
11 Release:        1
12 License:        GPL
13 Group:          Libraries
14 Source0:        http://josefsson.org/gsasl/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  5e527147cea5cc776240f6d7a6820955
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-pl.po-update.patch
18 URL:            http://www.gnu.org/software/gsasl/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake >= 1:1.9
21 BuildRequires:  gettext-devel >= 0.14.1
22 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
23 BuildRequires:  gtk-doc >= 1.1
24 BuildRequires:  libgcrypt-devel >= 1.1.42
25 BuildRequires:  libidn-devel >= 0.1.0
26 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
27 BuildRequires:  libtool >= 2:1.5
28 # alternatively, krb5 or heimdal could be used for GSSAPI and KERBEROS_V5
29 %{?with_krbv5:BuildRequires:    shishi-devel >= 0.0.0}
30 BuildRequires:  texinfo
31 Requires(post,postun):  /sbin/ldconfig
32 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
33 Obsoletes:      libgsasl
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 GNU SASL is an implementation of the Simple Authentication and
38 Security Layer framework and a few common SASL mechanisms. SASL is
39 used by network servers (e.g., IMAP, SMTP) to request authentication
40 from clients, and in clients to authenticate against servers.
41
42 GNU SASL contains a library (`libgsasl'), a command line utility
43 (`gsasl') to access the library from the shell, and a manual. The
44 library includes support for the SASL framework (with authentication
45 functions and application data privacy and integrity functions) and at
46 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
47 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
48
49 The library is portable because it does not do network communication
50 by itself, but rather leaves it up to the calling application. The
51 library is flexible with regards to the authorization infrastructure
52 used, as it utilizes callbacks into the application to decide whether
53 an user is authorized or not.
54
55 %description -l pl
56 GNU SASL to implementacja szkieletu Simple Authentication and Security
57 Layer (prostej warstwy uwierzytelniania i bezpieczeñstwa) oraz kilku
58 popularnych mechanizmów SASL. SASL jest u¿ywane przez serwery sieciowe
59 (np. IMAP i SMTP) do ¿±dania uwierzytelnienia od klientów oraz w
60 klientach do uwierzytelniania wzglêdem serwerów.
61
62 GNU SASL zawiera bibliotekê (libgsasl), narzêdzie dzia³aj±ce z linii
63 poleceñ (gsasl) pozwalaj±ce na korzystanie z biblioteki z poziomu
64 pow³oki oraz dokumentacjê. Biblioteka ma obs³ugê szkieletu SASL (z
65 funkcjami uwierzytelniaj±cymi oraz zapewniaj±cymi prywatno¶æ i
66 spójno¶æ danych aplikacji) oraz przynajmniej czê¶ciow± obs³ugê
67 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
68 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
69
70 Biblioteka jest przeno¶na, poniewa¿ sama nie korzysta z komunikacji
71 sieciowej, pozostawiaj±c to wywo³uj±cej j± aplikacji. Biblioteka jest
72 elastyczna ze wzglêdu na u¿ywan± infrastrukturê uwierzytelniania,
73 poniewa¿ korzysta z callbacków w aplikacji przy decydowaniu, czy
74 u¿ytkownik jest autoryzowany.
75
76 %package devel
77 Summary:        Header files for GNU SASL library
78 Summary(pl):    Pliki nag³ówkowe biblioteki GNU SASL
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 %{?with_gss:Requires:   gss-devel >= 0.0.0}
82 Requires:       libgcrypt-devel >= 1.1.42
83 Requires:       libidn-devel >= 0.1.0
84 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
85 %{?with_krbv5:Requires: shishi-devel >= 0.0.0}
86 Obsoletes:      libgsasl-devel
87
88 %description devel
89 Header files for GNU SASL library.
90
91 %description devel -l pl
92 Pliki nag³ówkowe biblioteki GNU SASL.
93
94 %package static
95 Summary:        Static GNU SASL library
96 Summary(pl):    Statyczna biblioteka GNU SASL
97 Group:          Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99 Obsoletes:      libgsasl-static
100
101 %description static
102 Static GNU SASL library.
103
104 %description static -l pl
105 Statyczna biblioteka GNU SASL.
106
107 %prep
108 %setup -q
109 %patch0 -p1
110 %patch1 -p1
111
112 rm -f lib/po/stamp-po
113
114 %build
115 %{__gettextize}
116 %{__libtoolize}
117 %{__aclocal} -I m4 -I gl/m4
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 %configure \
122         --enable-gtk-doc \
123         %{!?with_gss:--disable-gssapi} \
124         %{!?with_krbv5:--disable-kerberos_v5} \
125         %{!?with_ntlm:--disable-ntlm} \
126         --with-html-dir=%{_gtkdocdir} \
127         --with-libgcrypt
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 # libgsasl for lib, gsasl for app
138 %find_lang %{name} --all-name
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 /sbin/ldconfig
145 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
146
147 %postun
148 /sbin/ldconfig
149 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog NEWS README* THANKS
154 %attr(755,root,root) %{_bindir}/gsasl
155 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
156 %{_mandir}/man1/gsasl.1*
157 %{_infodir}/*.info*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libgsasl.so
162 %{_libdir}/libgsasl.la
163 %{_includedir}/gsasl*.h
164 %{_pkgconfigdir}/libgsasl.pc
165 %{_mandir}/man3/*.3*
166 %{_gtkdocdir}/gsasl
167
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libgsasl.a
This page took 0.08468 seconds and 4 git commands to generate.