]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- updated to 0.2.19
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_with     gss             # use gss instead of MIT as GSSAPI implementation
4 %bcond_with     kerberos5       # with KERBEROS_V5 mechanism (based on shishi, currently broken)
5 %bcond_without  ntlm            # without NTLM mechanism
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
9 Summary(pl.UTF-8):      GNU SASL - implementacja Simple Authentication and Security Layer
10 Name:           gsasl
11 Version:        0.2.19
12 Release:        1
13 License:        GPL
14 Group:          Libraries
15 Source0:        http://josefsson.org/gsasl/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  670359bf16126a114a68991a6682e7d0
17 Patch0:         %{name}-info.patch
18 URL:            http://www.gnu.org/software/gsasl/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake >= 1:1.10
21 BuildRequires:  gettext-devel >= 0.16.1
22 BuildRequires:  gnutls-devel >= 1.2.0
23 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
24 BuildRequires:  gtk-doc >= 1.1
25 BuildRequires:  libgcrypt-devel >= 1.1.42
26 BuildRequires:  libidn-devel >= 0.1.0
27 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
28 BuildRequires:  libtool >= 2:1.5
29 BuildRequires:  pkgconfig
30 # alternatively, gss or heimdal can be used for GSSAPI
31 %{!?with_gss:BuildRequires:     krb5-devel}
32 %{?with_kerberos5:BuildRequires:        shishi-devel}
33 BuildRequires:  texinfo
34 Requires(post,postun):  /sbin/ldconfig
35 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
36 Obsoletes:      libgsasl
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 GNU SASL is an implementation of the Simple Authentication and
41 Security Layer framework and a few common SASL mechanisms. SASL is
42 used by network servers (e.g., IMAP, SMTP) to request authentication
43 from clients, and in clients to authenticate against servers.
44
45 GNU SASL contains a library (`libgsasl'), a command line utility
46 (`gsasl') to access the library from the shell, and a manual. The
47 library includes support for the SASL framework (with authentication
48 functions and application data privacy and integrity functions) and at
49 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
50 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
51
52 The library is portable because it does not do network communication
53 by itself, but rather leaves it up to the calling application. The
54 library is flexible with regards to the authorization infrastructure
55 used, as it utilizes callbacks into the application to decide whether
56 an user is authorized or not.
57
58 %description -l pl.UTF-8
59 GNU SASL to implementacja szkieletu Simple Authentication and Security
60 Layer (prostej warstwy uwierzytelniania i bezpieczeństwa) oraz kilku
61 popularnych mechanizmów SASL. SASL jest używane przez serwery sieciowe
62 (np. IMAP i SMTP) do żądania uwierzytelnienia od klientów oraz w
63 klientach do uwierzytelniania względem serwerów.
64
65 GNU SASL zawiera bibliotekę (libgsasl), narzędzie działające z linii
66 poleceń (gsasl) pozwalające na korzystanie z biblioteki z poziomu
67 powłoki oraz dokumentację. Biblioteka ma obsługę szkieletu SASL (z
68 funkcjami uwierzytelniającymi oraz zapewniającymi prywatność i
69 spójność danych aplikacji) oraz przynajmniej częściową obsługę
70 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
71 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
72
73 Biblioteka jest przenośna, ponieważ sama nie korzysta z komunikacji
74 sieciowej, pozostawiając to wywołującej ją aplikacji. Biblioteka jest
75 elastyczna ze względu na używaną infrastrukturę uwierzytelniania,
76 ponieważ korzysta z callbacków w aplikacji przy decydowaniu, czy
77 użytkownik jest autoryzowany.
78
79 %package devel
80 Summary:        Header files for GNU SASL library
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GNU SASL
82 Group:          Development/Libraries
83 Requires:       %{name} = %{version}-%{release}
84 %{?with_gss:Requires:   gss-devel >= 0.0.0}
85 Requires:       libgcrypt-devel >= 1.1.42
86 Requires:       libidn-devel >= 0.1.0
87 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
88 %{!?with_gss:Requires:  krb5-devel}
89 %{?with_kerberos5:Requires:     shishi-devel}
90 Obsoletes:      libgsasl-devel
91
92 %description devel
93 Header files for GNU SASL library.
94
95 %description devel -l pl.UTF-8
96 Pliki nagłówkowe biblioteki GNU SASL.
97
98 %package static
99 Summary:        Static GNU SASL library
100 Summary(pl.UTF-8):      Statyczna biblioteka GNU SASL
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Obsoletes:      libgsasl-static
104
105 %description static
106 Static GNU SASL library.
107
108 %description static -l pl.UTF-8
109 Statyczna biblioteka GNU SASL.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114
115 %build
116 %{__gettextize}
117 %{__libtoolize}
118 %{__aclocal} -I m4 -I gl/m4
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 cd lib
123 %{__libtoolize}
124 %{__aclocal} -I m4 -I gl/m4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 cd -
129 %configure \
130         --enable-gtk-doc \
131         %{!?with_ntlm:--disable-ntlm} \
132         %{!?with_static_libs:--disable-static} \
133         %{?with_kerberos5:--enable-kerberos_v5} \
134         %{!?with_gss:--with-gssapi-impl=mit} \
135         --with-html-dir=%{_gtkdocdir} \
136         --with-libgcrypt
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 # libgsasl for lib, gsasl for app
147 %find_lang %{name} --all-name
148
149 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 /sbin/ldconfig
156 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
157
158 %postun
159 /sbin/ldconfig
160 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
161
162 %files -f %{name}.lang
163 %defattr(644,root,root,755)
164 %doc AUTHORS ChangeLog NEWS README* THANKS
165 %attr(755,root,root) %{_bindir}/gsasl
166 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
167 %{_mandir}/man1/gsasl.1*
168 %{_infodir}/*.info*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libgsasl.so
173 %{_libdir}/libgsasl.la
174 %{_includedir}/gsasl*.h
175 %{_pkgconfigdir}/libgsasl.pc
176 %{_mandir}/man3/*.3*
177 %{_gtkdocdir}/gsasl
178
179 %if %{with static_libs}
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libgsasl.a
183 %endif
This page took 0.040495 seconds and 4 git commands to generate.