]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- without_heimdal bcond added, so one can build gsasl with no Kerberos at all
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     gss             # use gss instead of Heimdal as GSSAPI implementation
5 %bcond_with     kerberos5       # with KERBEROS_V5 mechanism (based on shishi, currently broken)
6 %bcond_without  heimdal         # do not use Heimdal either
7 %bcond_without  ntlm            # without NTLM mechanism
8 %bcond_without  static_libs     # don't build static libraries
9 #
10 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
11 Summary(pl.UTF-8):      GNU SASL - implementacja Simple Authentication and Security Layer
12 Name:           gsasl
13 Version:        1.8.0
14 Release:        1
15 License:        LGPL v2.1+ (library), GPL v3+ (gsasl tool)
16 Group:          Libraries
17 Source0:        http://ftp.gnu.org/gnu/gsasl/%{name}-%{version}.tar.gz
18 # Source0-md5:  982fe54a20016aa46a871c084c990c36
19 Patch0:         %{name}-info.patch
20 Patch1:         %{name}-heimdal-check.patch
21 URL:            http://www.gnu.org/software/gsasl/
22 BuildRequires:  autoconf >= 2.61
23 BuildRequires:  automake >= 1:1.10
24 BuildRequires:  docbook-dtd412-xml
25 BuildRequires:  gettext-devel >= 0.18.1
26 BuildRequires:  gnutls-devel >= 1.2.0
27 %{?with_gss:BuildRequires:      gss-devel >= 1.0.0}
28 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.1}
29 BuildRequires:  libgcrypt-devel >= 1.3.0
30 BuildRequires:  libidn-devel >= 0.1.0
31 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
32 BuildRequires:  libtool >= 2:1.5
33 BuildRequires:  pkgconfig
34 %if %{without gss}
35 # alternatively, gss or krb5 can be used for GSSAPI
36 %{?with_heimdal:BuildRequires:  heimdal-devel}
37 %endif
38 %{?with_kerberos5:BuildRequires:        shishi-devel}
39 BuildRequires:  texinfo
40 Requires(post,postun):  /sbin/ldconfig
41 Requires:       libgcrypt >= 1.3.0
42 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
43 Obsoletes:      libgsasl
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 GNU SASL is an implementation of the Simple Authentication and
48 Security Layer framework and a few common SASL mechanisms. SASL is
49 used by network servers (e.g., IMAP, SMTP) to request authentication
50 from clients, and in clients to authenticate against servers.
51
52 GNU SASL contains a library (`libgsasl'), a command line utility
53 (`gsasl') to access the library from the shell, and a manual. The
54 library includes support for the SASL framework (with authentication
55 functions and application data privacy and integrity functions) and at
56 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
57 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
58
59 The library is portable because it does not do network communication
60 by itself, but rather leaves it up to the calling application. The
61 library is flexible with regards to the authorization infrastructure
62 used, as it utilizes callbacks into the application to decide whether
63 an user is authorized or not.
64
65 %description -l pl.UTF-8
66 GNU SASL to implementacja szkieletu Simple Authentication and Security
67 Layer (prostej warstwy uwierzytelniania i bezpieczeństwa) oraz kilku
68 popularnych mechanizmów SASL. SASL jest używane przez serwery sieciowe
69 (np. IMAP i SMTP) do żądania uwierzytelnienia od klientów oraz w
70 klientach do uwierzytelniania względem serwerów.
71
72 GNU SASL zawiera bibliotekę (libgsasl), narzędzie działające z linii
73 poleceń (gsasl) pozwalające na korzystanie z biblioteki z poziomu
74 powłoki oraz dokumentację. Biblioteka ma obsługę szkieletu SASL (z
75 funkcjami uwierzytelniającymi oraz zapewniającymi prywatność i
76 spójność danych aplikacji) oraz przynajmniej częściową obsługę
77 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
78 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
79
80 Biblioteka jest przenośna, ponieważ sama nie korzysta z komunikacji
81 sieciowej, pozostawiając to wywołującej ją aplikacji. Biblioteka jest
82 elastyczna ze względu na używaną infrastrukturę uwierzytelniania,
83 ponieważ korzysta z callbacków w aplikacji przy decydowaniu, czy
84 użytkownik jest autoryzowany.
85
86 %package devel
87 Summary:        Header files for GNU SASL library
88 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GNU SASL
89 License:        LGPL v2.1+
90 Group:          Development/Libraries
91 Requires:       %{name} = %{version}-%{release}
92 %if %{with gss}
93 Requires:       gss-devel >= 1.0.0
94 %else
95 %{?with_heimdal:Requires:       heimdal-devel}
96 %endif
97 Requires:       libgcrypt-devel >= 1.3.0
98 Requires:       libidn-devel >= 0.1.0
99 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
100 %{?with_kerberos5:Requires:     shishi-devel}
101 Obsoletes:      libgsasl-devel
102
103 %description devel
104 Header files for GNU SASL library.
105
106 %description devel -l pl.UTF-8
107 Pliki nagłówkowe biblioteki GNU SASL.
108
109 %package static
110 Summary:        Static GNU SASL library
111 Summary(pl.UTF-8):      Statyczna biblioteka GNU SASL
112 License:        LGPL v2.1+
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115 Obsoletes:      libgsasl-static
116
117 %description static
118 Static GNU SASL library.
119
120 %description static -l pl.UTF-8
121 Statyczna biblioteka GNU SASL.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127
128 %{__rm} po/stamp-po
129
130 # remove it when "linking libtool libraries using a non-POSIX archiver ..." warning is gone
131 # (after gsasl or libtool change)
132 %{__sed} -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac lib/configure.ac
133
134 %build
135 %{__gettextize}
136 %{__libtoolize}
137 %{__aclocal} -I m4 -I gl/m4
138 %{__autoconf}
139 %{__autoheader}
140 %{__automake}
141 cd lib
142 %{__libtoolize}
143 %{__aclocal} -I m4 -I gl/m4
144 %{__autoconf}
145 %{__autoheader}
146 %{__automake}
147 cd -
148 %configure \
149         --disable-silent-rules \
150         %{?with_apidocs:--enable-gtk-doc} \
151         %{!?with_ntlm:--disable-ntlm} \
152         %{!?with_static_libs:--disable-static} \
153         %{?with_kerberos5:--enable-kerberos_v5} \
154 %if %{with gss}
155         --with-gssapi-impl=gss
156 %else
157         %{?with_heimdal:--with-gssapi-impl=heimdal} \
158         %{!?with_heimdal:--with-gssapi-impl=no} \
159 %endif
160         --with-html-dir=%{_gtkdocdir} \
161         --with-libgcrypt
162
163 %{__make}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 # libgsasl for lib, gsasl for app
172 %find_lang %{name} --all-name
173
174 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post
180 /sbin/ldconfig
181 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
182
183 %postun
184 /sbin/ldconfig
185 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
186
187 %files -f %{name}.lang
188 %defattr(644,root,root,755)
189 %doc AUTHORS ChangeLog NEWS README* THANKS
190 %attr(755,root,root) %{_bindir}/gsasl
191 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
192 %attr(755,root,root) %ghost %{_libdir}/libgsasl.so.7
193 %{_mandir}/man1/gsasl.1*
194 %{_infodir}/gsasl.info*
195
196 %files devel
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_libdir}/libgsasl.so
199 %{_libdir}/libgsasl.la
200 %{_includedir}/gsasl*.h
201 %{_pkgconfigdir}/libgsasl.pc
202 %{_mandir}/man3/gsasl_*.3*
203 %{?with_apidocs:%{_gtkdocdir}/gsasl}
204
205 %if %{with static_libs}
206 %files static
207 %defattr(644,root,root,755)
208 %{_libdir}/libgsasl.a
209 %endif
This page took 0.046774 seconds and 4 git commands to generate.