]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- readded pl.po-update patch
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_with     gss             # use gss instead of MIT as GSSAPI implementation
4 %bcond_with     kerberos5       # with KERBEROS_V5 mechanism (based on shishi, currently broken)
5 %bcond_without  ntlm            # without NTLM mechanism
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
9 Summary(pl.UTF-8):      GNU SASL - implementacja Simple Authentication and Security Layer
10 Name:           gsasl
11 Version:        0.2.26
12 Release:        1
13 License:        LGPL v2.1+ (library), GPL v3+ (gsasl tool)
14 Group:          Libraries
15 Source0:        http://josefsson.org/gsasl/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  1debd9f67068ffbf73fa6ca4e4e2ffd4
17 Patch0:         %{name}-info.patch
18 Patch1:         %{name}-pl.po-update.patch
19 URL:            http://www.gnu.org/software/gsasl/
20 BuildRequires:  autoconf >= 2.61
21 BuildRequires:  automake >= 1:1.10
22 BuildRequires:  gettext-devel >= 0.16.1
23 BuildRequires:  gnutls-devel >= 1.2.0
24 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
25 BuildRequires:  gtk-doc >= 1.1
26 BuildRequires:  libgcrypt-devel >= 1.3.0
27 BuildRequires:  libidn-devel >= 0.1.0
28 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  pkgconfig
31 # alternatively, gss or heimdal can be used for GSSAPI
32 %{!?with_gss:BuildRequires:     krb5-devel}
33 %{?with_kerberos5:BuildRequires:        shishi-devel}
34 BuildRequires:  texinfo
35 Requires(post,postun):  /sbin/ldconfig
36 Requires:       libgcrypt >= 1.3.0
37 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
38 Obsoletes:      libgsasl
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GNU SASL is an implementation of the Simple Authentication and
43 Security Layer framework and a few common SASL mechanisms. SASL is
44 used by network servers (e.g., IMAP, SMTP) to request authentication
45 from clients, and in clients to authenticate against servers.
46
47 GNU SASL contains a library (`libgsasl'), a command line utility
48 (`gsasl') to access the library from the shell, and a manual. The
49 library includes support for the SASL framework (with authentication
50 functions and application data privacy and integrity functions) and at
51 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
52 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
53
54 The library is portable because it does not do network communication
55 by itself, but rather leaves it up to the calling application. The
56 library is flexible with regards to the authorization infrastructure
57 used, as it utilizes callbacks into the application to decide whether
58 an user is authorized or not.
59
60 %description -l pl.UTF-8
61 GNU SASL to implementacja szkieletu Simple Authentication and Security
62 Layer (prostej warstwy uwierzytelniania i bezpieczeństwa) oraz kilku
63 popularnych mechanizmów SASL. SASL jest używane przez serwery sieciowe
64 (np. IMAP i SMTP) do żądania uwierzytelnienia od klientów oraz w
65 klientach do uwierzytelniania względem serwerów.
66
67 GNU SASL zawiera bibliotekę (libgsasl), narzędzie działające z linii
68 poleceń (gsasl) pozwalające na korzystanie z biblioteki z poziomu
69 powłoki oraz dokumentację. Biblioteka ma obsługę szkieletu SASL (z
70 funkcjami uwierzytelniającymi oraz zapewniającymi prywatność i
71 spójność danych aplikacji) oraz przynajmniej częściową obsługę
72 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
73 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
74
75 Biblioteka jest przenośna, ponieważ sama nie korzysta z komunikacji
76 sieciowej, pozostawiając to wywołującej ją aplikacji. Biblioteka jest
77 elastyczna ze względu na używaną infrastrukturę uwierzytelniania,
78 ponieważ korzysta z callbacków w aplikacji przy decydowaniu, czy
79 użytkownik jest autoryzowany.
80
81 %package devel
82 Summary:        Header files for GNU SASL library
83 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GNU SASL
84 License:        LGPL v2.1+
85 Group:          Development/Libraries
86 Requires:       %{name} = %{version}-%{release}
87 %{?with_gss:Requires:   gss-devel >= 0.0.0}
88 Requires:       libgcrypt-devel >= 1.3.0
89 Requires:       libidn-devel >= 0.1.0
90 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
91 %{!?with_gss:Requires:  krb5-devel}
92 %{?with_kerberos5:Requires:     shishi-devel}
93 Obsoletes:      libgsasl-devel
94
95 %description devel
96 Header files for GNU SASL library.
97
98 %description devel -l pl.UTF-8
99 Pliki nagłówkowe biblioteki GNU SASL.
100
101 %package static
102 Summary:        Static GNU SASL library
103 Summary(pl.UTF-8):      Statyczna biblioteka GNU SASL
104 License:        LGPL v2.1+
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{version}-%{release}
107 Obsoletes:      libgsasl-static
108
109 %description static
110 Static GNU SASL library.
111
112 %description static -l pl.UTF-8
113 Statyczna biblioteka GNU SASL.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %patch1 -p1
119
120 rm -f po/stamp-po
121
122 %build
123 %{__gettextize}
124 %{__libtoolize}
125 %{__aclocal} -I m4 -I gl/m4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 cd lib
130 %{__libtoolize}
131 %{__aclocal} -I m4 -I gl/m4
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 cd -
136 %configure \
137         --enable-gtk-doc \
138         %{!?with_ntlm:--disable-ntlm} \
139         %{!?with_static_libs:--disable-static} \
140         %{?with_kerberos5:--enable-kerberos_v5} \
141         %{!?with_gss:--with-gssapi-impl=mit} \
142         --with-html-dir=%{_gtkdocdir} \
143         --with-libgcrypt
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 # libgsasl for lib, gsasl for app
154 %find_lang %{name} --all-name
155
156 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post
162 /sbin/ldconfig
163 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
164
165 %postun
166 /sbin/ldconfig
167 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
168
169 %files -f %{name}.lang
170 %defattr(644,root,root,755)
171 %doc AUTHORS ChangeLog NEWS README* THANKS
172 %attr(755,root,root) %{_bindir}/gsasl
173 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libgsasl.so.7
175 %{_mandir}/man1/gsasl.1*
176 %{_infodir}/gsasl.info*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libgsasl.so
181 %{_libdir}/libgsasl.la
182 %{_includedir}/gsasl*.h
183 %{_pkgconfigdir}/libgsasl.pc
184 %{_mandir}/man3/gsasl_*.3*
185 %{_gtkdocdir}/gsasl
186
187 %if %{with static_libs}
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/libgsasl.a
191 %endif
This page took 0.062169 seconds and 4 git commands to generate.