]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- release 2
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     gss             # use gss instead of MIT as GSSAPI implementation
5 %bcond_with     kerberos5       # with KERBEROS_V5 mechanism (based on shishi, currently broken)
6 %bcond_without  ntlm            # without NTLM mechanism
7 %bcond_without  static_libs     # don't build static libraries
8 #
9 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
10 Summary(pl.UTF-8):      GNU SASL - implementacja Simple Authentication and Security Layer
11 Name:           gsasl
12 Version:        1.0
13 Release:        2
14 License:        LGPL v2.1+ (library), GPL v3+ (gsasl tool)
15 Group:          Libraries
16 Source0:        http://ftp.gnu.org/gnu/gsasl/%{name}-%{version}.tar.gz
17 # Source0-md5:  eb7a0be5b5c5715823bb5338315d1d3c
18 Patch0:         %{name}-info.patch
19 URL:            http://www.gnu.org/software/gsasl/
20 BuildRequires:  autoconf >= 2.61
21 BuildRequires:  automake >= 1:1.10
22 BuildRequires:  gettext-devel >= 0.17
23 BuildRequires:  gnutls-devel >= 1.2.0
24 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
25 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.1}
26 BuildRequires:  libgcrypt-devel >= 1.3.0
27 BuildRequires:  libidn-devel >= 0.1.0
28 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  pkgconfig
31 # alternatively, gss or heimdal can be used for GSSAPI
32 %{!?with_gss:BuildRequires:     krb5-devel}
33 %{?with_kerberos5:BuildRequires:        shishi-devel}
34 BuildRequires:  texinfo
35 Requires(post,postun):  /sbin/ldconfig
36 Requires:       libgcrypt >= 1.3.0
37 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
38 Obsoletes:      libgsasl
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GNU SASL is an implementation of the Simple Authentication and
43 Security Layer framework and a few common SASL mechanisms. SASL is
44 used by network servers (e.g., IMAP, SMTP) to request authentication
45 from clients, and in clients to authenticate against servers.
46
47 GNU SASL contains a library (`libgsasl'), a command line utility
48 (`gsasl') to access the library from the shell, and a manual. The
49 library includes support for the SASL framework (with authentication
50 functions and application data privacy and integrity functions) and at
51 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
52 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
53
54 The library is portable because it does not do network communication
55 by itself, but rather leaves it up to the calling application. The
56 library is flexible with regards to the authorization infrastructure
57 used, as it utilizes callbacks into the application to decide whether
58 an user is authorized or not.
59
60 %description -l pl.UTF-8
61 GNU SASL to implementacja szkieletu Simple Authentication and Security
62 Layer (prostej warstwy uwierzytelniania i bezpieczeństwa) oraz kilku
63 popularnych mechanizmów SASL. SASL jest używane przez serwery sieciowe
64 (np. IMAP i SMTP) do żądania uwierzytelnienia od klientów oraz w
65 klientach do uwierzytelniania względem serwerów.
66
67 GNU SASL zawiera bibliotekę (libgsasl), narzędzie działające z linii
68 poleceń (gsasl) pozwalające na korzystanie z biblioteki z poziomu
69 powłoki oraz dokumentację. Biblioteka ma obsługę szkieletu SASL (z
70 funkcjami uwierzytelniającymi oraz zapewniającymi prywatność i
71 spójność danych aplikacji) oraz przynajmniej częściową obsługę
72 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
73 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
74
75 Biblioteka jest przenośna, ponieważ sama nie korzysta z komunikacji
76 sieciowej, pozostawiając to wywołującej ją aplikacji. Biblioteka jest
77 elastyczna ze względu na używaną infrastrukturę uwierzytelniania,
78 ponieważ korzysta z callbacków w aplikacji przy decydowaniu, czy
79 użytkownik jest autoryzowany.
80
81 %package devel
82 Summary:        Header files for GNU SASL library
83 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GNU SASL
84 License:        LGPL v2.1+
85 Group:          Development/Libraries
86 Requires:       %{name} = %{version}-%{release}
87 %{?with_gss:Requires:   gss-devel >= 0.0.0}
88 Requires:       libgcrypt-devel >= 1.3.0
89 Requires:       libidn-devel >= 0.1.0
90 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
91 %{!?with_gss:Requires:  krb5-devel}
92 %{?with_kerberos5:Requires:     shishi-devel}
93 Obsoletes:      libgsasl-devel
94
95 %description devel
96 Header files for GNU SASL library.
97
98 %description devel -l pl.UTF-8
99 Pliki nagłówkowe biblioteki GNU SASL.
100
101 %package static
102 Summary:        Static GNU SASL library
103 Summary(pl.UTF-8):      Statyczna biblioteka GNU SASL
104 License:        LGPL v2.1+
105 Group:          Development/Libraries
106 Requires:       %{name}-devel = %{version}-%{release}
107 Obsoletes:      libgsasl-static
108
109 %description static
110 Static GNU SASL library.
111
112 %description static -l pl.UTF-8
113 Statyczna biblioteka GNU SASL.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118
119 rm -f po/stamp-po
120
121 %build
122 %{__gettextize}
123 %{__libtoolize}
124 %{__aclocal} -I m4 -I gl/m4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 cd lib
129 %{__libtoolize}
130 %{__aclocal} -I m4 -I gl/m4
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 cd -
135 %configure \
136         %{?with_apidocs:--enable-gtk-doc} \
137         %{!?with_ntlm:--disable-ntlm} \
138         %{!?with_static_libs:--disable-static} \
139         %{?with_kerberos5:--enable-kerberos_v5} \
140         %{!?with_gss:--with-gssapi-impl=mit} \
141         --with-html-dir=%{_gtkdocdir} \
142         --with-libgcrypt
143
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 # libgsasl for lib, gsasl for app
153 %find_lang %{name} --all-name
154
155 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post
161 /sbin/ldconfig
162 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
163
164 %postun
165 /sbin/ldconfig
166 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
167
168 %files -f %{name}.lang
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog NEWS README* THANKS
171 %attr(755,root,root) %{_bindir}/gsasl
172 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
173 %attr(755,root,root) %ghost %{_libdir}/libgsasl.so.7
174 %{_mandir}/man1/gsasl.1*
175 %{_infodir}/gsasl.info*
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libgsasl.so
180 %{_libdir}/libgsasl.la
181 %{_includedir}/gsasl*.h
182 %{_pkgconfigdir}/libgsasl.pc
183 %{_mandir}/man3/gsasl_*.3*
184 %{?with_apidocs:%{_gtkdocdir}/gsasl}
185
186 %if %{with static_libs}
187 %files static
188 %defattr(644,root,root,755)
189 %{_libdir}/libgsasl.a
190 %endif
This page took 0.994446 seconds and 4 git commands to generate.