]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- consistent libgcrypt deps
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_with     gss             # use gss instead of MIT as GSSAPI implementation
4 %bcond_with     kerberos5       # with KERBEROS_V5 mechanism (based on shishi, currently broken)
5 %bcond_without  ntlm            # without NTLM mechanism
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
9 Summary(pl.UTF-8):      GNU SASL - implementacja Simple Authentication and Security Layer
10 Name:           gsasl
11 Version:        0.2.26
12 Release:        1
13 License:        LGPL v2.1+ (library), GPL v3+ (gsasl tool)
14 Group:          Libraries
15 Source0:        http://josefsson.org/gsasl/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  1debd9f67068ffbf73fa6ca4e4e2ffd4
17 Patch0:         %{name}-info.patch
18 URL:            http://www.gnu.org/software/gsasl/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake >= 1:1.10
21 BuildRequires:  gettext-devel >= 0.16.1
22 BuildRequires:  gnutls-devel >= 1.2.0
23 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
24 BuildRequires:  gtk-doc >= 1.1
25 BuildRequires:  libgcrypt-devel >= 1.3.0
26 BuildRequires:  libidn-devel >= 0.1.0
27 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
28 BuildRequires:  libtool >= 2:1.5
29 BuildRequires:  pkgconfig
30 # alternatively, gss or heimdal can be used for GSSAPI
31 %{!?with_gss:BuildRequires:     krb5-devel}
32 %{?with_kerberos5:BuildRequires:        shishi-devel}
33 BuildRequires:  texinfo
34 Requires(post,postun):  /sbin/ldconfig
35 Requires:       libgcrypt >= 1.3.0
36 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
37 Obsoletes:      libgsasl
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 GNU SASL is an implementation of the Simple Authentication and
42 Security Layer framework and a few common SASL mechanisms. SASL is
43 used by network servers (e.g., IMAP, SMTP) to request authentication
44 from clients, and in clients to authenticate against servers.
45
46 GNU SASL contains a library (`libgsasl'), a command line utility
47 (`gsasl') to access the library from the shell, and a manual. The
48 library includes support for the SASL framework (with authentication
49 functions and application data privacy and integrity functions) and at
50 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
51 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
52
53 The library is portable because it does not do network communication
54 by itself, but rather leaves it up to the calling application. The
55 library is flexible with regards to the authorization infrastructure
56 used, as it utilizes callbacks into the application to decide whether
57 an user is authorized or not.
58
59 %description -l pl.UTF-8
60 GNU SASL to implementacja szkieletu Simple Authentication and Security
61 Layer (prostej warstwy uwierzytelniania i bezpieczeństwa) oraz kilku
62 popularnych mechanizmów SASL. SASL jest używane przez serwery sieciowe
63 (np. IMAP i SMTP) do żądania uwierzytelnienia od klientów oraz w
64 klientach do uwierzytelniania względem serwerów.
65
66 GNU SASL zawiera bibliotekę (libgsasl), narzędzie działające z linii
67 poleceń (gsasl) pozwalające na korzystanie z biblioteki z poziomu
68 powłoki oraz dokumentację. Biblioteka ma obsługę szkieletu SASL (z
69 funkcjami uwierzytelniającymi oraz zapewniającymi prywatność i
70 spójność danych aplikacji) oraz przynajmniej częściową obsługę
71 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
72 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
73
74 Biblioteka jest przenośna, ponieważ sama nie korzysta z komunikacji
75 sieciowej, pozostawiając to wywołującej ją aplikacji. Biblioteka jest
76 elastyczna ze względu na używaną infrastrukturę uwierzytelniania,
77 ponieważ korzysta z callbacków w aplikacji przy decydowaniu, czy
78 użytkownik jest autoryzowany.
79
80 %package devel
81 Summary:        Header files for GNU SASL library
82 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GNU SASL
83 License:        LGPL v2.1+
84 Group:          Development/Libraries
85 Requires:       %{name} = %{version}-%{release}
86 %{?with_gss:Requires:   gss-devel >= 0.0.0}
87 Requires:       libgcrypt-devel >= 1.3.0
88 Requires:       libidn-devel >= 0.1.0
89 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
90 %{!?with_gss:Requires:  krb5-devel}
91 %{?with_kerberos5:Requires:     shishi-devel}
92 Obsoletes:      libgsasl-devel
93
94 %description devel
95 Header files for GNU SASL library.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe biblioteki GNU SASL.
99
100 %package static
101 Summary:        Static GNU SASL library
102 Summary(pl.UTF-8):      Statyczna biblioteka GNU SASL
103 License:        LGPL v2.1+
104 Group:          Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106 Obsoletes:      libgsasl-static
107
108 %description static
109 Static GNU SASL library.
110
111 %description static -l pl.UTF-8
112 Statyczna biblioteka GNU SASL.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117
118 rm -f m4/{libtool.m4,lt*} lib/m4/{libtool.m4,lt*}
119
120 %build
121 %{__gettextize}
122 %{__libtoolize}
123 %{__aclocal} -I m4 -I gl/m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 cd lib
128 %{__libtoolize}
129 %{__aclocal} -I m4 -I gl/m4
130 %{__autoconf}
131 %{__autoheader}
132 %{__automake}
133 cd -
134 %configure \
135         --enable-gtk-doc \
136         %{!?with_ntlm:--disable-ntlm} \
137         %{!?with_static_libs:--disable-static} \
138         %{?with_kerberos5:--enable-kerberos_v5} \
139         %{!?with_gss:--with-gssapi-impl=mit} \
140         --with-html-dir=%{_gtkdocdir} \
141         --with-libgcrypt
142
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147
148 %{__make} install \
149         DESTDIR=$RPM_BUILD_ROOT
150
151 # libgsasl for lib, gsasl for app
152 %find_lang %{name} --all-name
153
154 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post
160 /sbin/ldconfig
161 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
162
163 %postun
164 /sbin/ldconfig
165 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
166
167 %files -f %{name}.lang
168 %defattr(644,root,root,755)
169 %doc AUTHORS ChangeLog NEWS README* THANKS
170 %attr(755,root,root) %{_bindir}/gsasl
171 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libgsasl.so.7
173 %{_mandir}/man1/gsasl.1*
174 %{_infodir}/gsasl.info*
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libgsasl.so
179 %{_libdir}/libgsasl.la
180 %{_includedir}/gsasl*.h
181 %{_pkgconfigdir}/libgsasl.pc
182 %{_mandir}/man3/gsasl_*.3*
183 %{_gtkdocdir}/gsasl
184
185 %if %{with static_libs}
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libgsasl.a
189 %endif
This page took 0.050488 seconds and 4 git commands to generate.