]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- updated to 0.0.13
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  gss     # without GSSAPI mechanism
4 %bcond_without  krbv5   # without KERBEROS_V5 mechanism
5 %bcond_without  ntlm    # without NTLM mechanism
6 #
7 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
8 Summary(pl):    GNU SASL - implementacja Simple Authentication and Security Layer
9 Name:           gsasl
10 Version:        0.0.13
11 Release:        1
12 License:        GPL
13 Group:          Libraries
14 Source0:        http://josefsson.org/gsasl/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  6cfeab9a176bb029fdafb652ce1b0e81
16 Patch0:         %{name}-info.patch
17 URL:            http://www.gnu.org/software/gsasl/
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake >= 1.7
20 BuildRequires:  gettext-devel >= 0.12.1
21 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
22 BuildRequires:  gtk-doc >= 1.1
23 BuildRequires:  libgcrypt-devel >= 1.1.42
24 BuildRequires:  libidn-devel >= 0.1.0
25 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.1}
26 BuildRequires:  libtool >= 2:1.5
27 # alternatively, krb5 or heimdal could be used for GSSAPI and KERBEROS_V5
28 %{?with_krbv5:BuildRequires:    shishi-devel >= 0.0.0}
29 BuildRequires:  texinfo
30 Requires(post,postun):  /sbin/ldconfig
31 Obsoletes:      libgsasl
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 GNU SASL is an implementation of the Simple Authentication and
36 Security Layer framework and a few common SASL mechanisms. SASL is
37 used by network servers (e.g., IMAP, SMTP) to request authentication
38 from clients, and in clients to authenticate against servers.
39
40 GNU SASL contains a library (`libgsasl'), a command line utility
41 (`gsasl') to access the library from the shell, and a manual. The
42 library includes support for the SASL framework (with authentication
43 functions and application data privacy and integrity functions) and at
44 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
45 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
46
47 The library is portable because it does not do network communication
48 by itself, but rather leaves it up to the calling application. The
49 library is flexible with regards to the authorization infrastructure
50 used, as it utilizes callbacks into the application to decide whether
51 an user is authorized or not.
52
53 %description -l pl
54 GNU SASL to implementacja szkieletu Simple Authentication and Security
55 Layer (prostej warstwy uwierzytelniania i bezpieczeñstwa) oraz kilku
56 popularnych mechanizmów SASL. SASL jest u¿ywane przez serwery sieciowe
57 (np. IMAP i SMTP) do ¿±dania uwierzytelnienia od klientów oraz w
58 klientach do uwierzytelniania wzglêdem serwerów.
59
60 GNU SASL zawiera bibliotekê (libgsasl), narzêdzie dzia³aj±ce z linii
61 poleceñ (gsasl) pozwalaj±ce na korzystanie z biblioteki z poziomu
62 pow³oki oraz dokumentacjê. Biblioteka ma obs³ugê szkieletu SASL (z
63 funkcjami uwierzytelniaj±cymi oraz zapewniaj±cymi prywatno¶æ i
64 spójno¶æ danych aplikacji) oraz przynajmniej czê¶ciow± obs³ugê
65 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
66 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
67
68 Biblioteka jest przeno¶na, poniewa¿ sama nie korzysta z komunikacji
69 sieciowej, pozostawiaj±c to wywo³uj±cej j± aplikacji. Biblioteka jest
70 elastyczna ze wzglêdu na u¿ywan± infrastrukturê uwierzytelniania,
71 poniewa¿ korzysta z callbacków w aplikacji przy decydowaniu, czy
72 u¿ytkownik jest autoryzowany.
73
74 %package devel
75 Summary:        Header files for GNU SASL library
76 Summary(pl):    Pliki nag³ówkowe biblioteki GNU SASL
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}
79 %{?with_gss:Requires:   gss-devel >= 0.0.0}
80 Requires:       libgcrypt-devel >= 1.1.42
81 Requires:       libidn-devel >= 0.1.0
82 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.1}
83 %{?with_krbv5:Requires: shishi-devel >= 0.0.0}
84 Obsoletes:      libgsasl-devel
85
86 %description devel
87 Header files for GNU SASL library.
88
89 %description devel -l pl
90 Pliki nag³ówkowe biblioteki GNU SASL.
91
92 %package static
93 Summary:        Static GNU SASL library
94 Summary(pl):    Statyczna biblioteka GNU SASL
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}
97 Obsoletes:      libgsasl-static
98
99 %description static
100 Static GNU SASL library.
101
102 %description static -l pl
103 Statyczna biblioteka GNU SASL.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 # incompatible with ksh
110 rm -f m4/libtool.m4
111
112 %build
113 # blegh, lt incompatible with ksh - must rebuild
114 %{__gettextize}
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         %{!?with_gss:--disable-gssapi} \
122         %{!?with_krbv5:--disable-kerberos_v5} \
123         %{!?with_ntlm:--disable-ntlm} \
124         --enable-gtk-doc \
125         --with-html-dir=%{_gtkdocdir}
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %find_lang %{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 /sbin/ldconfig
142 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
143
144 %postun
145 /sbin/ldconfig
146 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README* THANKS
151 %attr(755,root,root) %{_bindir}/gsasl
152 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
153 %{_mandir}/man1/gsasl.1*
154 %{_infodir}/*.info*
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libgsasl.so
159 %{_libdir}/libgsasl.la
160 %{_includedir}/gsasl.h
161 %{_pkgconfigdir}/libgsasl.pc
162 %{_mandir}/man3/*.3*
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libgsasl.a
This page took 0.038108 seconds and 4 git commands to generate.