]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- converted to UTF-8
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  gss             # without GSSAPI mechanism
4 %bcond_without  krbv5           # without KERBEROS_V5 mechanism
5 %bcond_without  ntlm            # without NTLM mechanism
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
9 Summary(pl.UTF-8):   GNU SASL - implementacja Simple Authentication and Security Layer
10 Name:           gsasl
11 Version:        0.2.15
12 Release:        1
13 License:        GPL
14 Group:          Libraries
15 Source0:        http://josefsson.org/gsasl/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  906954c002098370c161ac2c97c4c33e
17 Patch0:         %{name}-info.patch
18 URL:            http://www.gnu.org/software/gsasl/
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake >= 1:1.9
21 BuildRequires:  gettext-devel >= 0.14.1
22 BuildRequires:  gnutls-devel >= 1.2.0
23 %{?with_gss:BuildRequires:      gss-devel >= 0.0.0}
24 BuildRequires:  gtk-doc >= 1.1
25 BuildRequires:  libgcrypt-devel >= 1.1.42
26 BuildRequires:  libidn-devel >= 0.1.0
27 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
28 BuildRequires:  libtool >= 2:1.5
29 BuildRequires:  pkgconfig
30 # alternatively, krb5 or heimdal could be used for GSSAPI and KERBEROS_V5
31 %{?with_krbv5:BuildRequires:    shishi-devel >= 0.0.0}
32 BuildRequires:  texinfo
33 Requires(post,postun):  /sbin/ldconfig
34 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
35 Obsoletes:      libgsasl
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 GNU SASL is an implementation of the Simple Authentication and
40 Security Layer framework and a few common SASL mechanisms. SASL is
41 used by network servers (e.g., IMAP, SMTP) to request authentication
42 from clients, and in clients to authenticate against servers.
43
44 GNU SASL contains a library (`libgsasl'), a command line utility
45 (`gsasl') to access the library from the shell, and a manual. The
46 library includes support for the SASL framework (with authentication
47 functions and application data privacy and integrity functions) and at
48 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
49 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
50
51 The library is portable because it does not do network communication
52 by itself, but rather leaves it up to the calling application. The
53 library is flexible with regards to the authorization infrastructure
54 used, as it utilizes callbacks into the application to decide whether
55 an user is authorized or not.
56
57 %description -l pl.UTF-8
58 GNU SASL to implementacja szkieletu Simple Authentication and Security
59 Layer (prostej warstwy uwierzytelniania i bezpieczeństwa) oraz kilku
60 popularnych mechanizmów SASL. SASL jest używane przez serwery sieciowe
61 (np. IMAP i SMTP) do żądania uwierzytelnienia od klientów oraz w
62 klientach do uwierzytelniania względem serwerów.
63
64 GNU SASL zawiera bibliotekę (libgsasl), narzędzie działające z linii
65 poleceń (gsasl) pozwalające na korzystanie z biblioteki z poziomu
66 powłoki oraz dokumentację. Biblioteka ma obsługę szkieletu SASL (z
67 funkcjami uwierzytelniającymi oraz zapewniającymi prywatność i
68 spójność danych aplikacji) oraz przynajmniej częściową obsługę
69 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
70 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
71
72 Biblioteka jest przenośna, ponieważ sama nie korzysta z komunikacji
73 sieciowej, pozostawiając to wywołującej ją aplikacji. Biblioteka jest
74 elastyczna ze względu na używaną infrastrukturę uwierzytelniania,
75 ponieważ korzysta z callbacków w aplikacji przy decydowaniu, czy
76 użytkownik jest autoryzowany.
77
78 %package devel
79 Summary:        Header files for GNU SASL library
80 Summary(pl.UTF-8):   Pliki nagłówkowe biblioteki GNU SASL
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83 %{?with_gss:Requires:   gss-devel >= 0.0.0}
84 Requires:       libgcrypt-devel >= 1.1.42
85 Requires:       libidn-devel >= 0.1.0
86 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
87 %{?with_krbv5:Requires: shishi-devel >= 0.0.0}
88 Obsoletes:      libgsasl-devel
89
90 %description devel
91 Header files for GNU SASL library.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki GNU SASL.
95
96 %package static
97 Summary:        Static GNU SASL library
98 Summary(pl.UTF-8):   Statyczna biblioteka GNU SASL
99 Group:          Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 Obsoletes:      libgsasl-static
102
103 %description static
104 Static GNU SASL library.
105
106 %description static -l pl.UTF-8
107 Statyczna biblioteka GNU SASL.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112
113 %build
114 %{__gettextize}
115 %{__libtoolize}
116 %{__aclocal} -I m4 -I gl/m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 cd lib
121 %{__libtoolize}
122 %{__aclocal} -I m4 -I gl/m4
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 cd -
127 %configure \
128         --enable-gtk-doc \
129         %{!?with_gss:--disable-gssapi} \
130         %{!?with_krbv5:--disable-kerberos_v5} \
131         %{!?with_ntlm:--disable-ntlm} \
132         %{!?with_static_libs:--disable-static} \
133         --with-html-dir=%{_gtkdocdir} \
134         --with-libgcrypt
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # libgsasl for lib, gsasl for app
145 %find_lang %{name} --all-name
146
147 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 /sbin/ldconfig
154 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
155
156 %postun
157 /sbin/ldconfig
158 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc AUTHORS ChangeLog NEWS README* THANKS
163 %attr(755,root,root) %{_bindir}/gsasl
164 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
165 %{_mandir}/man1/gsasl.1*
166 %{_infodir}/*.info*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libgsasl.so
171 %{_libdir}/libgsasl.la
172 %{_includedir}/gsasl*.h
173 %{_pkgconfigdir}/libgsasl.pc
174 %{_mandir}/man3/*.3*
175 %{_gtkdocdir}/gsasl
176
177 %if %{with static_libs}
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libgsasl.a
181 %endif
This page took 0.046352 seconds and 4 git commands to generate.