]> git.pld-linux.org Git - packages/gsasl.git/blob - gsasl.spec
- updated to 1.6.1
[packages/gsasl.git] / gsasl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     gss             # use gss instead of Heimdal as GSSAPI implementation
5 %bcond_with     kerberos5       # with KERBEROS_V5 mechanism (based on shishi, currently broken)
6 %bcond_without  ntlm            # without NTLM mechanism
7 %bcond_without  static_libs     # don't build static libraries
8 #
9 Summary:        GNU SASL - implementation of the Simple Authentication and Security Layer
10 Summary(pl.UTF-8):      GNU SASL - implementacja Simple Authentication and Security Layer
11 Name:           gsasl
12 Version:        1.6.1
13 Release:        1
14 License:        LGPL v2.1+ (library), GPL v3+ (gsasl tool)
15 Group:          Libraries
16 Source0:        http://ftp.gnu.org/gnu/gsasl/%{name}-%{version}.tar.gz
17 # Source0-md5:  7ae813eeb1f90ad52e9a781ac9e17f28
18 Patch0:         %{name}-info.patch
19 Patch1:         %{name}-heimdal-check.patch
20 URL:            http://www.gnu.org/software/gsasl/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake >= 1:1.10
23 BuildRequires:  docbook-dtd412-xml
24 BuildRequires:  gettext-devel >= 0.18.1
25 BuildRequires:  gnutls-devel >= 1.2.0
26 %{?with_gss:BuildRequires:      gss-devel >= 1.0.0}
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.1}
28 BuildRequires:  libgcrypt-devel >= 1.3.0
29 BuildRequires:  libidn-devel >= 0.1.0
30 %{?with_ntlm:BuildRequires:     libntlm-devel >= 0.3.5}
31 BuildRequires:  libtool >= 2:1.5
32 BuildRequires:  pkgconfig
33 # alternatively, gss or krb5 can be used for GSSAPI
34 %{!?with_gss:BuildRequires:     heimdal-devel}
35 %{?with_kerberos5:BuildRequires:        shishi-devel}
36 BuildRequires:  texinfo
37 Requires(post,postun):  /sbin/ldconfig
38 Requires:       libgcrypt >= 1.3.0
39 %{?with_ntlm:Requires:  libntlm >= 0.3.5}
40 Obsoletes:      libgsasl
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GNU SASL is an implementation of the Simple Authentication and
45 Security Layer framework and a few common SASL mechanisms. SASL is
46 used by network servers (e.g., IMAP, SMTP) to request authentication
47 from clients, and in clients to authenticate against servers.
48
49 GNU SASL contains a library (`libgsasl'), a command line utility
50 (`gsasl') to access the library from the shell, and a manual. The
51 library includes support for the SASL framework (with authentication
52 functions and application data privacy and integrity functions) and at
53 least partial support for the CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS,
54 PLAIN, SECURID, DIGEST-MD5, LOGIN, NTLM and KERBEROS_V5 mechanisms.
55
56 The library is portable because it does not do network communication
57 by itself, but rather leaves it up to the calling application. The
58 library is flexible with regards to the authorization infrastructure
59 used, as it utilizes callbacks into the application to decide whether
60 an user is authorized or not.
61
62 %description -l pl.UTF-8
63 GNU SASL to implementacja szkieletu Simple Authentication and Security
64 Layer (prostej warstwy uwierzytelniania i bezpieczeństwa) oraz kilku
65 popularnych mechanizmów SASL. SASL jest używane przez serwery sieciowe
66 (np. IMAP i SMTP) do żądania uwierzytelnienia od klientów oraz w
67 klientach do uwierzytelniania względem serwerów.
68
69 GNU SASL zawiera bibliotekę (libgsasl), narzędzie działające z linii
70 poleceń (gsasl) pozwalające na korzystanie z biblioteki z poziomu
71 powłoki oraz dokumentację. Biblioteka ma obsługę szkieletu SASL (z
72 funkcjami uwierzytelniającymi oraz zapewniającymi prywatność i
73 spójność danych aplikacji) oraz przynajmniej częściową obsługę
74 mechanizmów CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID,
75 DIGEST-MD5, LOGIN, NTLM oraz KERBEROS_V5.
76
77 Biblioteka jest przenośna, ponieważ sama nie korzysta z komunikacji
78 sieciowej, pozostawiając to wywołującej ją aplikacji. Biblioteka jest
79 elastyczna ze względu na używaną infrastrukturę uwierzytelniania,
80 ponieważ korzysta z callbacków w aplikacji przy decydowaniu, czy
81 użytkownik jest autoryzowany.
82
83 %package devel
84 Summary:        Header files for GNU SASL library
85 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GNU SASL
86 License:        LGPL v2.1+
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89 %{?with_gss:Requires:   gss-devel >= 1.0.0}
90 %{!?with_gss:Requires:  heimdal-devel}
91 Requires:       libgcrypt-devel >= 1.3.0
92 Requires:       libidn-devel >= 0.1.0
93 %{?with_ntlm:Requires:  libntlm-devel >= 0.3.5}
94 %{?with_kerberos5:Requires:     shishi-devel}
95 Obsoletes:      libgsasl-devel
96
97 %description devel
98 Header files for GNU SASL library.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe biblioteki GNU SASL.
102
103 %package static
104 Summary:        Static GNU SASL library
105 Summary(pl.UTF-8):      Statyczna biblioteka GNU SASL
106 License:        LGPL v2.1+
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109 Obsoletes:      libgsasl-static
110
111 %description static
112 Static GNU SASL library.
113
114 %description static -l pl.UTF-8
115 Statyczna biblioteka GNU SASL.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 %patch1 -p1
121
122 %{__rm} po/stamp-po
123
124 %build
125 %{__gettextize}
126 %{__libtoolize}
127 %{__aclocal} -I m4 -I gl/m4
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 cd lib
132 %{__libtoolize}
133 %{__aclocal} -I m4 -I gl/m4
134 %{__autoconf}
135 %{__autoheader}
136 %{__automake}
137 cd -
138 %configure \
139         --disable-silent-rules \
140         %{?with_apidocs:--enable-gtk-doc} \
141         %{!?with_ntlm:--disable-ntlm} \
142         %{!?with_static_libs:--disable-static} \
143         %{?with_kerberos5:--enable-kerberos_v5} \
144         %{!?with_gss:--with-gssapi-impl=heimdal} \
145         --with-html-dir=%{_gtkdocdir} \
146         --with-libgcrypt
147
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 # libgsasl for lib, gsasl for app
157 %find_lang %{name} --all-name
158
159 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post
165 /sbin/ldconfig
166 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
167
168 %postun
169 /sbin/ldconfig
170 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
171
172 %files -f %{name}.lang
173 %defattr(644,root,root,755)
174 %doc AUTHORS ChangeLog NEWS README* THANKS
175 %attr(755,root,root) %{_bindir}/gsasl
176 %attr(755,root,root) %{_libdir}/libgsasl.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libgsasl.so.7
178 %{_mandir}/man1/gsasl.1*
179 %{_infodir}/gsasl.info*
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libgsasl.so
184 %{_libdir}/libgsasl.la
185 %{_includedir}/gsasl*.h
186 %{_pkgconfigdir}/libgsasl.pc
187 %{_mandir}/man3/gsasl_*.3*
188 %{?with_apidocs:%{_gtkdocdir}/gsasl}
189
190 %if %{with static_libs}
191 %files static
192 %defattr(644,root,root,755)
193 %{_libdir}/libgsasl.a
194 %endif
This page took 0.048491 seconds and 3 git commands to generate.