]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
- more rpm macros,
[packages/grep.git] / grep.spec
1 Summary:        GNU grep Utilities
2 Summary(fr):    Utilitaires grep de GNU
3 Summary(pl):    GNU grep 
4 Summary(tr):    Dosyalarda katar arama aracý
5 Name:           grep
6 Version:        2.3
7 Release:        5
8 Copyright:      GPL
9 Group:          Utilities/Text
10 Group(pl):      Narzêdzia/Tekst
11 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
12 Source1:        grep.1.pl
13 Patch0:         grep-info.patch
14 Prereq:         /sbin/install-info
15 Buildroot:      /tmp/%{name}-%{version}-root
16
17 %define _bindir /bin
18
19 %description
20 This is the GNU implementation of the popular `grep' *nix utility. It
21 allows for the fast locating of strings in text files.
22
23 %description -l de
24 Dies ist die GNU-Implementierung des beliebten *nix-Dienstprogramms 'grep'.
25 Damit können schnell Zeichenketten in Textdateien finden.
26
27 %description -l fr
28 Ceci est l'implémentation par GNU du  populaire l'utilitaire grep su *nix.
29 Il permet de localiser rapidement des chaînes de caractéres dans les
30 fichiers.
31
32 %description -l pl 
33 GNU grep jest implementacj± popularnego programu unixowego `grep'. Grep jest
34 jednym z podstawowych narzêdzi, korzysta z niego prawie ka¿dy skrypt shella.
35
36 %description -l tr
37 Bu, bütün Unix'lerde bulunan ve yaygýn olarak kullanýlan grep aracýnýn GNU
38 sürümüdür. Metin dosyalarý içinde bulunan katarlarý aramada kullanýlýr.
39
40 %prep
41 %setup  -q
42 %patch0 -p1
43
44 %build
45 gettextize --force --copy
46 autoconf
47 %configure \
48         --prefix=%{_prefix} \
49         --exec-prefix=/
50 make
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_mandir}/pl/man1
55
56 make install-strip DESTDIR=$RPM_BUILD_ROOT
57
58 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/grep.1
59
60 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
61 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
62
63 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/pl/man1/egrep.1
64 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/pl/man1/fgrep.1
65
66 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/{man1/*,pl/man1/*}} \
67         NEWS README ChangeLog TODO
68
69 %find_lang grep
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 /sbin/install-info %{_infodir}/grep.info.gz /etc/info-dir
76
77 %preun
78 if [ "$1" = "0" ]; then
79         /sbin/install-info --delete %{_infodir}/grep.info.gz /etc/info-dir
80 fi
81
82 %files -f grep.lang
83 %defattr(644,root,root,755)
84 %doc {NEWS,README,ChangeLog,TODO}.gz
85
86 %attr(755,root,root) /bin/*
87 %{_mandir}/man1/*
88 %lang(pl) %{_mandir}/pl/man1/*
89 %{_infodir}/*info*
90
91 %changelog
92 * Fri May 21 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
93   [2.3-4]
94 - added more macros.
95
96 * Wed Apr 28 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
97   [2.3-3]
98 - added el .mo file,
99 - added pl man page for grep,
100 - added info pages for grep.
101
102 * Tue Apr 27 1999 Piotr Czerwiñski <pius@pld.org.pl>
103   [2.2-6]
104 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
105 - gzipping documentation,
106 - removed man group from man pages,
107 - replacements in %files,
108 - minor changes,
109 - recompiled on rpm 3.
110
111 * Fri Dec 11 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
112   [2.2-4]
113 - added gzipping man pages,
114 - added using LDFLAGS="-s" to ./configure enviroment.
115
116 * Tue Oct 06 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
117   [2.2-3]
118 - added pl translation,
119 - minor modification of the spec file.
120 - build against GNU libc-2.1,
121 - start at RH spec file.
This page took 0.309753 seconds and 4 git commands to generate.