]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
- run test suite
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # with PCRE support
4 %bcond_without  tests
5 #
6 Summary:        GNU grep Utilities
7 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
8 Summary(es.UTF-8):      Utilitarios grep GNU
9 Summary(fr.UTF-8):      Utilitaires grep de GNU
10 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
11 Summary(pl.UTF-8):      GNU grep
12 Summary(pt_BR.UTF-8):   Utilitários grep GNU
13 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
14 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
15 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
16 Name:           grep
17 Version:        2.5.4
18 Release:        3
19 Epoch:          2
20 License:        GPL v3+
21 Group:          Applications/Text
22 Source0:        http://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.gz
23 # Source0-md5:  92258031d98d4f12dfc6a6d24057e672
24 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
26 Patch0:         %{name}-info.patch
27 Patch1:         %{name}-strerror.patch
28 # from debian; very important for multibytes locale; see https://savannah.gnu.org/bugs/?14472
29 Patch2:         %{name}-egf-speedup.patch
30 Patch3:         %{name}-match_icase.patch
31 Patch4:         %{name}-pl.po-update.patch
32 URL:            http://www.gnu.org/software/grep/grep.html
33 BuildRequires:  autoconf >= 2.53
34 BuildRequires:  automake
35 BuildRequires:  gettext-devel
36 BuildRequires:  libtool
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  texinfo
39 %{?with_pcre:Requires:  pcre}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _bindir         /bin
43 %define         _exec_prefix    /
44
45 %description
46 The GNU versions of commonly used grep utilities. Grep searches one or
47 more input files for lines which contain a match to a specified
48 pattern and then prints the matching lines. GNU's grep utilities
49 include grep, egrep and fgrep.
50
51 %description -l de.UTF-8
52 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
53 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
54 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
55 enthält grep, egrep und fgrep.
56
57 %description -l es.UTF-8
58 Esta es la implementación GNU del popular utilitario grep. Permite la
59 localización rápida de strings en archivos texto.
60
61 %description -l fr.UTF-8
62 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
63 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
64 les fichiers.
65
66 %description -l ja.UTF-8
67 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
68 イトパッチ(mb1.04)によって日本語対応にしたものです.
69
70 %description -l pl.UTF-8
71 GNU grep jest implementacją popularnego programu uniksowego `grep'.
72 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
73 każdy skrypt shella.
74
75 %description -l pt_BR.UTF-8
76 Esta é a implementação GNU do popular utilitário grep. Permite a
77 localização rápida de strings em arquivos texto.
78
79 %description -l ru.UTF-8
80 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
81 по образцу в текстовых файлах.
82
83 %description -l tr.UTF-8
84 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
85 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
86 kullanılır.
87
88 %description -l uk.UTF-8
89 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
90 пошуку по шаблону в текстових файлах.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p0
97 %patch3 -p0
98 %patch4 -p1
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I m4
103 %{__automake}
104 %{__autoheader}
105 %{__autoconf}
106 %configure \
107         %{!?with_pcre:--disable-perl-regexp} \
108         --without-included-regex \
109         --enable-nls
110 %{__make}
111
112 %{?with_tests:%{__make} check}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT/etc/env.d
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
122 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
123
124 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
125
126 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
127 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
128 EOF
129
130 %find_lang %{name}
131
132 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
133 rm -f $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
134 rm -f $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post -p /sbin/postshell
140 -/usr/sbin/fix-info-dir -c %{_infodir}
141 -/sbin/env-update -u
142
143 %postun -p /sbin/postshell
144 -/usr/sbin/fix-info-dir -c %{_infodir}
145 -/sbin/env-update -u
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc NEWS README ChangeLog TODO
150 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
151 %attr(755,root,root) %{_bindir}/*
152 %{_mandir}/man1/*
153 %lang(cs) %{_mandir}/cs/man1/*
154 %lang(de) %{_mandir}/de/man1/*
155 %lang(es) %{_mandir}/es/man1/*
156 %lang(fi) %{_mandir}/fi/man1/*
157 %lang(fr) %{_mandir}/fr/man1/*
158 %lang(hu) %{_mandir}/hu/man1/*
159 %lang(it) %{_mandir}/it/man1/*
160 %lang(ja) %{_mandir}/ja/man1/*
161 %lang(nl) %{_mandir}/nl/man1/*
162 %lang(pl) %{_mandir}/pl/man1/*
163 %{_infodir}/*info*
This page took 0.044867 seconds and 4 git commands to generate.