]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
ebc3423d8cb1168e1f5ea7dde5b4be694868ed49
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_with     pcre    # PCRE support
4 #
5 Summary:        GNU grep Utilities
6 Summary(de):    GNU-Version der Pattern-Matching-Utilities
7 Summary(es):    Utilitarios grep GNU
8 Summary(fr):    Utilitaires grep de GNU
9 Summary(ja):    GNU grep ¤ÎÆüËܸìÂбþÈǤǤ¹.
10 Summary(pl):    GNU grep
11 Summary(pt_BR): Utilitários grep GNU
12 Summary(ru):    õÔÉÌÉÔÙ ÐÏÉÓËÁ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
13 Summary(tr):    Dosyalarda katar arama aracý
14 Summary(uk):    õÔÉ̦ÔÉ ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
15 Name:           grep
16 Version:        2.5.1
17 Release:        10
18 Epoch:          2
19 License:        GPL
20 Group:          Applications/Text
21 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
22 # Source0-md5:  ae69f8112cdc63615cefe944f38bbee7
23 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-egrep.patch
27 %{?with_pcre:BuildRequires:     pcre-devel}
28 %{?with_pcre:Requires:  pcre}
29 BuildRequires:  gettext-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  automake
32 BuildRequires:  autoconf
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _bindir         /bin
36 %define         _exec_prefix    /
37
38 %description
39 The GNU versions of commonly used grep utilities. Grep searches one or
40 more input files for lines which contain a match to a specified
41 pattern and then prints the matching lines. GNU's grep utilities
42 include grep, egrep and fgrep.
43
44 %description -l de
45 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
46 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
47 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
48 enthält grep, egrep und fgrep.
49
50 %description -l es
51 Esta es la implementación GNU del popular utilitario grep. Permite la
52 localización rápida de strings en archivos texto.
53
54 %description -l fr
55 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
56 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
57 les fichiers.
58
59 %description -l ja
60 GNU ¥×¥í¥¸¥§¥¯¥È¤Ë¤è¤ë grep, egrep, fgrep (°Ê²¼Ã±¤Ë grep) ¤ò¥Þ¥ë¥Á¥Ð
61 ¥¤¥È¥Ñ¥Ã¥Á(mb1.04)¤Ë¤è¤Ã¤ÆÆüËܸìÂбþ¤Ë¤·¤¿¤â¤Î¤Ç¤¹.
62
63 %description -l pl
64 GNU grep jest implementacj± popularnego programu uniksowego `grep'.
65 Grep jest jednym z podstawowych narzêdzi, korzysta z niego prawie
66 ka¿dy skrypt shella.
67
68 %description -l pt_BR
69 Esta é a implementação GNU do popular utilitário grep. Permite a
70 localização rápida de strings em arquivos texto.
71
72 %description -l ru
73 üÔÏ ÒÅÁÌÉÚÁÃÉÑ GNU ÕÔÉÌÉÔÙ grep, ÐÒÅÄÎÁÚÎÁÞÅÎÎÏÊ ÄÌÑ ÂÙÓÔÒÏÇÏ ÐÏÉÓËÁ
74 ÐÏ ÏÂÒÁÚÃÕ × ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÁÈ.
75
76 %description -l tr
77 Bu, bütün Unix'lerde bulunan ve yaygýn olarak kullanýlan grep aracýnýn
78 GNU sürümüdür. Metin dosyalarý içinde bulunan katarlarý aramada
79 kullanýlýr.
80
81 %description -l uk
82 ãÅ GNU ÒÅÁ̦ÚÁæѠÐÏÐÕÌÑÒÎϧ ÕÔÉ̦ÔÉ grep, ÐÒÉÚÎÁÞÅÎϧ ÄÌÑ Û×ÉÄËÏÇÏ
83 ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÕ × ÔÅËÓÔÏ×ÉÈ ÆÁÊÌÁÈ.
84
85 %prep
86 %setup  -q
87 %patch0 -p1
88 %patch1 -p1
89
90 rm -f m4/{header,init}.m4
91
92 # hack: AC_FUNC_STRERROR_R from strerror_r.m4 must override autoconf's version
93 # (it contains HAVE_WORKING_STRERROR_R define, needed with glibc 2.x, as
94 #  glibc version returns pointer to string and doesn't seem to store string in
95 #  supplied buffer(???))
96 cat m4/strerror_r.m4 >> acinclude.m4
97 touch m4/{header,init}.m4
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__automake}
103 %{__autoconf}
104 %ifarch sparc sparc64
105 CPPFLAGS=""
106 export CPPFLAGS
107 %endif
108 %configure \
109         %{!?with_pcre:--disable-perl-regexp} \
110         --without-included-regex \
111         --enable-nls
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT/etc/env.d
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
122 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
123
124 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
125
126 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
127 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
128 EOF
129
130 %find_lang %{name}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post
136 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
137
138 %postun
139 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
140
141 %files -f %{name}.lang
142 %defattr(644,root,root,755)
143 %doc NEWS README ChangeLog TODO
144 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/*
145 %attr(755,root,root) %{_bindir}/*
146 %{_mandir}/man1/*
147 %lang(cs) %{_mandir}/cs/man1/*
148 %lang(de) %{_mandir}/de/man1/*
149 %lang(es) %{_mandir}/es/man1/*
150 %lang(fi) %{_mandir}/fi/man1/*
151 %lang(fr) %{_mandir}/fr/man1/*
152 %lang(hu) %{_mandir}/hu/man1/*
153 %lang(it) %{_mandir}/it/man1/*
154 %lang(ja) %{_mandir}/ja/man1/*
155 %lang(nl) %{_mandir}/nl/man1/*
156 %lang(pl) %{_mandir}/pl/man1/*
157 %{_infodir}/*info*
This page took 0.087632 seconds and 3 git commands to generate.