]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
c18edc6722ffacce71656d140dbd9d150c19b539
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_with     pcre    # with PCRE support
4 #
5 Summary:        GNU grep Utilities
6 Summary(de):    GNU-Version der Pattern-Matching-Utilities
7 Summary(es):    Utilitarios grep GNU
8 Summary(fr):    Utilitaires grep de GNU
9 Summary(ja):    GNU grep ¤ÎÆüËܸìÂбþÈǤǤ¹.
10 Summary(pl):    GNU grep
11 Summary(pt_BR): Utilitários grep GNU
12 Summary(ru):    õÔÉÌÉÔÙ ÐÏÉÓËÁ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
13 Summary(tr):    Dosyalarda katar arama aracý
14 Summary(uk):    õÔÉ̦ÔÉ ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
15 Name:           grep
16 Version:        2.5.1
17 Release:        12
18 Epoch:          2
19 License:        GPL
20 Group:          Applications/Text
21 Source0:        ftp://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.gz
22 # Source0-md5:  ae69f8112cdc63615cefe944f38bbee7
23 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-egrep.patch
27 Patch2:         %{name}-locale-names.patch
28 %{?with_pcre:BuildRequires:     pcre-devel}
29 BuildRequires:  gettext-devel
30 BuildRequires:  automake
31 BuildRequires:  autoconf
32 %{?with_pcre:Requires:  pcre}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _bindir         /bin
36 %define         _exec_prefix    /
37
38 %description
39 The GNU versions of commonly used grep utilities. Grep searches one or
40 more input files for lines which contain a match to a specified
41 pattern and then prints the matching lines. GNU's grep utilities
42 include grep, egrep and fgrep.
43
44 %description -l de
45 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
46 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
47 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
48 enthält grep, egrep und fgrep.
49
50 %description -l es
51 Esta es la implementación GNU del popular utilitario grep. Permite la
52 localización rápida de strings en archivos texto.
53
54 %description -l fr
55 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
56 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
57 les fichiers.
58
59 %description -l ja
60 GNU ¥×¥í¥¸¥§¥¯¥È¤Ë¤è¤ë grep, egrep, fgrep (°Ê²¼Ã±¤Ë grep) ¤ò¥Þ¥ë¥Á¥Ð
61 ¥¤¥È¥Ñ¥Ã¥Á(mb1.04)¤Ë¤è¤Ã¤ÆÆüËܸìÂбþ¤Ë¤·¤¿¤â¤Î¤Ç¤¹.
62
63 %description -l pl
64 GNU grep jest implementacj± popularnego programu uniksowego `grep'.
65 Grep jest jednym z podstawowych narzêdzi, korzysta z niego prawie
66 ka¿dy skrypt shella.
67
68 %description -l pt_BR
69 Esta é a implementação GNU do popular utilitário grep. Permite a
70 localização rápida de strings em arquivos texto.
71
72 %description -l ru
73 üÔÏ ÒÅÁÌÉÚÁÃÉÑ GNU ÕÔÉÌÉÔÙ grep, ÐÒÅÄÎÁÚÎÁÞÅÎÎÏÊ ÄÌÑ ÂÙÓÔÒÏÇÏ ÐÏÉÓËÁ
74 ÐÏ ÏÂÒÁÚÃÕ × ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÁÈ.
75
76 %description -l tr
77 Bu, bütün Unix'lerde bulunan ve yaygýn olarak kullanýlan grep aracýnýn
78 GNU sürümüdür. Metin dosyalarý içinde bulunan katarlarý aramada
79 kullanýlýr.
80
81 %description -l uk
82 ãÅ GNU ÒÅÁ̦ÚÁæѠÐÏÐÕÌÑÒÎϧ ÕÔÉ̦ÔÉ grep, ÐÒÉÚÎÁÞÅÎϧ ÄÌÑ Û×ÉÄËÏÇÏ
83 ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÕ × ÔÅËÓÔÏ×ÉÈ ÆÁÊÌÁÈ.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89 %patch2 -p1
90
91 rm -f m4/{header,init}.m4
92
93 # hack: AC_FUNC_STRERROR_R from strerror_r.m4 must override autoconf's version
94 # (it contains HAVE_WORKING_STRERROR_R define, needed with glibc 2.x, as
95 #  glibc version returns pointer to string and doesn't seem to store string in
96 #  supplied buffer(???))
97 cat m4/strerror_r.m4 >> acinclude.m4
98 touch m4/{header,init}.m4
99
100 # there is nb.po included, but more outdated than no.po (only no was in LINGUAS)
101 mv -f po/{no,nb}.po
102
103 %build
104 %{__libtoolize}
105 %{__aclocal} -I m4
106 %{__automake}
107 %{__autoconf}
108 %ifarch sparc sparc64
109 CPPFLAGS=""
110 export CPPFLAGS
111 %endif
112 %configure \
113         %{!?with_pcre:--disable-perl-regexp} \
114         --without-included-regex \
115         --enable-nls
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 install -d $RPM_BUILD_ROOT/etc/env.d
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
126 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
127
128 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
129
130 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
131 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
132 EOF
133
134 %find_lang %{name}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
141
142 %postun
143 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %doc NEWS README ChangeLog TODO
148 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 size mtime) /etc/env.d/*
149 %attr(755,root,root) %{_bindir}/*
150 %{_mandir}/man1/*
151 %lang(cs) %{_mandir}/cs/man1/*
152 %lang(de) %{_mandir}/de/man1/*
153 %lang(es) %{_mandir}/es/man1/*
154 %lang(fi) %{_mandir}/fi/man1/*
155 %lang(fr) %{_mandir}/fr/man1/*
156 %lang(hu) %{_mandir}/hu/man1/*
157 %lang(it) %{_mandir}/it/man1/*
158 %lang(ja) %{_mandir}/ja/man1/*
159 %lang(nl) %{_mandir}/nl/man1/*
160 %lang(pl) %{_mandir}/pl/man1/*
161 %{_infodir}/*info*
This page took 0.065544 seconds and 3 git commands to generate.