]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
b42047aee0a8c187c00f37efec475a98d5df917d
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # PCRE support
4 %bcond_without  tests   # don't perform "make check"
5 #
6 Summary:        GNU grep Utilities
7 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
8 Summary(es.UTF-8):      Utilitarios grep GNU
9 Summary(fr.UTF-8):      Utilitaires grep de GNU
10 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
11 Summary(pl.UTF-8):      GNU grep
12 Summary(pt_BR.UTF-8):   Utilitários grep GNU
13 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
14 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
15 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
16 Name:           grep
17 Version:        2.20
18 Release:        1
19 Epoch:          2
20 License:        GPL v3+
21 Group:          Applications/Text
22 Source0:        http://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.xz
23 # Source0-md5:  2cbea44a4f1548aee20b9ff2d3076908
24 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
26 Patch0:         %{name}-info.patch
27 Patch1:         %{name}-pl.po-update.patch
28 URL:            http://www.gnu.org/software/grep/grep.html
29 BuildRequires:  autoconf >= 2.59
30 BuildRequires:  automake >= 1:1.11
31 BuildRequires:  gettext-devel >= 0.18.2
32 %{?with_pcre:BuildRequires:     pcre-devel}
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  texinfo
35 BuildRequires:  xz
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _bindir         /bin
39 %define         _exec_prefix    /
40
41 %description
42 The GNU versions of commonly used grep utilities. Grep searches one or
43 more input files for lines which contain a match to a specified
44 pattern and then prints the matching lines. GNU's grep utilities
45 include grep, egrep and fgrep.
46
47 %description -l de.UTF-8
48 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
49 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
50 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
51 enthält grep, egrep und fgrep.
52
53 %description -l es.UTF-8
54 Esta es la implementación GNU del popular utilitario grep. Permite la
55 localización rápida de strings en archivos texto.
56
57 %description -l fr.UTF-8
58 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
59 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
60 les fichiers.
61
62 %description -l ja.UTF-8
63 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
64 イトパッチ(mb1.04)によって日本語対応にしたものです.
65
66 %description -l pl.UTF-8
67 GNU grep jest implementacją popularnego programu uniksowego `grep'.
68 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
69 każdy skrypt shella.
70
71 %description -l pt_BR.UTF-8
72 Esta é a implementação GNU do popular utilitário grep. Permite a
73 localização rápida de strings em arquivos texto.
74
75 %description -l ru.UTF-8
76 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
77 по образцу в текстовых файлах.
78
79 %description -l tr.UTF-8
80 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
81 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
82 kullanılır.
83
84 %description -l uk.UTF-8
85 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
86 пошуку по шаблону в текстових файлах.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92
93 %{__rm} po/stamp-po
94
95 %build
96 %{__gettextize}
97 %{__aclocal} -I m4
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         %{!?with_pcre:--disable-perl-regexp} \
103         --disable-silent-rules \
104         --without-included-regex
105 %{__make}
106
107 %{?with_tests:%{__make} check}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT/etc/env.d
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
117 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
118
119 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
120
121 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
122 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
123 EOF
124
125 %find_lang %{name}
126
127 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
128 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
129 %{__rm} $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post -p /sbin/postshell
135 -/usr/sbin/fix-info-dir -c %{_infodir}
136 -/sbin/env-update -u
137
138 %postun -p /sbin/postshell
139 -/usr/sbin/fix-info-dir -c %{_infodir}
140 -/sbin/env-update -u
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc NEWS README ChangeLog TODO
145 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GREP_OPTIONS
146 %attr(755,root,root) %{_bindir}/egrep
147 %attr(755,root,root) %{_bindir}/fgrep
148 %attr(755,root,root) %{_bindir}/grep
149 %{_mandir}/man1/egrep.1*
150 %{_mandir}/man1/fgrep.1*
151 %{_mandir}/man1/grep.1*
152 %lang(cs) %{_mandir}/cs/man1/*
153 %lang(de) %{_mandir}/de/man1/*
154 %lang(es) %{_mandir}/es/man1/*
155 %lang(fi) %{_mandir}/fi/man1/*
156 %lang(fr) %{_mandir}/fr/man1/*
157 %lang(hu) %{_mandir}/hu/man1/*
158 %lang(it) %{_mandir}/it/man1/*
159 %lang(ja) %{_mandir}/ja/man1/*
160 %lang(nl) %{_mandir}/nl/man1/*
161 %lang(pl) %{_mandir}/pl/man1/*
162 %{_infodir}/grep.info*
This page took 0.109415 seconds and 3 git commands to generate.