]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
a3b6e083bb50c40b246ba9149ec0c4c88451ea9e
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # with PCRE support
4 #
5 Summary:        GNU grep Utilities
6 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
7 Summary(es.UTF-8):      Utilitarios grep GNU
8 Summary(fr.UTF-8):      Utilitaires grep de GNU
9 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
10 Summary(pl.UTF-8):      GNU grep
11 Summary(pt_BR.UTF-8):   Utilitários grep GNU
12 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
13 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
14 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
15 Name:           grep
16 Version:        2.5.3
17 Release:        2
18 Epoch:          2
19 License:        GPL v3+
20 Group:          Applications/Text
21 Source0:        http://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.gz
22 # Source0-md5:  4f371f25f413f700fb1984b878421f9d
23 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-locale-names.patch
27 Patch2:         %{name}-pl.po-update.patch
28 Patch3:         %{name}-strerror.patch
29 URL:            http://www.gnu.org/software/grep/grep.html
30 BuildRequires:  autoconf >= 2.53
31 BuildRequires:  automake
32 BuildRequires:  gettext-devel
33 BuildRequires:  libtool
34 %{?with_pcre:BuildRequires:     pcre-devel}
35 BuildRequires:  texinfo
36 %{?with_pcre:Requires:  pcre}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _bindir         /bin
40 %define         _exec_prefix    /
41
42 %description
43 The GNU versions of commonly used grep utilities. Grep searches one or
44 more input files for lines which contain a match to a specified
45 pattern and then prints the matching lines. GNU's grep utilities
46 include grep, egrep and fgrep.
47
48 %description -l de.UTF-8
49 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
50 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
51 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
52 enthält grep, egrep und fgrep.
53
54 %description -l es.UTF-8
55 Esta es la implementación GNU del popular utilitario grep. Permite la
56 localización rápida de strings en archivos texto.
57
58 %description -l fr.UTF-8
59 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
60 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
61 les fichiers.
62
63 %description -l ja.UTF-8
64 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
65 イトパッチ(mb1.04)によって日本語対応にしたものです.
66
67 %description -l pl.UTF-8
68 GNU grep jest implementacją popularnego programu uniksowego `grep'.
69 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
70 każdy skrypt shella.
71
72 %description -l pt_BR.UTF-8
73 Esta é a implementação GNU do popular utilitário grep. Permite a
74 localização rápida de strings em arquivos texto.
75
76 %description -l ru.UTF-8
77 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
78 по образцу в текстовых файлах.
79
80 %description -l tr.UTF-8
81 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
82 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
83 kullanılır.
84
85 %description -l uk.UTF-8
86 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
87 пошуку по шаблону в текстових файлах.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94 %patch3 -p1
95
96 # outdated, there is already nb.po
97 rm -f po/no.po
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__automake}
103 %{__autoheader}
104 %{__autoconf}
105 %configure \
106         %{!?with_pcre:--disable-perl-regexp} \
107         --without-included-regex \
108         --enable-nls
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 install -d $RPM_BUILD_ROOT/etc/env.d
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
119 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
120
121 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
122
123 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
124 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
125 EOF
126
127 %find_lang %{name}
128
129 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
130 rm -f $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
131 rm -f $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post -p /sbin/postshell
137 -/usr/sbin/fix-info-dir -c %{_infodir}
138 -/sbin/env-update -u
139
140 %postun -p /sbin/postshell
141 -/usr/sbin/fix-info-dir -c %{_infodir}
142 -/sbin/env-update -u
143
144 %files -f %{name}.lang
145 %defattr(644,root,root,755)
146 %doc NEWS README ChangeLog TODO
147 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
148 %attr(755,root,root) %{_bindir}/*
149 %{_mandir}/man1/*
150 %lang(cs) %{_mandir}/cs/man1/*
151 %lang(de) %{_mandir}/de/man1/*
152 %lang(es) %{_mandir}/es/man1/*
153 %lang(fi) %{_mandir}/fi/man1/*
154 %lang(fr) %{_mandir}/fr/man1/*
155 %lang(hu) %{_mandir}/hu/man1/*
156 %lang(it) %{_mandir}/it/man1/*
157 %lang(ja) %{_mandir}/ja/man1/*
158 %lang(nl) %{_mandir}/nl/man1/*
159 %lang(pl) %{_mandir}/pl/man1/*
160 %{_infodir}/*info*
This page took 0.123857 seconds and 3 git commands to generate.