]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
9572b55378a01a53354b31267e84c989de6bbe4f
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # with PCRE support
4 #
5 Summary:        GNU grep Utilities
6 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
7 Summary(es.UTF-8):      Utilitarios grep GNU
8 Summary(fr.UTF-8):      Utilitaires grep de GNU
9 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
10 Summary(pl.UTF-8):      GNU grep
11 Summary(pt_BR.UTF-8):   Utilitários grep GNU
12 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
13 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
14 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
15 Name:           grep
16 Version:        2.5.4
17 Release:        1
18 Epoch:          2
19 License:        GPL v3+
20 Group:          Applications/Text
21 Source0:        http://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.gz
22 # Source0-md5:  92258031d98d4f12dfc6a6d24057e672
23 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-strerror.patch
27 # from debian; very important for multibytes locale; see https://savannah.gnu.org/bugs/?14472
28 Patch2:         %{name}-egf-speedup.patch
29 Patch3:         %{name}-dfa-optional.patch
30 Patch4:         %{name}-match_icase.patch
31 URL:            http://www.gnu.org/software/grep/grep.html
32 BuildRequires:  autoconf >= 2.53
33 BuildRequires:  automake
34 BuildRequires:  gettext-devel
35 BuildRequires:  libtool
36 %{?with_pcre:BuildRequires:     pcre-devel}
37 BuildRequires:  texinfo
38 %{?with_pcre:Requires:  pcre}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _bindir         /bin
42 %define         _exec_prefix    /
43
44 %description
45 The GNU versions of commonly used grep utilities. Grep searches one or
46 more input files for lines which contain a match to a specified
47 pattern and then prints the matching lines. GNU's grep utilities
48 include grep, egrep and fgrep.
49
50 %description -l de.UTF-8
51 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
52 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
53 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
54 enthält grep, egrep und fgrep.
55
56 %description -l es.UTF-8
57 Esta es la implementación GNU del popular utilitario grep. Permite la
58 localización rápida de strings en archivos texto.
59
60 %description -l fr.UTF-8
61 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
62 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
63 les fichiers.
64
65 %description -l ja.UTF-8
66 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
67 イトパッチ(mb1.04)によって日本語対応にしたものです.
68
69 %description -l pl.UTF-8
70 GNU grep jest implementacją popularnego programu uniksowego `grep'.
71 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
72 każdy skrypt shella.
73
74 %description -l pt_BR.UTF-8
75 Esta é a implementação GNU do popular utilitário grep. Permite a
76 localização rápida de strings em arquivos texto.
77
78 %description -l ru.UTF-8
79 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
80 по образцу в текстовых файлах.
81
82 %description -l tr.UTF-8
83 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
84 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
85 kullanılır.
86
87 %description -l uk.UTF-8
88 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
89 пошуку по шаблону в текстових файлах.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p0
96 %patch3 -p0
97 %patch4 -p0
98
99 # outdated, there is already nb.po
100 rm -f po/no.po
101
102 %build
103 %{__libtoolize}
104 %{__aclocal} -I m4
105 %{__automake}
106 %{__autoheader}
107 %{__autoconf}
108 %configure \
109         %{!?with_pcre:--disable-perl-regexp} \
110         --without-included-regex \
111         --enable-nls
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT/etc/env.d
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
122 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
123
124 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
125
126 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
127 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
128 EOF
129
130 %find_lang %{name}
131
132 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
133 rm -f $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
134 rm -f $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post -p /sbin/postshell
140 -/usr/sbin/fix-info-dir -c %{_infodir}
141 -/sbin/env-update -u
142
143 %postun -p /sbin/postshell
144 -/usr/sbin/fix-info-dir -c %{_infodir}
145 -/sbin/env-update -u
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc NEWS README ChangeLog TODO
150 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
151 %attr(755,root,root) %{_bindir}/*
152 %{_mandir}/man1/*
153 %lang(cs) %{_mandir}/cs/man1/*
154 %lang(de) %{_mandir}/de/man1/*
155 %lang(es) %{_mandir}/es/man1/*
156 %lang(fi) %{_mandir}/fi/man1/*
157 %lang(fr) %{_mandir}/fr/man1/*
158 %lang(hu) %{_mandir}/hu/man1/*
159 %lang(it) %{_mandir}/it/man1/*
160 %lang(ja) %{_mandir}/ja/man1/*
161 %lang(nl) %{_mandir}/nl/man1/*
162 %lang(pl) %{_mandir}/pl/man1/*
163 %{_infodir}/*info*
This page took 0.084961 seconds and 3 git commands to generate.