]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
6b614f3332255827062eff3e9700524e7722c40d
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # PCRE support
4 %bcond_without  tests   # don't perform "make check"
5 #
6 Summary:        GNU grep Utilities
7 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
8 Summary(es.UTF-8):      Utilitarios grep GNU
9 Summary(fr.UTF-8):      Utilitaires grep de GNU
10 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
11 Summary(pl.UTF-8):      GNU grep
12 Summary(pt_BR.UTF-8):   Utilitários grep GNU
13 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
14 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
15 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
16 Name:           grep
17 Version:        2.10
18 Release:        1
19 Epoch:          2
20 License:        GPL v3+
21 Group:          Applications/Text
22 Source0:        http://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.xz
23 # Source0-md5:  709915434d09f5db655e5ebd7fd6bb7f
24 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
26 Patch0:         %{name}-info.patch
27 URL:            http://www.gnu.org/software/grep/grep.html
28 BuildRequires:  autoconf >= 2.59
29 BuildRequires:  automake >= 1:1.11
30 BuildRequires:  gettext-devel >= 0.18
31 %{?with_pcre:BuildRequires:     pcre-devel}
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  texinfo
34 BuildRequires:  xz
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _bindir         /bin
38 %define         _exec_prefix    /
39
40 %description
41 The GNU versions of commonly used grep utilities. Grep searches one or
42 more input files for lines which contain a match to a specified
43 pattern and then prints the matching lines. GNU's grep utilities
44 include grep, egrep and fgrep.
45
46 %description -l de.UTF-8
47 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
48 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
49 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
50 enthält grep, egrep und fgrep.
51
52 %description -l es.UTF-8
53 Esta es la implementación GNU del popular utilitario grep. Permite la
54 localización rápida de strings en archivos texto.
55
56 %description -l fr.UTF-8
57 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
58 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
59 les fichiers.
60
61 %description -l ja.UTF-8
62 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
63 イトパッチ(mb1.04)によって日本語対応にしたものです.
64
65 %description -l pl.UTF-8
66 GNU grep jest implementacją popularnego programu uniksowego `grep'.
67 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
68 każdy skrypt shella.
69
70 %description -l pt_BR.UTF-8
71 Esta é a implementação GNU do popular utilitário grep. Permite a
72 localização rápida de strings em arquivos texto.
73
74 %description -l ru.UTF-8
75 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
76 по образцу в текстовых файлах.
77
78 %description -l tr.UTF-8
79 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
80 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
81 kullanılır.
82
83 %description -l uk.UTF-8
84 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
85 пошуку по шаблону в текстових файлах.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90
91 %{__rm} po/stamp-po
92
93 %build
94 %{__gettextize}
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         %{!?with_pcre:--disable-perl-regexp} \
101         --disable-silent-rules \
102         --without-included-regex
103 %{__make}
104
105 %{?with_tests:%{__make} check}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT/etc/env.d
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
115 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
116
117 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
118
119 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
120 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
121 EOF
122
123 %find_lang %{name}
124
125 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
126 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
127 %{__rm} $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post -p /sbin/postshell
133 -/usr/sbin/fix-info-dir -c %{_infodir}
134 -/sbin/env-update -u
135
136 %postun -p /sbin/postshell
137 -/usr/sbin/fix-info-dir -c %{_infodir}
138 -/sbin/env-update -u
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc NEWS README ChangeLog TODO
143 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/GREP_OPTIONS
144 %attr(755,root,root) %{_bindir}/egrep
145 %attr(755,root,root) %{_bindir}/fgrep
146 %attr(755,root,root) %{_bindir}/grep
147 %{_mandir}/man1/egrep.1*
148 %{_mandir}/man1/fgrep.1*
149 %{_mandir}/man1/grep.1*
150 %lang(cs) %{_mandir}/cs/man1/*
151 %lang(de) %{_mandir}/de/man1/*
152 %lang(es) %{_mandir}/es/man1/*
153 %lang(fi) %{_mandir}/fi/man1/*
154 %lang(fr) %{_mandir}/fr/man1/*
155 %lang(hu) %{_mandir}/hu/man1/*
156 %lang(it) %{_mandir}/it/man1/*
157 %lang(ja) %{_mandir}/ja/man1/*
158 %lang(nl) %{_mandir}/nl/man1/*
159 %lang(pl) %{_mandir}/pl/man1/*
160 %{_infodir}/grep.info*
This page took 0.041474 seconds and 3 git commands to generate.