]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
- adapterized (sorted %verify flags)
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_with     pcre    # with PCRE support
4 #
5 Summary:        GNU grep Utilities
6 Summary(de):    GNU-Version der Pattern-Matching-Utilities
7 Summary(es):    Utilitarios grep GNU
8 Summary(fr):    Utilitaires grep de GNU
9 Summary(ja):    GNU grep ¤ÎÆüËܸìÂбþÈǤǤ¹.
10 Summary(pl):    GNU grep
11 Summary(pt_BR): Utilitários grep GNU
12 Summary(ru):    õÔÉÌÉÔÙ ÐÏÉÓËÁ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
13 Summary(tr):    Dosyalarda katar arama aracý
14 Summary(uk):    õÔÉ̦ÔÉ ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÁÍ GNU grep
15 Name:           grep
16 Version:        2.5.1a
17 Release:        1
18 Epoch:          2
19 License:        GPL
20 Group:          Applications/Text
21 Source0:        ftp://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.gz
22 # Source0-md5:  71db1cb262c27f02461c4bca514591ce
23 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-egrep.patch
27 Patch2:         %{name}-locale-names.patch
28 URL:            http://www.gnu.org/software/grep/grep.html
29 BuildRequires:  autoconf
30 BuildRequires:  automake
31 BuildRequires:  gettext-devel
32 BuildRequires:  libtool
33 %{?with_pcre:BuildRequires:     pcre-devel}
34 BuildRequires:  texinfo
35 %{?with_pcre:Requires:  pcre}
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _bindir         /bin
39 %define         _exec_prefix    /
40
41 %description
42 The GNU versions of commonly used grep utilities. Grep searches one or
43 more input files for lines which contain a match to a specified
44 pattern and then prints the matching lines. GNU's grep utilities
45 include grep, egrep and fgrep.
46
47 %description -l de
48 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
49 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
50 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
51 enthält grep, egrep und fgrep.
52
53 %description -l es
54 Esta es la implementación GNU del popular utilitario grep. Permite la
55 localización rápida de strings en archivos texto.
56
57 %description -l fr
58 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
59 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
60 les fichiers.
61
62 %description -l ja
63 GNU ¥×¥í¥¸¥§¥¯¥È¤Ë¤è¤ë grep, egrep, fgrep (°Ê²¼Ã±¤Ë grep) ¤ò¥Þ¥ë¥Á¥Ð
64 ¥¤¥È¥Ñ¥Ã¥Á(mb1.04)¤Ë¤è¤Ã¤ÆÆüËܸìÂбþ¤Ë¤·¤¿¤â¤Î¤Ç¤¹.
65
66 %description -l pl
67 GNU grep jest implementacj± popularnego programu uniksowego `grep'.
68 Grep jest jednym z podstawowych narzêdzi, korzysta z niego prawie
69 ka¿dy skrypt shella.
70
71 %description -l pt_BR
72 Esta é a implementação GNU do popular utilitário grep. Permite a
73 localização rápida de strings em arquivos texto.
74
75 %description -l ru
76 üÔÏ ÒÅÁÌÉÚÁÃÉÑ GNU ÕÔÉÌÉÔÙ grep, ÐÒÅÄÎÁÚÎÁÞÅÎÎÏÊ ÄÌÑ ÂÙÓÔÒÏÇÏ ÐÏÉÓËÁ
77 ÐÏ ÏÂÒÁÚÃÕ × ÔÅËÓÔÏ×ÙÈ ÆÁÊÌÁÈ.
78
79 %description -l tr
80 Bu, bütün Unix'lerde bulunan ve yaygýn olarak kullanýlan grep aracýnýn
81 GNU sürümüdür. Metin dosyalarý içinde bulunan katarlarý aramada
82 kullanýlýr.
83
84 %description -l uk
85 ãÅ GNU ÒÅÁ̦ÚÁæѠÐÏÐÕÌÑÒÎϧ ÕÔÉ̦ÔÉ grep, ÐÒÉÚÎÁÞÅÎϧ ÄÌÑ Û×ÉÄËÏÇÏ
86 ÐÏÛÕËÕ ÐÏ ÛÁÂÌÏÎÕ × ÔÅËÓÔÏ×ÉÈ ÆÁÊÌÁÈ.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93
94 rm -f m4/{header,init}.m4
95
96 # hack: AC_FUNC_STRERROR_R from strerror_r.m4 must override autoconf's version
97 # (it contains HAVE_WORKING_STRERROR_R define, needed with glibc 2.x, as
98 #  glibc version returns pointer to string and doesn't seem to store string in
99 #  supplied buffer(???))
100 cat m4/strerror_r.m4 >> acinclude.m4
101 touch m4/{header,init}.m4
102
103 # there is nb.po included, but more outdated than no.po (only no was in LINGUAS)
104 mv -f po/{no,nb}.po
105
106 %build
107 %{__libtoolize}
108 %{__aclocal} -I m4
109 %{__automake}
110 %{__autoconf}
111 %ifarch sparc sparc64
112 CPPFLAGS=""
113 export CPPFLAGS
114 %endif
115 %configure \
116         %{!?with_pcre:--disable-perl-regexp} \
117         --without-included-regex \
118         --enable-nls
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT/etc/env.d
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
129 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
130
131 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
132
133 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
134 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
135 EOF
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
144
145 %postun
146 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc NEWS README ChangeLog TODO
151 %attr(644,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
152 %attr(755,root,root) %{_bindir}/*
153 %{_mandir}/man1/*
154 %lang(cs) %{_mandir}/cs/man1/*
155 %lang(de) %{_mandir}/de/man1/*
156 %lang(es) %{_mandir}/es/man1/*
157 %lang(fi) %{_mandir}/fi/man1/*
158 %lang(fr) %{_mandir}/fr/man1/*
159 %lang(hu) %{_mandir}/hu/man1/*
160 %lang(it) %{_mandir}/it/man1/*
161 %lang(ja) %{_mandir}/ja/man1/*
162 %lang(nl) %{_mandir}/nl/man1/*
163 %lang(pl) %{_mandir}/pl/man1/*
164 %{_infodir}/*info*
This page took 0.040468 seconds and 3 git commands to generate.