]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
- up to 2.6.3
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # with PCRE support
4 %bcond_without  tests
5 #
6 Summary:        GNU grep Utilities
7 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
8 Summary(es.UTF-8):      Utilitarios grep GNU
9 Summary(fr.UTF-8):      Utilitaires grep de GNU
10 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
11 Summary(pl.UTF-8):      GNU grep
12 Summary(pt_BR.UTF-8):   Utilitários grep GNU
13 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
14 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
15 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
16 Name:           grep
17 Version:        2.6.3
18 Release:        1
19 Epoch:          2
20 License:        GPL v3+
21 Group:          Applications/Text
22 Source0:        http://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.xz
23 # Source0-md5:  69a3bf508a3f14d12369e0e1c7a92763
24 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
25 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
26 Patch0:         %{name}-info.patch
27 URL:            http://www.gnu.org/software/grep/grep.html
28 BuildRequires:  autoconf >= 2.53
29 BuildRequires:  automake
30 BuildRequires:  gettext-devel
31 BuildRequires:  libtool
32 %{?with_pcre:BuildRequires:     pcre-devel}
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  texinfo
35 BuildRequires:  xz
36 %{?with_pcre:Requires:  pcre}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _bindir         /bin
40 %define         _exec_prefix    /
41
42 %description
43 The GNU versions of commonly used grep utilities. Grep searches one or
44 more input files for lines which contain a match to a specified
45 pattern and then prints the matching lines. GNU's grep utilities
46 include grep, egrep and fgrep.
47
48 %description -l de.UTF-8
49 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
50 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
51 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
52 enthält grep, egrep und fgrep.
53
54 %description -l es.UTF-8
55 Esta es la implementación GNU del popular utilitario grep. Permite la
56 localización rápida de strings en archivos texto.
57
58 %description -l fr.UTF-8
59 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
60 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
61 les fichiers.
62
63 %description -l ja.UTF-8
64 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
65 イトパッチ(mb1.04)によって日本語対応にしたものです.
66
67 %description -l pl.UTF-8
68 GNU grep jest implementacją popularnego programu uniksowego `grep'.
69 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
70 każdy skrypt shella.
71
72 %description -l pt_BR.UTF-8
73 Esta é a implementação GNU do popular utilitário grep. Permite a
74 localização rápida de strings em arquivos texto.
75
76 %description -l ru.UTF-8
77 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
78 по образцу в текстовых файлах.
79
80 %description -l tr.UTF-8
81 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
82 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
83 kullanılır.
84
85 %description -l uk.UTF-8
86 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
87 пошуку по шаблону в текстових файлах.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92
93 %build
94 %{__libtoolize}
95 %{__aclocal} -I m4
96 %{__automake}
97 %{__autoheader}
98 %{__autoconf}
99 %configure \
100         %{!?with_pcre:--disable-perl-regexp} \
101         --disable-silent-rules \
102         --without-included-regex
103 %{__make}
104
105 %{?with_tests:%{__make} check}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT/etc/env.d
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
115 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
116
117 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
118
119 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
120 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
121 EOF
122
123 %find_lang %{name}
124
125 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
126 rm -f $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
127 rm -f $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post -p /sbin/postshell
133 -/usr/sbin/fix-info-dir -c %{_infodir}
134 -/sbin/env-update -u
135
136 %postun -p /sbin/postshell
137 -/usr/sbin/fix-info-dir -c %{_infodir}
138 -/sbin/env-update -u
139
140 %files -f %{name}.lang
141 %defattr(644,root,root,755)
142 %doc NEWS README ChangeLog TODO
143 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
144 %attr(755,root,root) %{_bindir}/*
145 %{_mandir}/man1/*
146 %lang(cs) %{_mandir}/cs/man1/*
147 %lang(de) %{_mandir}/de/man1/*
148 %lang(es) %{_mandir}/es/man1/*
149 %lang(fi) %{_mandir}/fi/man1/*
150 %lang(fr) %{_mandir}/fr/man1/*
151 %lang(hu) %{_mandir}/hu/man1/*
152 %lang(it) %{_mandir}/it/man1/*
153 %lang(ja) %{_mandir}/ja/man1/*
154 %lang(nl) %{_mandir}/nl/man1/*
155 %lang(pl) %{_mandir}/pl/man1/*
156 %{_infodir}/*info*
This page took 0.03737 seconds and 3 git commands to generate.