]> git.pld-linux.org Git - packages/grep.git/blob - grep.spec
02a48ee3abd328b3a4151778f4e5ffb1578d0057
[packages/grep.git] / grep.spec
1 #
2 # Conditional build:
3 %bcond_without  pcre    # with PCRE support
4 #
5 Summary:        GNU grep Utilities
6 Summary(de.UTF-8):      GNU-Version der Pattern-Matching-Utilities
7 Summary(es.UTF-8):      Utilitarios grep GNU
8 Summary(fr.UTF-8):      Utilitaires grep de GNU
9 Summary(ja.UTF-8):      GNU grep の日本語対応版です.
10 Summary(pl.UTF-8):      GNU grep
11 Summary(pt_BR.UTF-8):   Utilitários grep GNU
12 Summary(ru.UTF-8):      Утилиты поиска по шаблонам GNU grep
13 Summary(tr.UTF-8):      Dosyalarda katar arama aracı
14 Summary(uk.UTF-8):      Утиліти пошуку по шаблонам GNU grep
15 Name:           grep
16 Version:        2.5.4
17 Release:        2
18 Epoch:          2
19 License:        GPL v3+
20 Group:          Applications/Text
21 Source0:        http://ftp.gnu.org/gnu/grep/%{name}-%{version}.tar.gz
22 # Source0-md5:  92258031d98d4f12dfc6a6d24057e672
23 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
24 # Source1-md5:  1b5e726d0bee53e898531de4a76ad290
25 Patch0:         %{name}-info.patch
26 Patch1:         %{name}-strerror.patch
27 # from debian; very important for multibytes locale; see https://savannah.gnu.org/bugs/?14472
28 Patch2:         %{name}-egf-speedup.patch
29 Patch3:         %{name}-dfa-optional.patch
30 Patch4:         %{name}-match_icase.patch
31 Patch5:         %{name}-pl.po-update.patch
32 URL:            http://www.gnu.org/software/grep/grep.html
33 BuildRequires:  autoconf >= 2.53
34 BuildRequires:  automake
35 BuildRequires:  gettext-devel
36 BuildRequires:  libtool
37 %{?with_pcre:BuildRequires:     pcre-devel}
38 BuildRequires:  texinfo
39 %{?with_pcre:Requires:  pcre}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _bindir         /bin
43 %define         _exec_prefix    /
44
45 %description
46 The GNU versions of commonly used grep utilities. Grep searches one or
47 more input files for lines which contain a match to a specified
48 pattern and then prints the matching lines. GNU's grep utilities
49 include grep, egrep and fgrep.
50
51 %description -l de.UTF-8
52 Die GNU-Versionen der häufig benutzten grep-Utilities. Grep durchsucht
53 eine oder mehrere Eingabedateien nach Zeilen, die auf ein angegebenes
54 Muster passen, und zeigt dann die entsprechenden Zeilen an. GNUs grep
55 enthält grep, egrep und fgrep.
56
57 %description -l es.UTF-8
58 Esta es la implementación GNU del popular utilitario grep. Permite la
59 localización rápida de strings en archivos texto.
60
61 %description -l fr.UTF-8
62 Ceci est l'implémentation par GNU du populaire l'utilitaire grep su
63 Unix. Il permet de localiser rapidement des chaînes de caractéres dans
64 les fichiers.
65
66 %description -l ja.UTF-8
67 GNU プロジェクトによる grep, egrep, fgrep (以下単に grep) をマルチバ
68 イトパッチ(mb1.04)によって日本語対応にしたものです.
69
70 %description -l pl.UTF-8
71 GNU grep jest implementacją popularnego programu uniksowego `grep'.
72 Grep jest jednym z podstawowych narzędzi, korzysta z niego prawie
73 każdy skrypt shella.
74
75 %description -l pt_BR.UTF-8
76 Esta é a implementação GNU do popular utilitário grep. Permite a
77 localização rápida de strings em arquivos texto.
78
79 %description -l ru.UTF-8
80 Это реализация GNU утилиты grep, предназначенной для быстрого поиска
81 по образцу в текстовых файлах.
82
83 %description -l tr.UTF-8
84 Bu, bütün Unix'lerde bulunan ve yaygın olarak kullanılan grep aracının
85 GNU sürümüdür. Metin dosyaları içinde bulunan katarları aramada
86 kullanılır.
87
88 %description -l uk.UTF-8
89 Це GNU реалізація популярної утиліти grep, призначеної для швидкого
90 пошуку по шаблону в текстових файлах.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p0
97 %patch3 -p0
98 %patch4 -p0
99 %patch5 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal} -I m4
104 %{__automake}
105 %{__autoheader}
106 %{__autoconf}
107 %configure \
108         %{!?with_pcre:--disable-perl-regexp} \
109         --without-included-regex \
110         --enable-nls
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT/etc/env.d
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/egrep.1
121 echo .so grep.1 > $RPM_BUILD_ROOT%{_mandir}/man1/fgrep.1
122
123 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
124
125 cat << EOF >$RPM_BUILD_ROOT/etc/env.d/GREP_OPTIONS
126 #GREP_OPTIONS="--binary-files=without-match --directories=skip --color=auto"
127 EOF
128
129 %find_lang %{name}
130
131 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
132 rm -f $RPM_BUILD_ROOT%{_mandir}/README.grep-non-english-man-pages
133 rm -f $RPM_BUILD_ROOT%{_mandir}/ja-grep-nozgrep.diff
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post -p /sbin/postshell
139 -/usr/sbin/fix-info-dir -c %{_infodir}
140 -/sbin/env-update -u
141
142 %postun -p /sbin/postshell
143 -/usr/sbin/fix-info-dir -c %{_infodir}
144 -/sbin/env-update -u
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc NEWS README ChangeLog TODO
149 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
150 %attr(755,root,root) %{_bindir}/*
151 %{_mandir}/man1/*
152 %lang(cs) %{_mandir}/cs/man1/*
153 %lang(de) %{_mandir}/de/man1/*
154 %lang(es) %{_mandir}/es/man1/*
155 %lang(fi) %{_mandir}/fi/man1/*
156 %lang(fr) %{_mandir}/fr/man1/*
157 %lang(hu) %{_mandir}/hu/man1/*
158 %lang(it) %{_mandir}/it/man1/*
159 %lang(ja) %{_mandir}/ja/man1/*
160 %lang(nl) %{_mandir}/nl/man1/*
161 %lang(pl) %{_mandir}/pl/man1/*
162 %{_infodir}/*info*
This page took 0.092136 seconds and 3 git commands to generate.