]> git.pld-linux.org Git - SPECS.git/blob - grendel.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / grendel.spec
1 %define         _snap 20060316
2 Summary:        A Java mail/news client
3 Summary(pl.UTF-8):      Napisany w Javie klient poczty/newsów
4 Name:           grendel
5 Version:        cvs
6 Release:        0.%{_snap}.1
7 License:        LGPL
8 Group:          Libraries
9 Source0:        %{name}-%{_snap}.tar.bz2
10 # Source0-md5:  77d59a5174837c2b4339529b174e8793
11 #Source1:       http://wired.st-and.ac.uk/~hash9/grendel/%{name}-jar-pack-20051224.zip
12 Source1:        http://mirrors.trfenv.com/rlk/%{name}-jar-pack.zip
13 # NoSource1-md5:        9e6d2e6b2727151cbd07b79e9d8fbb70
14 # not sure about licenses, so NoSource for now
15 NoSource:       1
16 URL:            http://wiki.mozilla.org/Grendel
17 BuildRequires:  ant >= 1.6
18 BuildRequires:  java-activation
19 BuildRequires:  javamail
20 BuildRequires:  jdk >= 1.5.0
21 BuildRequires:  jpackage-utils
22 BuildRequires:  rpmbuild(macros) >= 1.300
23 BuildRequires:  unzip
24 Requires:       java >= 1.5.0
25 # JavaBeans Activation Framework (JAF) (http://java.sun.com/beans/glasgow/jaf.html)
26 # JavaMail (http://java.sun.com/products/javamail/)
27 # Netscape Directory SDK for Java (http://www.mozilla.org/directory/)
28 # ORO Matcher (http://www.savarese.org/oro/)
29 # MozCreator XUL Parser
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Grendel is the mail-news portion of the Xena project written in Java.
35 Its goal is to be a true cross-platform application with a feature set
36 that satisfies the poweruser.
37
38 %description -l pl.UTF-8
39 Grendel to część pocztowo-newsowa projektu Xena napisana w Javie. Jej
40 celem jest bycie naprawdę przenośną aplikacją o możliwościach
41 satysfakcjonujących doświadczonego użytkownika.
42
43 %prep
44 %setup -qc
45 rm -f mozilla/grendel/extlib/rhino.jar
46 %{__unzip} -qd mozilla/grendel/extlib %{SOURCE1}
47
48 %build
49 cd mozilla/grendel
50
51 required_jars="mail activation jaxp_parser_impl"
52 export CLASSPATH=$(%{_bindir}/build-classpath $required_jars)
53
54 %ant build
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_bindir},%{_javadir}}
59 cd mozilla/grendel
60
61 # should make jar from dist/ with manifest but 'ant jar' doesn't exist.
62 %ant makeZip
63
64 install %{name}.zip $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
65 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
66 #!/bin/sh
67 exec %{_bindir}/java -jar %{name}.jar
68 EOF
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_bindir}/%{name}
76 %{_javadir}/*.jar
This page took 0.587605 seconds and 3 git commands to generate.