]> git.pld-linux.org Git - packages/grass.git/blob - grass.spec
- sorted build requirements
[packages/grass.git] / grass.spec
1
2 #
3 # todo:
4 # 1. Manuals conflicts with ImageMagick 
5 # file /usr/X11R6/man/man1/display.1.gz from install of grass-5.0.0pre3-1
6 #   conflicts with file from package ImageMagick-5.4.4-1
7 # file /usr/X11R6/man/man1/import.1.gz from install of grass-5.0.0pre3-1
8 #   conflicts with file from package ImageMagick-5.4.4-1
9 #
10 # 2. see %install section :-\
11 # 3. 755 for etc/bin/cmd/*
12 #
13
14 Summary:        The Geographic Resources Analysis Support System
15 Summary(pl):    System obs³uguj±cy analizê zasobów geograficznych
16 Name:           grass
17 Version:        5.0.0pre3
18 Release:        1
19 License:        GPL
20 Group:          X11/Applications
21 Source0:        http://grass.itc.it/grass5/source/%{name}%{version}.tar.gz
22 URL:            http://grass.itc.it/
23 BuildRequires:  awk
24 BuildRequires:  bison
25 BuildRequires:  blas-devel
26 BuildRequires:  fftw-devel
27 BuildRequires:  flex
28 BuildRequires:  freetype-devel
29 BuildRequires:  gcc-g77
30 #BuildRequires: gdal-devel
31 BuildRequires:  gdbm-devel
32 BuildRequires:  gd-devel
33 BuildRequires:  lapack-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel
36 BuildRequires:  libtiff-devel
37 BuildRequires:  motif-devel
38 BuildRequires:  ncurses-devel
39 BuildRequires:  OpenGL-devel
40 BuildRequires:  postgresql-backend-devel
41 BuildRequires:  postgresql-devel
42 BuildRequires:  tcl-devel
43 BuildRequires:  tk-devel
44 BuildRequires:  unixODBC-devel
45 BuildRequires:  zlib-devel
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
49 %define         _prefix         /usr/X11R6
50 %define         _mandir         %{_prefix}/man
51 %define         _sysconfdir     /etc/X11
52
53 %description
54 GRASS (the Geographic Resources Analysis Support System) is a software
55 raster- and vector-based GIS (Geographic Information System), image
56 processing system, graphics production system, and spatial modeling
57 system. GRASS contains many modules for raster data manipulation,
58 vector data manipulation, rendering images on the monitor or paper,
59 multispectral image processing, point data management and general data
60 management. It also has tools for interfacing with digitizers,
61 scanners, and the RIM, Informix, Postgres, and Oracle databases.
62
63 %description -l pl
64 GRASS (System Wspierania Analiz Zasobów Geograficznych) jest rastrowym
65 oraz wektorowym systemem GIS (System Informacji Geograficznej),
66 obróbki obrazów, tworzenia grafiki oraz modelowania przestrzennego.
67 GRASS zawiera wiele modu³ów wspomagaj±cych manipulacjê danymi
68 rastrowymi i wektorowymi, renderowanie obrazów na monitorze lub
69 papierze, obróbkê multispektralnych obrazów, punktowe oraz ogólne
70 zarz±dzanie danymi. Zawiera równie¿ narzêdzia do wspó³pracy z
71 digitizerami, skanerami oraz bazami RIM, Informix, Postgres oraz
72 Oracle.
73
74 %package OpenGL
75 Summary:        NVIZ - a 3D-tool for GRASS
76 Summary(pl):    NVIZ - narzêdzie 3D dla GRASSa
77 Group:          X11/Applications
78 Requires:       %{name} = %{version}
79
80 %description OpenGL
81 Package contains nviz, which is a GRASS module-in-progress which
82 allows users to realistically render multiple surfaces in a 3D space,
83 optionally using thematic coloring, draping GRASS vector files over
84 the surfaces, and displaying GRASS site files either draped on the
85 surfaces or as 3D point locations.
86
87 %description OpenGL -l pl
88 Pakiet zawiera modu³ nviz, który rozszerza funkcjonalno¶æ systemu
89 GRASS o mo¿liwo¶æ realistycznego renderowania wielu powierzchni w
90 trójwymiarowej przestrzeni. Na renderowanych powierzchniach, które
91 mog± byæ tematycznie kolorowane, mo¿na zawieszaæ pliki wektorowe
92 GRASSa.
93
94 %package pg
95 Summary:        PostgreSQL database interface
96 Summary(pl):    Interfejs do bazy PostgreSQL
97 Group:          X11/Applications
98 Requires:       %{name} = %{version}
99
100 %description pg
101 PostgreSQL database interface for GRASS.
102
103 %dewscription pg -l pl
104 Interfejs do bazy PostgreSQL dla GRASSa.
105
106 %package odbc
107 Summary:        ODBC database interface
108 Summary(pl):    Interfejs ODBC dla GRASSa
109 Group:          X11/Applications
110 Requires:       %{name} = %{version}
111
112 %description odbc
113 ODBC database interface for GRASS.
114
115 %description odbc -l pl
116 Interfejs ODBC dla GRASSa.
117
118 %package devel
119 Summary:        Header files for GRASS
120 Summary(pl):    Pliki nag³ówkowe systemu GRASS
121 Group:          X11/Development/Libraries
122 Requires:       %{name} = %{version}
123
124 %description devel 
125 Header files for GRASS.
126
127 %description devel -l pl
128 Pliki nag³ówkowe systemu GRASS.
129
130 %package static
131 Summary:        GRASS static libraries
132 Summary(pl):    Biblioteki statyczne systemu GRASS
133 Group:          X11/Development/Libraries
134 Requires:       %{name} = %{version}
135
136 %description static 
137 GRASS static libraries.
138
139 %description static -l pl
140 Biblioteki statyczne systemu GRASS.
141
142 %prep
143 %setup -q -n %{name}%{version}
144
145 %build
146 if [ -f %{_pkgconfigdir}/libpng12.pc ] ; then
147         CPPFLAGS="`pkg-config libpng12 --cflags`"; export CPPFLAGS
148 fi
149 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"; export CFLAGS
150 %configure2_13 \
151         --with-lapack \
152         --with-motif \
153         --with-freetype \
154         --with-includes=%{_includedir} \
155         --with-libs=%{_libdir} \
156         --with-postgres-includes=/usr/include/postgresql/server \
157         --with-freetype-includes=/usr/include/freetype2
158 %{__make}
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,%{_includedir}/grass5,%{_libdir}/grass5,%{_bindir}}
164
165 cd bin.%{_host}
166 mv grass5 grass5.in
167 awk '// {if (/^GISBASE/) { print "GISBASE=%{_libdir}/grass5" } else { print $0 }}' < grass5.in > grass5
168 install grass5 $RPM_BUILD_ROOT%{_bindir}
169 cd ..
170
171 cd dist.%{_host}
172
173 # bin: there are many binaries with the same content, i.e. d.*, i.* -
174 #      create symlinks instead of binaries?
175 # etc: it is a big mess; do not move the content of "etc" dir to /etc
176 # txt: move to %docdir?
177 # tcltkgrass: separate package?
178 # bwidget: move to devel or separate package?
179 # dev: move the content to /dev or leave it as below?
180 cp -a bin bwidget etc dev driver fonts scripts tcltkgrass txt $RPM_BUILD_ROOT%{_libdir}/grass5
181
182 install man/man1/* $RPM_BUILD_ROOT%{_mandir}/man1
183 install lib/* $RPM_BUILD_ROOT%{_libdir}
184 install include/* $RPM_BUILD_ROOT%{_includedir}/grass5
185
186 cd ..
187
188 gzip -9nf AUTHORS BUGS COPYING NEWS.html ONGOING TODO.txt documents/*.*
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %files
194 %defattr(644,root,root,755)
195 %doc *.gz */*.gz
196 %attr(755,root,root) %{_bindir}/*
197 %attr(-,root,root) %{_libdir}/grass5
198
199
200 #%dir %{_libdir}/grass5
201 #%dir %{_libdir}/grass5/bin
202 #%attr(755,root,root) %{_libdir}/grass5/bin/*
203 #%{_libdir}/grass5/bwidget
204 #%{_libdir}/grass5/etc
205 #%{_libdir}/grass5/dev
206 #%{_libdir}/grass5/driver
207 #%{_libdir}/grass5/fonts
208 #%{_libdir}/grass5/scripts
209 #%{_libdir}/grass5/tcltkgrass
210 #%{_libdir}/grass5/txt
211 %{_mandir}/man1/*
212
213 %files devel
214 %defattr(644,root,root,755)
215 %{_includedir}/grass5
216
217 %files static
218 %defattr(644,root,root,755)
219 %{_libdir}/*.a
This page took 0.099377 seconds and 4 git commands to generate.