]> git.pld-linux.org Git - packages/grass.git/blob - grass.spec
- initial update to grass70 series, version 7.0.3 (6.4.x series left on grass-6.4...
[packages/grass.git] / grass.spec
1 # TODO
2 # - openDWG
3 #
4 # Conditional build, see http://grass.itc.it/grass61/source/REQUIREMENTS.html
5 # for description of optional requirements.
6 %bcond_without  mysql   # MySQL support
7 %bcond_without  odbc    # unixODBC support
8
9 Summary:        The Geographic Resources Analysis Support System
10 Summary(pl.UTF-8):      System obsługujący analizę zasobów geograficznych
11 Name:           grass
12 Version:        7.0.3
13 Release:        1
14 Epoch:          1
15 License:        GPL v2+
16 Group:          X11/Applications
17 Source0:        http://grass.osgeo.org/grass70/source/%{name}-%{version}.tar.gz
18 # Source0-md5:  dfbd39829036ee2d59b13c35a183ec0e
19 Patch0:         %{name}-soname.patch
20 Patch1:         %{name}-ac.patch
21 Patch2:         %{name}-format.patch
22 Patch3:         %{name}-ctypesgen.patch
23 URL:            http://grass.osgeo.org/
24 BuildRequires:  OpenGL-GLU-devel
25 BuildRequires:  autoconf >= 2.13
26 BuildRequires:  automake
27 BuildRequires:  bison
28 BuildRequires:  blas-devel
29 BuildRequires:  cairo-devel
30 BuildRequires:  fftw3-devel >= 3
31 BuildRequires:  flex
32 BuildRequires:  freetype-devel >= 2.0.0
33 BuildRequires:  gcc-fortran
34 BuildRequires:  gd-devel
35 BuildRequires:  gdal-devel
36 BuildRequires:  gdbm-devel
37 BuildRequires:  geos-devel
38 BuildRequires:  lapack-devel
39 BuildRequires:  libjpeg-devel
40 BuildRequires:  libpng-devel
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtiff-devel
43 # man or man-db
44 BuildRequires:  /usr/bin/man
45 %{?with_mysql:BuildRequires:    mysql-devel}
46 BuildRequires:  pkgconfig
47 BuildRequires:  postgresql-backend-devel
48 BuildRequires:  postgresql-devel
49 BuildRequires:  proj-devel >= 4.4.6
50 BuildRequires:  proj-progs
51 BuildRequires:  python-devel >= 1:2.3
52 BuildRequires:  python-wxPython
53 BuildRequires:  readline-devel
54 BuildRequires:  sed >= 4.0
55 BuildRequires:  sqlite3-devel >= 3.0
56 %{?with_odbc:BuildRequires:     unixODBC-devel}
57 BuildRequires:  wxGTK2-unicode-devel >= 2.8.1
58 BuildRequires:  xorg-lib-libX11-devel
59 BuildRequires:  xorg-lib-libXext-devel
60 BuildRequires:  xorg-lib-libXt-devel
61 BuildRequires:  zlib-devel
62 # R language?
63 Requires:       proj >= 4.4.6
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         gver    %{version}
67 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
68 %define         _sysconfdir     /etc/X11
69
70 %description
71 GRASS (the Geographic Resources Analysis Support System) is a software
72 raster- and vector-based GIS (Geographic Information System), image
73 processing system, graphics production system, and spatial modeling
74 system. GRASS contains many modules for raster data manipulation,
75 vector data manipulation, rendering images on the monitor or paper,
76 multispectral image processing, point data management and general data
77 management. It also has tools for interfacing with digitizers,
78 scanners, and the RIM, Informix, Postgres, and Oracle databases.
79
80 %description -l pl.UTF-8
81 GRASS (System Wspierania Analiz Zasobów Geograficznych) jest rastrowym
82 oraz wektorowym systemem GIS (System Informacji Geograficznej),
83 obróbki obrazów, tworzenia grafiki oraz modelowania przestrzennego.
84 GRASS zawiera wiele modułów wspomagających manipulację danymi
85 rastrowymi i wektorowymi, renderowanie obrazów na monitorze lub
86 papierze, obróbkę multispektralnych obrazów, punktowe oraz ogólne
87 zarządzanie danymi. Zawiera również narzędzia do współpracy z
88 digitizerami, skanerami oraz bazami RIM, Informix, Postgres oraz
89 Oracle.
90
91 %package OpenGL
92 Summary:        NVIZ - a 3D-tool for GRASS
93 Summary(pl.UTF-8):      NVIZ - narzędzie 3D dla GRASSa
94 Group:          X11/Applications
95 Requires:       %{name} = %{epoch}:%{version}-%{release}
96
97 %description OpenGL
98 Package contains nviz, which is a GRASS module-in-progress which
99 allows users to realistically render multiple surfaces in a 3D space,
100 optionally using thematic coloring, draping GRASS vector files over
101 the surfaces, and displaying GRASS site files either draped on the
102 surfaces or as 3D point locations.
103
104 %description OpenGL -l pl.UTF-8
105 Pakiet zawiera moduł nviz, który rozszerza funkcjonalność systemu
106 GRASS o możliwość realistycznego renderowania wielu powierzchni w
107 trójwymiarowej przestrzeni. Na renderowanych powierzchniach, które
108 mogą być tematycznie kolorowane, można zawieszać pliki wektorowe
109 GRASSa.
110
111 %package pg
112 Summary:        PostgreSQL database interface
113 Summary(pl.UTF-8):      Interfejs do bazy PostgreSQL
114 Group:          X11/Applications
115 Requires:       %{name} = %{epoch}:%{version}-%{release}
116
117 %description pg
118 PostgreSQL database interface for GRASS.
119
120 %description pg -l pl.UTF-8
121 Interfejs do bazy PostgreSQL dla GRASSa.
122
123 %package odbc
124 Summary:        ODBC database interface
125 Summary(pl.UTF-8):      Interfejs ODBC dla GRASSa
126 Group:          X11/Applications
127 Requires:       %{name} = %{epoch}:%{version}-%{release}
128
129 %description odbc
130 ODBC database interface for GRASS.
131
132 %description odbc -l pl.UTF-8
133 Interfejs ODBC dla GRASSa.
134
135 %package devel
136 Summary:        Header files and static libraries for GRASS
137 Summary(pl.UTF-8):      Pliki nagłówkowe i biblioteki statyczne systemu GRASS
138 Group:          X11/Development/Libraries
139 Requires:       %{name} = %{epoch}:%{version}-%{release}
140
141 %description devel
142 Header files and static libraries for GRASS.
143
144 %description devel -l pl.UTF-8
145 Pliki nagłówkowe i biblioteki statyczne systemu GRASS.
146
147 %prep
148 %setup -q
149 %patch0 -p1
150 %patch1 -p1
151 %patch2 -p1
152 %patch3 -p1
153
154 %{__sed} -i -e '1s,/usr/bin/env perl,%{__perl},' \
155         display/d.text/test.pl
156         raster/r.topidx/gridatb.to.arc.pl \
157         raster/r.topidx/arc.to.gridatb.pl
158
159 find general gui imagery lib/python/pygrass lib/init raster scripts temporal tools -name '*.py' | xargs grep -l '/usr/bin/env python' | xargs %{__sed} -i -e '1s,/usr/bin/env python,%{__python},'
160
161 %build
162 %{__libtoolize}
163 %{__aclocal}
164 %{__autoconf}
165 %configure \
166 %if "%{_lib}" == "lib64"
167         --enable-64bit \
168 %endif
169         --enable-largefile \
170         --with-includes=%{_includedir} \
171         --with-libs=%{_libdir} \
172         --with-blas \
173         --with-cairo \
174         --with-cxx \
175         --with-freetype \
176         --with-freetype-includes=/usr/include/freetype2 \
177         --with-geos=/usr/bin/geos-config \
178         --with-lapack \
179         %{?with_mysql:--with-mysql} \
180         %{?with_mysql:--with-mysql-includes=/usr/include/mysql} \
181         --with-nls \
182         %{?with_odbc:--with-odbc} \
183         --with-opengl \
184         --with-postgres \
185         --with-postgres-includes=/usr/include/postgresql/server \
186         --with-proj-share=/usr/share/proj \
187         --with-readline \
188         --with-sqlite \
189         --with-wxwidgets=/usr/bin/wx-gtk2-unicode-config
190
191 %{__make}
192
193 %install
194 rm -rf $RPM_BUILD_ROOT
195
196 %{__make} install \
197         prefix=$RPM_BUILD_ROOT%{_libdir} \
198         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
199         PREFIX=$RPM_BUILD_ROOT%{_libdir}
200
201 install -d $RPM_BUILD_ROOT{%{_datadir},%{_includedir}/grass70}
202 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/include/* $RPM_BUILD_ROOT%{_includedir}/grass70
203 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/lib/* $RPM_BUILD_ROOT%{_libdir}
204 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/locale $RPM_BUILD_ROOT%{_datadir}
205 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/docs/man $RPM_BUILD_ROOT%{_datadir}
206 %{__mv} $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/share/{appdata,applications,icons} $RPM_BUILD_ROOT%{_datadir}
207
208 # these manual cover topics, not programs, so shouldn't exist in section 1
209 # (maybe in section 7, but names are too common anyway); keep HTML version only
210 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{cairodriver,database,databaseintro,display,displaydrivers,full_index,general,helptext,htmldriver,imagery,imageryintro,index,keywords,misc,pngdriver,postscript,projectionintro,psdriver,raster,rasterintro,raster3d,raster3dintro,sql,temporal,temporalintro,topics,variables,vector,vectorascii,vectorintro}.1
211
212 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/grass-%{gver}/docs
213
214 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{pt_br,pt_BR}
215 %{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{zh,zh_CN}
216
217 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/AUTHORS
218 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/CHANGES
219 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/COPYING
220 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/GPL.TXT
221 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/REQUIREMENTS.html
222
223 %find_lang %{name} --all-name
224
225 %clean
226 rm -rf $RPM_BUILD_ROOT
227
228 %post   -p /sbin/ldconfig
229 %postun -p /sbin/ldconfig
230
231 %files -f %{name}.lang
232 %defattr(644,root,root,755)
233 %doc AUTHORS CHANGES COPYING README TODO
234 #%attr(755,root,root) %{_bindir}/grass70
235 %attr(755,root,root) %{_libdir}/libgrass_*.%{version}.so
236 %dir %{_libdir}/grass-%{gver}
237 %dir %{_libdir}/grass-%{gver}/*.csv
238 %attr(755,root,root) %{_libdir}/grass-%{gver}/config.status
239 %attr(755,root,root) %{_libdir}/grass-%{gver}/bin
240 %attr(755,root,root) %{_libdir}/grass-%{gver}/driver
241 %dir %{_libdir}/grass-%{gver}/etc
242 %{_libdir}/grass-%{gver}/etc/VERSIONNUMBER
243 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/clean_temp
244 %{_libdir}/grass-%{gver}/etc/colors
245 %{_libdir}/grass-%{gver}/etc/colors.desc
246 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/current_time_s_ms
247 %{_libdir}/grass-%{gver}/etc/d.polar
248 %{_libdir}/grass-%{gver}/etc/db.test
249 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/echo
250 %{_libdir}/grass-%{gver}/etc/element_list
251 %{_libdir}/grass-%{gver}/etc/fontcap
252 %{_libdir}/grass-%{gver}/etc/grass70.py
253 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/i.find
254 %{_libdir}/grass-%{gver}/etc/license
255 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/lister
256 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/lock
257 %{_libdir}/grass-%{gver}/etc/paint
258 %{_libdir}/grass-%{gver}/etc/proj
259 %{_libdir}/grass-%{gver}/etc/psdriver.ps
260 %{_libdir}/grass-%{gver}/etc/python
261 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/r.in.wms
262 %dir %{_libdir}/grass-%{gver}/etc/r.watershed
263 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/r.watershed/ram
264 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/r.watershed/seg
265 %{_libdir}/grass-%{gver}/etc/renamed_options
266 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/run
267 %{_libdir}/grass-%{gver}/etc/sql
268 %{_libdir}/grass-%{gver}/etc/symbol
269 %attr(755,root,root) %{_libdir}/grass-%{gver}/etc/wxpyimgview_gui.py
270 %{_libdir}/grass-%{gver}/fonts
271 %dir %{_libdir}/grass-%{gver}/gui
272 %{_libdir}/grass-%{gver}/gui/icons
273 %{_libdir}/grass-%{gver}/gui/images
274 %dir %{_libdir}/grass-%{gver}/gui/scripts
275 %attr(755,root,root) %{_libdir}/grass-%{gver}/gui/scripts/d.*
276 %dir %{_libdir}/grass-%{gver}/gui/wxpython
277 %{_libdir}/grass-%{gver}/gui/wxpython/README
278 %{_libdir}/grass-%{gver}/gui/wxpython/animation
279 %{_libdir}/grass-%{gver}/gui/wxpython/core
280 %{_libdir}/grass-%{gver}/gui/wxpython/dbmgr
281 %{_libdir}/grass-%{gver}/gui/wxpython/gcp
282 %{_libdir}/grass-%{gver}/gui/wxpython/gmodeler
283 %{_libdir}/grass-%{gver}/gui/wxpython/gui_core
284 %{_libdir}/grass-%{gver}/gui/wxpython/iclass
285 %{_libdir}/grass-%{gver}/gui/wxpython/icons
286 %{_libdir}/grass-%{gver}/gui/wxpython/iscatt
287 %{_libdir}/grass-%{gver}/gui/wxpython/lmgr
288 %{_libdir}/grass-%{gver}/gui/wxpython/location_wizard
289 %{_libdir}/grass-%{gver}/gui/wxpython/mapdisp
290 %{_libdir}/grass-%{gver}/gui/wxpython/mapswipe
291 %{_libdir}/grass-%{gver}/gui/wxpython/mapwin
292 %{_libdir}/grass-%{gver}/gui/wxpython/modules
293 %{_libdir}/grass-%{gver}/gui/wxpython/nviz
294 %{_libdir}/grass-%{gver}/gui/wxpython/psmap
295 %{_libdir}/grass-%{gver}/gui/wxpython/rlisetup
296 %{_libdir}/grass-%{gver}/gui/wxpython/timeline
297 %{_libdir}/grass-%{gver}/gui/wxpython/tplot
298 %{_libdir}/grass-%{gver}/gui/wxpython/vdigit
299 %{_libdir}/grass-%{gver}/gui/wxpython/vnet
300 %{_libdir}/grass-%{gver}/gui/wxpython/web_services
301 %{_libdir}/grass-%{gver}/gui/wxpython/wxplot
302 %{_libdir}/grass-%{gver}/gui/wxpython/xml
303 %{_libdir}/grass-%{gver}/gui/wxpython/gis_set*.py*
304 %{_libdir}/grass-%{gver}/gui/wxpython/wxgui.py*
305 %{_libdir}/grass-%{gver}/gui/xml
306 %attr(755,root,root) %{_libdir}/grass-%{gver}/scripts
307 %dir %{_libdir}/grass-%{gver}/tools
308 %attr(755,root,root) %{_libdir}/grass-%{gver}/tools/g.echo
309 %attr(755,root,root) %{_libdir}/grass-%{gver}/tools/g.html2man.py
310 %{_libdir}/grass-%{gver}/tools/groff.py*
311 %{_libdir}/grass-%{gver}/tools/html.py*
312 %attr(755,root,root) %{_libdir}/grass-%{gver}/tools/mkhtml.py
313 %{_libdir}/grass-%{gver}/translation_status.json
314 # default (demo?) database - subpackage?
315 %{_libdir}/grass-%{gver}/demolocation
316 %{_datadir}/appdata/grass.appdata.xml
317 %{_desktopdir}/grass.desktop
318 %{_iconsdir}/hicolor/*x*/apps/grass70.png
319 %{_iconsdir}/hicolor/scalable/apps/grass70.svg
320 %{_mandir}/man1/d.*.1*
321 %{_mandir}/man1/db.*.1*
322 %{_mandir}/man1/g.*.1*
323 %{_mandir}/man1/grass7.1*
324 %{_mandir}/man1/grass-*.1*
325 %{_mandir}/man1/i.*.1*
326 %{_mandir}/man1/lrs.1*
327 %{_mandir}/man1/m.*.1*
328 %{_mandir}/man1/ps.map.1*
329 %{_mandir}/man1/r.*.1*
330 %{_mandir}/man1/r3.*.1*
331 %{_mandir}/man1/t.*.1*
332 %{_mandir}/man1/topic_*.1*
333 %{_mandir}/man1/v.*.1*
334 %{_mandir}/man1/wximgview.1*
335 %{_mandir}/man1/wxpyimgview.1*
336 %{_mandir}/man1/wxGUI*.1*
337 %{_mandir}/man1/ximgview.1*
338
339 %files devel
340 %defattr(644,root,root,755)
341 %attr(755,root,root) %{_libdir}/libgrass_*[!0-9].so
342 %attr(755,root,root) %{_libdir}/libgrass_btree2.so
343 %attr(755,root,root) %{_libdir}/libgrass_dig2.so
344 %{_libdir}/libgrass_iostream.%{version}.a
345 %{_includedir}/grass70
346
347 %files doc
348 %defattr(644,root,root,755)
349 %doc dist.*/docs/html/*
This page took 0.073087 seconds and 4 git commands to generate.