]> git.pld-linux.org Git - packages/gramps.git/blob - gramps.spec
adad9880b87cdd0a8d4ef3c71a4c7fd31c2a7a2d
[packages/gramps.git] / gramps.spec
1 %define prefix   /usr
2 %define localstatedir /var/lib
3 %define _prefix   %prefix
4 %define _localstatedir %localstatedir
5
6 Summary:        Genealogical Research and Analysis Management Programming System.
7 Name:           gramps
8 Version:        0.98.0
9 Release:        0.1
10 License:        GPL
11 Group:          Applications/Science
12 Source0:        http://download.sourceforge.net/gramps/%{name}-%{version}.tar.gz
13 # Source0-md5:  027500af2012889b37bfa99ab1e9e382
14 URL:            http://gramps.sourceforge.net/
15 BuildRequires:  scrollkeeper >= 0.3.5
16 BuildRequires:  automake >= 1.6
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  rpm >= 4.1
19 BuildRequires:  desktop-file-utils >= 0.2.92
20 Requires:       python >= 2.2
21 Requires:       python-Imaging 
22 Requires:       python-gnome >= 1.99
23 Requires:       python-gnome-canvas >= 1.99
24 Requires:       python-gnome-gconf >= 1.99
25 Requires:       python-gnome-ui >= 1.99
26 Requires:       python-pygtk >= 1.99
27 Requires:       python-pygtk-glade >= 1.99
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 gramps (Genealogical Research and Analysis Management Programming
32 System) is a GNOME based genealogy program supporting a Python based
33 plugin system.
34
35 %prep
36 %setup -q
37
38 %build
39 if [ ! -f configure ]; then
40 CFLAGS="$MYCFLAGS" ./autogen.sh $MYARCH_FLAGS --prefix=%{_prefix} \
41     --localstatedir=%localstatedir --bindir=%{_bindir} \
42     --mandir=%{_mandir} --libdir=%{_libdir} --datadir=%{_datadir} \
43     --includedir=%{_includedir} --sysconfdir=%{_sysconfdir}
44 else
45   CFLAGS="$MYCFLAGS" %configure
46 fi
47
48 CFLAGS="%{rpmcflags}" make
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %makeinstall
54 mkdir $RPM_BUILD_ROOT%{_datadir}/applications
55 desktop-file-install --vendor gramps --delete-original \
56         --dir $RPM_BUILD_ROOT%{_datadir}/applications  \
57         --add-category Application                     \
58         --add-category Utility                         \
59         $RPM_BUILD_ROOT%{_datadir}/gnome/apps/Applications/gramps.desktop
60 %find_lang gramps
61 rm -rf $RPM_BUILD_ROOT/%{_localstatedir}/scrollkeeper/
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files -f gramps.lang
67 %defattr(644,root,root,755)
68
69 %doc AUTHORS COPYING-DOCS ChangeLog FAQ NEWS README TODO
70 %doc %{_mandir}/man1/*
71
72 %attr(755,root,root) %{_bindir}/gramps
73
74 %{_datadir}/applications/*
75 %{_datadir}/pixmaps/gramps.png
76
77 %{_libdir}/gramps
78 %{_datadir}/gramps
79 %{_datadir}/omf/gramps
80
81 %post
82 if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update; fi
83
84 %postun
85 if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update; fi
This page took 0.065737 seconds and 2 git commands to generate.