]> git.pld-linux.org Git - packages/gpsd.git/blob - gpsd.spec
- cleanups
[packages/gpsd.git] / gpsd.spec
1 # TODO
2 # - at this time package do not build with dbus support
3 #   I do not need it ...
4 # Conditional build:
5 %bcond_with     dbus    # build with dbus support
6
7 #
8 Summary:        Service daemon for mediating access to a GPS
9 Summary(pl):    Oprogramowanie komunikuj±ce siê z GPS'em
10 Name:           gpsd
11 Version:        2.30
12 Release:        1.1
13 License:        BSD
14 Group:          Daemons
15 Source0:        http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
16 # Source0-md5:  dde177174878e8ae6db15f8010da46dd
17 Patch0:         %{name}-ncurses.patch
18 URL:            http://gpsd.berlios.de/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  ncurses-devel
22 BuildRequires:  openmotif-devel
23 BuildRequires:  XFree86-devel
24 %if %{with dbus}
25 BuildRequires:  dbus-devel
26 BuildRequires:  dbus-glib-devel
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _libx11dir      %{_prefix}/lib/X11
31 %define         _appdefsdir     %{_libx11dir}/app-defaults
32
33 %description
34 gpsd is a service daemon that mediates access to a GPS sensor
35 connected to the host computer by serial or USB interface, making its
36 data on the location/course/velocity of the sensor available to be
37 queried on TCP port 2947 of the host computer. With gpsd, multiple GPS
38 client applications (such as navigational and wardriving software) can
39 share access to a GPS without contention or loss of data. Also, gpsd
40 responds to queries with a format that is substantially easier to
41 parse than NMEA 0183. A client library is provided for applications.
42
43 After installing this RPM, gpsd will automatically connect to USB
44 GPSes when they are plugged in and requires no configuration. For
45 serial GPSes, you will need to start gpsd by hand. Once connected, the
46 daemon automatically discovers the correct baudrate, stop bits, and
47 protocol. The daemon will be quiescent when there are no clients
48 asking for location information, and copes gracefully when the GPS is
49 unplugged and replugged.
50
51 %package -n gpsd-devel
52 Summary:        Client libraries in C and Python for talking to a running gpsd or GPS
53 Group:          Development/Libraries
54 Requires:       gpsd
55
56 %description -n gpsd-devel
57 This package provides C header files for the gpsd shared libraries
58 that manage access to a GPS for applications; also Python modules. You
59 will need to have gpsd installed for it to work.
60
61 %package -n gpsd-clients
62 Summary:        Clients for gpsd with an X interface
63 Group:          Applications/System
64 Requires:       openmotif-libs
65 Requires:       gpsd
66
67 %description -n gpsd-clients
68 xgps is a simple test client for gpsd with an X interface. It displays
69 current GPS position/time/velocity information and (for GPSes that
70 support the feature) the locations of accessible satellites.
71
72 xgpsspeed is a speedometer that uses position information from the
73 GPS. It accepts an -h option and optional argument as for gps, or a -v
74 option to dump the package version and exit. Additionally, it accepts
75 - -rv (reverse video) and -nc (needle color) options.
76
77 cgps resembles xgps, but without the pictorial satellite display. It
78 can run on a serial terminal or terminal emulator.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         %{?with_dbus: --enable-dbus}
91
92 %{__make}
93 %{__python} -c "import compiler;compiler.compileFile('gps.py')"
94 %{__python} -c "import compiler;compiler.compileFile('gpsfake.py')"
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hotplug/usb,%{py_sitedir},%{_appdefsdir},%{_datadir}/gpsd/}
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 install gps.pyc gpsfake.pyc $RPM_BUILD_ROOT/%{py_sitedir}/
104 install gpsd.hotplug gpsd.usermap $RPM_BUILD_ROOT/%{_sysconfdir}/hotplug/usb/
105 install xgps.ad $RPM_BUILD_ROOT/%{_appdefsdir}/xgps
106 install xgpsspeed.ad $RPM_BUILD_ROOT/%{_appdefsdir}/xgpsspeed
107 install dgpsip-servers $RPM_BUILD_ROOT/%{_datadir}/gpsd/dgpsip-servers
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 #%post -n gpsd
113 #/sbin/ldconfig
114
115 #%postun -n gpsd
116 #/sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc README INSTALL COPYING TODO AUTHORS HACKING
121 %attr(755,root,root) %{_sbindir}/gpsd
122 %attr(755,root,root) %{_bindir}/gpsprof
123 %attr(755,root,root) %{_bindir}/sirfmon
124 #%{_libdir}/libgps.la
125 #%attr(755,root,root) %{_libdir}/libgps.so*
126 #%{_libdir}/libgps.a
127 %attr(755,root,root) %{_libdir}/libgps.so.15*
128 %{_mandir}/man8/gpsd.8*
129 %{_mandir}/man1/gpsprof.1*
130 %{_mandir}/man1/sirfmon.1*
131 %{_sysconfdir}/hotplug/usb/gpsd.hotplug
132 %{_sysconfdir}/hotplug/usb/gpsd.usermap
133 %{_datadir}/gpsd/dgpsip-servers
134 %{py_sitedir}/gps.pyc
135
136 %files -n gpsd-clients
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/xgps
139 %attr(755,root,root) %{_bindir}/xgpsspeed
140 %attr(755,root,root) %{_bindir}/cgps
141 %attr(755,root,root) %{_bindir}/gpspipe
142 %{?with_dbus: %attr(755,root,root) %{_bindir}/gpxlogger}
143 %{_mandir}/man1/xgps.1*
144 %{_mandir}/man1/gpspipe.1*
145 %{?with_dbus: %{_mandir}/man1/gpxlogger.1*}
146 %{_appdefsdir}/xgps
147 %{_appdefsdir}/xgpsspeed
148
149 %files -n gpsd-devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/gpsfake
152 %attr(755,root,root) %{_bindir}/rtcmdecode
153 %attr(755,root,root) %{_bindir}/gpsflash
154 %{py_sitedir}/gpsfake.pyc
155 %{_includedir}/gps.h
156 %{_includedir}/libgpsmm.h
157 %{_includedir}/gpsd.h
158 %{_mandir}/man1/gpsfake.1*
159 %{_mandir}/man1/rtcmdecode.1*
160 %{_mandir}/man1/gpsflash.1*
161 %{_mandir}/man3/libgps.3*
162 %{_mandir}/man3/libgpsmm.3*
163 %{_mandir}/man3/libgpsd.3*
164 %{_mandir}/man5/rtcm-104.5*
165 %{_mandir}/man5/srec.5*
This page took 0.044667 seconds and 4 git commands to generate.