]> git.pld-linux.org Git - packages/gpsd.git/blob - gpsd.spec
- release 3
[packages/gpsd.git] / gpsd.spec
1 #
2 # Conditional build:
3 %bcond_without  dbus    # build without dbus support
4 %bcond_without  bluez   # build without Bluetooth support
5 %bcond_without  x       # build without X Window System support
6 #
7 Summary:        Service daemon for mediating access to a GPS
8 Summary(pl.UTF-8):      Oprogramowanie komunikujące się z GPS-em
9 Name:           gpsd
10 Version:        2.95
11 Release:        3
12 License:        BSD
13 Group:          Daemons
14 Source0:        http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
15 # Source0-md5:  12535a9ed9fecf9ea2c5bdc9840da5ae
16 Patch0:         %{name}-link.patch
17 Patch1:         %{name}-python.patch
18 URL:            http://gpsd.berlios.de/
19 BuildRequires:  QtNetwork-devel >= 4.4
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 %if %{with dbus}
23 BuildRequires:  dbus-devel
24 BuildRequires:  dbus-glib-devel
25 %endif
26 %{?with_bluez:BuildRequires:    bluez-libs-devel}
27 BuildRequires:  docbook-dtd412-xml
28 BuildRequires:  docbook-style-xsl
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool >= 2:1.5
31 BuildRequires:  libusb-devel >= 1.0.0
32 BuildRequires:  libxslt-progs
33 BuildRequires:  ncurses-devel
34 BuildRequires:  pkgconfig
35 BuildRequires:  python-devel >= 1:2.4
36 BuildRequires:  qt4-qmake >= 4.4
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  xmlto
39 Requires:       %{name}-libs = %{version}-%{release}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         udevdir         /lib/udev
43
44 %description
45 gpsd is a service daemon that mediates access to a GPS sensor
46 connected to the host computer by serial or USB interface, making its
47 data on the location/course/velocity of the sensor available to be
48 queried on TCP port 2947 of the host computer. With gpsd, multiple GPS
49 client applications (such as navigational and wardriving software) can
50 share access to a GPS without contention or loss of data. Also, gpsd
51 responds to queries with a format that is substantially easier to
52 parse than NMEA 0183. A client library is provided for applications.
53
54 After installing this RPM, gpsd will automatically connect to USB
55 GPSes when they are plugged in and requires no configuration. For
56 serial GPSes, you will need to start gpsd by hand. Once connected, the
57 daemon automatically discovers the correct baudrate, stop bits, and
58 protocol. The daemon will be quiescent when there are no clients
59 asking for location information, and copes gracefully when the GPS is
60 unplugged and replugged.
61
62 %description -l pl.UTF-8
63 gpsd to demon usługi pośredniczącej w dostępie do sensora GPS
64 połączonego z komputerem poprzez interfejs szeregowy lub USB,
65 udostępniający dane o położeniu, kierunku ruchu i prędkości z sensora
66 na porcie TCP 2947 komputera. Przy użyciu gpsd wiele aplikacji
67 klienckich GPS (takich jak oprogramowanie nawigacyjne) może
68 współdzielić dostęp do GPS-a bez utraty danych. Ponadto gpsd odpowiada
69 na zapytania w formacie znacznie łatwiejszym do przetworzenia niż NMEA
70 0183. Dostarczona jest biblioteka kliencka dla aplikacji.
71
72 Po zainstalowaniu tego pakietu gpsd będzie się automatycznie łączył z
73 GPS-ami USB po podłączeniu ich. Dla GPS-ów szeregowych trzeba
74 uruchomić gpsd ręcznie. Po poączeniu demon automatycznie wykrywa
75 właściwą prędkość, liczbę bitów stopu i protokół. Demon oczekuje
76 spokojnie kiedy nie ma klientów i radzi sobie dobrze z odłączaniem i
77 ponownym podłączaniem GPS-a.
78
79 %package -n udev-gpsd
80 Summary:        UDEV support for GPS hotplugging
81 Summary(pl.UTF-8):      Obsługa UDEV-a do podłączania urządzeń GPS
82 Group:          Applications/System
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       udev-core >= 1:127
85
86 %description -n udev-gpsd
87 UDEV support for GPS hotplugging.
88
89 %description -n udev-gpsd -l pl.UTF-8
90 Obsługa UDEV-a do podłączania urządzeń GPS.
91
92 %package libs
93 Summary:        GPSd client library
94 Summary(pl.UTF-8):      Biblioteka kliencka GPSd
95 Group:          Libraries
96
97 %description libs
98 GPSd client library.
99
100 %description libs -l pl.UTF-8
101 Biblioteka kliencka GPSd.
102
103 %package devel
104 Summary:        Client libraries in C and Python for talking to a running gpsd or GPS
105 Summary(pl.UTF-8):      Biblioteki klienckie dla C i Pythona do komunikacji z gpsd lub GPS-em
106 Group:          Development/Libraries
107 Requires:       %{name}-libs = %{version}-%{release}
108 Requires:       libstdc++-devel
109
110 %description devel
111 This package provides C header files for the gpsd shared libraries
112 that manage access to a GPS for applications; also Python modules. You
113 will need to have gpsd installed for it to work.
114
115 %description devel -l pl.UTF-8
116 Ten pakiet zawiera pliki nagłówkowe C dla bibliotek współdzielonych
117 gpsd zarządzających dostępem do GPS-a dla aplikacji, a także moduły
118 Pythona. Do działania bibliotek potrzebny jest gpsd.
119
120 %package static
121 Summary:        Static GPS client library
122 Summary(pl.UTF-8):      Statyczna biblioteka kliencka GPS
123 Group:          Development/Libraries
124 Requires:       %{name}-devel = %{version}-%{release}
125
126 %description static
127 Static GPS client library.
128
129 %description static -l pl.UTF-8
130 Statyczna biblioteka kliencka GPS.
131
132 %package qt-libs
133 Summary:        GPS Qt4 integration library
134 Summary(pl.UTF-8):      Biblioteka integrująca GPS z Qt4
135 Group:          X11/Libraries
136 Requires:       %{name}-libs = %{version}-%{release}
137 Requires:       QtNetwork >= 4.4
138
139 %description qt-libs
140 GPS Qt4 integration library.
141
142 %description qt-libs -l pl.UTF-8
143 Biblioteka integrująca GPS z Qt4.
144
145 %package qt-devel
146 Summary:        Development files for GPS Qt4 integration library
147 Summary(pl.UTF-8):      Pliki programistyczne biblioteki integrującej GPS z Qt4
148 Group:          X11/Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150 Requires:       %{name}-qt-libs = %{version}-%{release}
151 Requires:       QtNetwork-devel >= 4.4
152
153 %description qt-devel
154 Development files for GPS Qt4 integration library.
155
156 %description qt-devel -l pl.UTF-8
157 Pliki programistyczne biblioteki integrującej GPS z Qt4.
158
159 %package -n python-gps
160 Summary:        Python GPSd client library
161 Summary(pl.UTF-8):      Biblioteka kliencka GPSd dla Pythona
162 Group:          Libraries/Python
163 Requires:       %{name}-libs = %{version}-%{release}
164
165 %description -n python-gps
166 GPSd client library for Python.
167
168 %description -n python-gps -l pl.UTF-8
169 Biblioteka kliencka GPSd dla Pythona.
170
171 %package clients
172 Summary:        Clients for gpsd
173 Summary(pl.UTF-8):      Aplikacje klienckie dla gpsd
174 Group:          Applications/System
175 Requires:       %{name}-libs = %{version}-%{release}
176
177 %description clients
178 cgps is a simple test client for gpsd. It displays current GPS
179 position/time/velocity information and (for GPSes that support the
180 feature) the locations of accessible satellites. cgps resembles xgps,
181 but without the pictorial satellite display. It can run on a serial
182 terminal or terminal emulator.
183
184 %description clients -l pl.UTF-8
185 cgps to prosty klient testowy dla gpsd. Wyświetla bieżące informacje
186 GPS o położeniu, czasie i prędkości oraz (w przypadku GPS-ów
187 obsługujących to) położenia dostępnych satelitów. Jest podobny do
188 xgps, ale nie ma rysunkowego przedstawiania satelitów. Może działać na
189 terminalu szeregowym lub emulatorze terminala.
190
191 %package clients-gui
192 Summary:        Clients for gpsd with an X interface
193 Summary(pl.UTF-8):      Aplikacje klienckie z interfejsem X
194 Group:          Applications/System
195 Requires:       %{name}-libs = %{version}-%{release}
196 Requires:       python-gps = %{version}-%{release}
197 Requires:       python-pygtk-gtk >= 2:2.0
198
199 %description clients-gui
200 xgps is a simple test client for gpsd with an X interface. It displays
201 current GPS position/time/velocity information and (for GPSes that
202 support the feature) the locations of accessible satellites.
203
204 xgpsspeed is a speedometer that uses position information from the
205 GPS.
206
207 %description clients-gui -l pl.UTF-8
208 xgps to prosty klient testowy dla gpsd z interfejsem X. Wyświetla
209 bieżące informacje GPS o położeniu, czasie i prędkości oraz (w
210 przypadku GPS-ów obsługujących to) położenia dostępnych satelitów.
211
212 xgpsspeed to prędkościomierz używający informacji o położeniu z GPS-a.
213
214 %prep
215 %setup -q
216 %patch0 -p1
217 %patch1 -p1
218
219 %build
220 %{__libtoolize}
221 %{__aclocal}
222 %{__autoconf}
223 %{__autoheader}
224 %{__automake}
225 %configure \
226         CPPFLAGS="-I/usr/include/ncurses" \
227         %{?with_bluez:--enable-bluetooth} \
228         %{?with_dbus:--enable-dbus} \
229         %{!?with_x:--without-x}
230
231 %{__make} -j1
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_datadir}/%{name}}
236 install -d $RPM_BUILD_ROOT{%{udevdir},/etc/{udev/rules.d,sysconfig}}
237
238 %{__make} -j1 install \
239         DESTDIR=$RPM_BUILD_ROOT
240
241 install gpsd.hotplug gpsd.hotplug.wrapper $RPM_BUILD_ROOT%{udevdir}
242 #install        gpsd.udev $RPM_BUILD_ROOT/etc/udev/rules.d/25-gpsd.rules
243 #install        gpsd.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/gpsd
244 install dgpsip-servers $RPM_BUILD_ROOT%{_datadir}/gpsd/dgpsip-servers
245
246 # check if missing header installation is up to date
247 [ ! -f $RPM_BUILD_ROOT%{_includedir}/libQgpsmm_global.h ] || exit 1
248 install libQgpsmm/libQgpsmm_global.h $RPM_BUILD_ROOT%{_includedir}
249
250 [ ! -d $RPM_BUILD_ROOT%{_desktopdir} ] || exit 1
251 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
252 install packaging/X11/{xgps,xgpsspeed}.desktop $RPM_BUILD_ROOT%{_desktopdir}
253 install packaging/X11/gpsd-logo.png $RPM_BUILD_ROOT%{_pixmapsdir}
254
255 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
256 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
257 %py_postclean
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %post   libs -p /sbin/ldconfig
263 %postun libs -p /sbin/ldconfig
264
265 %post   qt-libs -p /sbin/ldconfig
266 %postun qt-libs -p /sbin/ldconfig
267
268 %files
269 %defattr(644,root,root,755)
270 %doc README INSTALL COPYING TODO AUTHORS
271 %attr(755,root,root) %{_sbindir}/gpsd
272 %attr(755,root,root) %{_bindir}/gpsmon
273 %{_mandir}/man8/gpsd.8*
274 %{_mandir}/man1/gpsmon.1*
275 %dir %{_datadir}/gpsd
276 %{_datadir}/gpsd/dgpsip-servers
277
278 %files -n udev-gpsd
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{udevdir}/gpsd.hotplug
281 %attr(755,root,root) %{udevdir}/gpsd.hotplug.wrapper
282 #/etc/udev/rules.d/25-gpsd.rules
283 #%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/gpsd
284
285 %files libs
286 %defattr(644,root,root,755)
287 %attr(755,root,root) %{_libdir}/libgpsd.so.*.*.*
288 %attr(755,root,root) %ghost %{_libdir}/libgpsd.so.0
289 %attr(755,root,root) %{_libdir}/libgps.so.*.*.*
290 %attr(755,root,root) %ghost %{_libdir}/libgps.so.19
291
292 %files devel
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_bindir}/gpsdecode
295 %attr(755,root,root) %{_libdir}/libgps.so
296 %attr(755,root,root) %{_libdir}/libgpsd.so
297 %{_libdir}/libgps.la
298 %{_libdir}/libgpsd.la
299 %{_includedir}/gps.h
300 %{_includedir}/gpsd.h
301 %{_includedir}/libgpsmm.h
302 %{_pkgconfigdir}/libgps.pc
303 %{_pkgconfigdir}/libgpsd.pc
304 %{_mandir}/man1/gpsdecode.1*
305 %{_mandir}/man3/libgps.3*
306 %{_mandir}/man3/libgpsd.3*
307 %{_mandir}/man3/libgpsmm.3*
308 %{_mandir}/man5/rtcm-104.5*
309 %{_mandir}/man5/srec.5*
310
311 %files static
312 %defattr(644,root,root,755)
313 %{_libdir}/libgps.a
314 %{_libdir}/libgpsd.a
315
316 %files qt-libs
317 %defattr(644,root,root,755)
318 %attr(755,root,root) %{_libdir}/libQgpsmm.so.*.*.*
319 %attr(755,root,root) %ghost %{_libdir}/libQgpsmm.so.19
320
321 %files qt-devel
322 %defattr(644,root,root,755)
323 %attr(755,root,root) %{_libdir}/libQgpsmm.so
324 %{_includedir}/libQgpsmm_global.h
325
326 %files -n python-gps
327 %defattr(644,root,root,755)
328 %attr(755,root,root) %{_bindir}/gpscat
329 %attr(755,root,root) %{_bindir}/gpsfake
330 %attr(755,root,root) %{_bindir}/gpsprof
331 %dir %{py_sitedir}/gps
332 %attr(755,root,root) %{py_sitedir}/gps/*.so
333 %{py_sitedir}/gps/*.py[co]
334 %{py_sitedir}/gps-%{version}-py*.egg-info
335 %{py_sitescriptdir}/gpscap.py[co]
336 %{_mandir}/man1/gpscat.1*
337 %{_mandir}/man1/gpsfake.1*
338 %{_mandir}/man1/gpsprof.1*
339
340 %files clients
341 %defattr(644,root,root,755)
342 %attr(755,root,root) %{_bindir}/gpsctl
343 %attr(755,root,root) %{_bindir}/cgps
344 %attr(755,root,root) %{_bindir}/gpspipe
345 %{?with_dbus:%attr(755,root,root) %{_bindir}/gpxlogger}
346 %{_mandir}/man1/gpsctl.1*
347 %{_mandir}/man1/cgps.1*
348 %{_mandir}/man1/gps.1*
349 %{_mandir}/man1/gpspipe.1*
350
351 %if %{with x}
352 %files clients-gui
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_bindir}/lcdgps
355 %attr(755,root,root) %{_bindir}/xgps
356 %attr(755,root,root) %{_bindir}/xgpsspeed
357 %{_mandir}/man1/lcdgps.1*
358 %{_mandir}/man1/xgps.1*
359 %{_mandir}/man1/xgpsspeed.1*
360 %{_desktopdir}/xgps.desktop
361 %{_desktopdir}/xgpsspeed.desktop
362 %{_pixmapsdir}/gpsd-logo.png
363 %endif
This page took 0.081684 seconds and 4 git commands to generate.