]> git.pld-linux.org Git - packages/gpsd.git/blob - gpsd.spec
- unified, .so perms
[packages/gpsd.git] / gpsd.spec
1 #
2 # TODO:
3 #       - integrate udev stuff from Debian (die hotplug, die!)
4 #       - fix pysitedir???
5 #       
6 # Conditional build:
7 %bcond_without  dbus    # build without dbus support
8 #
9 Summary:        Service daemon for mediating access to a GPS
10 Summary(pl.UTF-8):      Oprogramowanie komunikujące się z GPS-em
11 Name:           gpsd
12 Version:        2.37
13 Release:        0.1
14 License:        BSD
15 Group:          Daemons
16 Source0:        http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
17 # Source0-md5:  6c96cc0b2df0279cb7baac1ebc5881d3
18 Patch0:         %{name}-ncurses.patch
19 URL:            http://gpsd.berlios.de/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 %if %{with dbus}
23 BuildRequires:  dbus-devel
24 BuildRequires:  dbus-glib-devel
25 %endif
26 BuildRequires:  ncurses-devel
27 BuildRequires:  openmotif-devel
28 BuildRequires:  python-devel
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  xorg-lib-libXaw-devel
31 Requires:       %{name}-libs = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _appdefsdir     /usr/share/X11/app-defaults
35
36 %description
37 gpsd is a service daemon that mediates access to a GPS sensor
38 connected to the host computer by serial or USB interface, making its
39 data on the location/course/velocity of the sensor available to be
40 queried on TCP port 2947 of the host computer. With gpsd, multiple GPS
41 client applications (such as navigational and wardriving software) can
42 share access to a GPS without contention or loss of data. Also, gpsd
43 responds to queries with a format that is substantially easier to
44 parse than NMEA 0183. A client library is provided for applications.
45
46 After installing this RPM, gpsd will automatically connect to USB
47 GPSes when they are plugged in and requires no configuration. For
48 serial GPSes, you will need to start gpsd by hand. Once connected, the
49 daemon automatically discovers the correct baudrate, stop bits, and
50 protocol. The daemon will be quiescent when there are no clients
51 asking for location information, and copes gracefully when the GPS is
52 unplugged and replugged.
53
54 %description -l pl.UTF-8
55 gpsd to demon usługi pośredniczącej w dostępie do sensora GPS
56 połączonego z komputerem poprzez interfejs szeregowy lub USB,
57 udostępniający dane o położeniu, kierunku ruchu i prędkości z sensora
58 na porcie TCP 2947 komputera. Przy użyciu gpsd wiele aplikacji
59 klienckich GPS (takich jak oprogramowanie nawigacyjne) może
60 współdzielić dostęp do GPS-a bez utraty danych. Ponadto gpsd odpowiada
61 na zapytania w formacie znacznie łatwiejszym do przetworzenia niż NMEA
62 0183. Dostarczona jest biblioteka kliencka dla aplikacji.
63
64 Po zainstalowaniu tego pakietu gpsd będzie się automatycznie łączył z
65 GPS-ami USB po podłączeniu ich. Dla GPS-ów szeregowych trzeba
66 uruchomić gpsd ręcznie. Po poączeniu demon automatycznie wykrywa
67 właściwą prędkość, liczbę bitów stopu i protokół. Demon oczekuje
68 spokojnie kiedy nie ma klientów i radzi sobie dobrze z odłączaniem i
69 ponownym podłączaniem GPS-a.
70
71 %package libs
72 Summary:        GPSd client library
73 Summary(pl.UTF-8):      Biblioteka kliencka GPSd
74 Group:          Libraries
75
76 %description libs
77 GPSd client library.
78
79 %description libs -l pl.UTF-8
80 Biblioteka kliencka GPSd.
81
82 %package devel
83 Summary:        Client libraries in C and Python for talking to a running gpsd or GPS
84 Summary(pl.UTF-8):      Biblioteki klienckie dla C i Pythona do komunikacji z gpsd lub GPS-em
85 Group:          Development/Libraries
86 Requires:       %{name}-libs = %{version}-%{release}
87
88 %description devel
89 This package provides C header files for the gpsd shared libraries
90 that manage access to a GPS for applications; also Python modules. You
91 will need to have gpsd installed for it to work.
92
93 %description devel -l pl.UTF-8
94 Ten pakiet zawiera pliki nagłówkowe C dla bibliotek współdzielonych
95 gpsd zarządzających dostępem do GPS-a dla aplikacji, a także moduły
96 Pythona. Do działania bibliotek potrzebny jest gpsd.
97
98 %package static
99 Summary:        Static GPS client library
100 Summary(pl.UTF-8):      Statyczna biblioteka kliencka GPS
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103
104 %description static
105 Static GPS client library.
106
107 %description static -l pl.UTF-8
108 Statyczna biblioteka kliencka GPS.
109
110 %package -n python-gps
111 Summary:        Python GPSd client library
112 Summary(pl.UTF-8):      Biblioteka kliencka GPSd dla Pythona
113 Group:          Libraries/Python
114 Requires:       %{name}-libs = %{version}-%{release}
115
116 %description -n python-gps
117 GPSd client library for Python.
118
119 %description -n python-gps -l pl.UTF-8
120 Biblioteka kliencka GPSd dla Pythona.
121
122 %package clients
123 Summary:        Clients for gpsd with an X interface
124 Summary(pl.UTF-8):      Aplikacje klienckie z interfejsem X
125 Group:          Applications/System
126 Requires:       %{name}-libs = %{version}-%{release}
127 Requires:       xorg-lib-libXt >= 1.0.0
128
129 %description clients
130 xgps is a simple test client for gpsd with an X interface. It displays
131 current GPS position/time/velocity information and (for GPSes that
132 support the feature) the locations of accessible satellites.
133
134 xgpsspeed is a speedometer that uses position information from the
135 GPS. It accepts an -h option and optional argument as for gps, or a -v
136 option to dump the package version and exit. Additionally, it accepts
137 -rv (reverse video) and -nc (needle color) options.
138
139 cgps resembles xgps, but without the pictorial satellite display. It
140 can run on a serial terminal or terminal emulator.
141
142 %description clients -l pl.UTF-8
143 xgps to prosty klient testowy dla gpsd z interfejsem X. Wyświetla
144 bieżące informacje GPS o położeniu, czasie i prędkości oraz (w
145 przypadku GPS-ów obsługujących to) położenia dostępnych satelitów.
146
147 xgpsspeed to prędkościomierz używający informacji o położeniu z GPS-a.
148 Przyjmuje opcję -h i opcjonalnie argument taki jak gps lub opcję -v w
149 celu wyświetlenia wersji pakietu. Ponadto przyjmuje opcje -rv (reverse
150 video - odwrotny obraz) i -nc (needle color).
151
152 cgps jest podobny do xgps, ale bez rysunkowego przedstawiania
153 satelitów. Może działać na terminalu szeregowym lub emulatorze
154 terminala.
155
156 %prep
157 %setup -q
158 %patch0 -p1
159
160 %build
161 %{__libtoolize}
162 %{__aclocal}
163 %{__autoconf}
164 %{__autoheader}
165 %{__automake}
166 %configure \
167         %{?with_dbus:--enable-dbus}
168
169 %{__make}
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hotplug/usb,%{_appdefsdir},%{py_sitedir},%{_datadir}/%{name}}
174
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT
177
178 install gpsd.hotplug gpsd.usermap $RPM_BUILD_ROOT%{_sysconfdir}/hotplug/usb
179 install xgps.ad $RPM_BUILD_ROOT%{_appdefsdir}/xgps
180 install xgpsspeed.ad $RPM_BUILD_ROOT%{_appdefsdir}/xgpsspeed
181 install dgpsip-servers $RPM_BUILD_ROOT%{_datadir}/gpsd/dgpsip-servers
182
183 rm -f $RPM_BUILD_ROOT%{_libdir}/libgps.so.[0-9][0-9]
184
185 mv $RPM_BUILD_ROOT%{py_sitescriptdir}/*.so $RPM_BUILD_ROOT%{py_sitedir}
186
187 %py_postclean
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %post   libs -p /sbin/ldconfig
193 %postun libs -p /sbin/ldconfig
194
195 %files
196 %defattr(644,root,root,755)
197 %doc README INSTALL COPYING TODO AUTHORS
198 %attr(755,root,root) %{_sbindir}/gpsd
199 %attr(755,root,root) %{_bindir}/gpsprof
200 %attr(755,root,root) %{_bindir}/sirfmon
201 %{_mandir}/man8/gpsd.8*
202 %{_mandir}/man1/gpsprof.1*
203 %{_mandir}/man1/sirfmon.1*
204 %{_sysconfdir}/hotplug/usb/gpsd.hotplug
205 %{_sysconfdir}/hotplug/usb/gpsd.usermap
206 %dir %{_datadir}/%{name}
207 %{_datadir}/gpsd/dgpsip-servers
208 %{_pkgconfigdir}/libgps.pc
209 %{_pkgconfigdir}/libgpsd.pc
210  
211 %files libs
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_libdir}/libgps.so.*.*.*
214
215 %files devel
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_bindir}/gpsfake
218 %attr(755,root,root) %{_bindir}/rtcmdecode
219 %attr(755,root,root) %{_bindir}/gpsflash
220 %attr(755,root,root) %{_libdir}/libgps.so
221 %{_libdir}/libgps.la
222 %{_includedir}/gps.h
223 %{_includedir}/libgpsmm.h
224 %{_includedir}/gpsd.h
225 %{_mandir}/man1/gpsfake.1*
226 %{_mandir}/man1/rtcmdecode.1*
227 %{_mandir}/man1/gpsflash.1*
228 %{_mandir}/man3/libgps.3*
229 %{_mandir}/man3/libgpsmm.3*
230 %{_mandir}/man3/libgpsd.3*
231 %{_mandir}/man5/rtcm-104.5*
232 %{_mandir}/man5/srec.5*
233
234 %files static
235 %defattr(644,root,root,755)
236 %{_libdir}/libgps.a
237
238 %files -n python-gps
239 %defattr(644,root,root,755)
240 %{py_sitescriptdir}/*.py[co]
241 %attr(755,root,root) %{py_sitedir}/*.so
242
243 %files clients
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_bindir}/gpscat
246 %attr(755,root,root) %{_bindir}/gpsctl
247 %attr(755,root,root) %{_bindir}/xgps
248 %attr(755,root,root) %{_bindir}/xgpsspeed
249 %attr(755,root,root) %{_bindir}/cgpxlogger
250 %attr(755,root,root) %{_bindir}/cgps
251 %attr(755,root,root) %{_bindir}/gpspipe
252 %{?with_dbus:%attr(755,root,root) %{_bindir}/gpxlogger}
253 %{_mandir}/man1/gpscat.1*
254 %{_mandir}/man1/gpsctl.1*
255 %{_mandir}/man1/xgps.1*
256 %{_mandir}/man1/cgps.1*
257 %{_mandir}/man1/cgpxlogger.1*
258 %{_mandir}/man1/gps.1*
259 %{_mandir}/man1/xgpsspeed.1*
260 %{_mandir}/man1/gpspipe.1*
261 %{_appdefsdir}/xgps
262 %{_appdefsdir}/xgpsspeed
This page took 0.096537 seconds and 3 git commands to generate.