]> git.pld-linux.org Git - packages/gpsd.git/blob - gpsd.spec
- added required skip_post_check_so
[packages/gpsd.git] / gpsd.spec
1 # TODO:
2 #       - fix pysitedir???
3 #   - ?? what the above todo means??
4 #
5 # Conditional build:
6 %bcond_without  dbus    # build without dbus support
7 %bcond_without  x       # build without X Window System support
8
9 %define         skip_post_check_so      libgpsd.so.0.0.0
10
11 Summary:        Service daemon for mediating access to a GPS
12 Summary(pl.UTF-8):      Oprogramowanie komunikujące się z GPS-em
13 Name:           gpsd
14 Version:        2.95
15 Release:        2
16 License:        BSD
17 Group:          Daemons
18 Source0:        http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
19 # Source0-md5:  12535a9ed9fecf9ea2c5bdc9840da5ae
20 Patch0:         %{name}-link.patch
21 URL:            http://gpsd.berlios.de/
22 %if %{with dbus}
23 BuildRequires:  dbus-devel
24 BuildRequires:  dbus-glib-devel
25 %endif
26 BuildRequires:  docbook-dtd412-xml
27 BuildRequires:  docbook-style-xsl
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libusb-devel
30 BuildRequires:  libxslt-progs
31 BuildRequires:  ncurses-devel
32 %{?with_x:BuildRequires:        openmotif-devel}
33 BuildRequires:  pkgconfig
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  xmlto
37 %{?with_x:BuildRequires:        xorg-lib-libXaw-devel}
38 Requires:       %{name}-libs = %{version}-%{release}
39 Requires:       udev-core >= 1:127
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         udevdir         /lib/udev
43
44 %description
45 gpsd is a service daemon that mediates access to a GPS sensor
46 connected to the host computer by serial or USB interface, making its
47 data on the location/course/velocity of the sensor available to be
48 queried on TCP port 2947 of the host computer. With gpsd, multiple GPS
49 client applications (such as navigational and wardriving software) can
50 share access to a GPS without contention or loss of data. Also, gpsd
51 responds to queries with a format that is substantially easier to
52 parse than NMEA 0183. A client library is provided for applications.
53
54 After installing this RPM, gpsd will automatically connect to USB
55 GPSes when they are plugged in and requires no configuration. For
56 serial GPSes, you will need to start gpsd by hand. Once connected, the
57 daemon automatically discovers the correct baudrate, stop bits, and
58 protocol. The daemon will be quiescent when there are no clients
59 asking for location information, and copes gracefully when the GPS is
60 unplugged and replugged.
61
62 %description -l pl.UTF-8
63 gpsd to demon usługi pośredniczącej w dostępie do sensora GPS
64 połączonego z komputerem poprzez interfejs szeregowy lub USB,
65 udostępniający dane o położeniu, kierunku ruchu i prędkości z sensora
66 na porcie TCP 2947 komputera. Przy użyciu gpsd wiele aplikacji
67 klienckich GPS (takich jak oprogramowanie nawigacyjne) może
68 współdzielić dostęp do GPS-a bez utraty danych. Ponadto gpsd odpowiada
69 na zapytania w formacie znacznie łatwiejszym do przetworzenia niż NMEA
70 0183. Dostarczona jest biblioteka kliencka dla aplikacji.
71
72 Po zainstalowaniu tego pakietu gpsd będzie się automatycznie łączył z
73 GPS-ami USB po podłączeniu ich. Dla GPS-ów szeregowych trzeba
74 uruchomić gpsd ręcznie. Po poączeniu demon automatycznie wykrywa
75 właściwą prędkość, liczbę bitów stopu i protokół. Demon oczekuje
76 spokojnie kiedy nie ma klientów i radzi sobie dobrze z odłączaniem i
77 ponownym podłączaniem GPS-a.
78
79 %package libs
80 Summary:        GPSd client library
81 Summary(pl.UTF-8):      Biblioteka kliencka GPSd
82 Group:          Libraries
83
84 %description libs
85 GPSd client library.
86
87 %description libs -l pl.UTF-8
88 Biblioteka kliencka GPSd.
89
90 %package devel
91 Summary:        Client libraries in C and Python for talking to a running gpsd or GPS
92 Summary(pl.UTF-8):      Biblioteki klienckie dla C i Pythona do komunikacji z gpsd lub GPS-em
93 Group:          Development/Libraries
94 Requires:       %{name}-libs = %{version}-%{release}
95
96 %description devel
97 This package provides C header files for the gpsd shared libraries
98 that manage access to a GPS for applications; also Python modules. You
99 will need to have gpsd installed for it to work.
100
101 %description devel -l pl.UTF-8
102 Ten pakiet zawiera pliki nagłówkowe C dla bibliotek współdzielonych
103 gpsd zarządzających dostępem do GPS-a dla aplikacji, a także moduły
104 Pythona. Do działania bibliotek potrzebny jest gpsd.
105
106 %package static
107 Summary:        Static GPS client library
108 Summary(pl.UTF-8):      Statyczna biblioteka kliencka GPS
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111
112 %description static
113 Static GPS client library.
114
115 %description static -l pl.UTF-8
116 Statyczna biblioteka kliencka GPS.
117
118 %package -n python-gps
119 Summary:        Python GPSd client library
120 Summary(pl.UTF-8):      Biblioteka kliencka GPSd dla Pythona
121 Group:          Libraries/Python
122 Requires:       %{name}-libs = %{version}-%{release}
123
124 %description -n python-gps
125 GPSd client library for Python.
126
127 %description -n python-gps -l pl.UTF-8
128 Biblioteka kliencka GPSd dla Pythona.
129
130 %package clients
131 Summary:        Clients for gpsd
132 Summary(pl.UTF-8):      Aplikacje klienckie dla gpsd
133 Group:          Applications/System
134 Requires:       %{name}-libs = %{version}-%{release}
135
136 %description clients
137 cgps is a simple test client for gpsd. It displays current GPS
138 position/time/velocity information and (for GPSes that support the
139 feature) the locations of accessible satellites. cgps resembles xgps,
140 but without the pictorial satellite display. It can run on a serial
141 terminal or terminal emulator.
142
143 %description clients -l pl.UTF-8
144 cgps to prosty klient testowy dla gpsd. Wyświetla bieżące informacje
145 GPS o położeniu, czasie i prędkości oraz (w przypadku GPS-ów
146 obsługujących to) położenia dostępnych satelitów. Jest podobny do
147 xgps, ale nie ma rysunkowego przedstawiania satelitów. Może działać na
148 terminalu szeregowym lub emulatorze terminala.
149
150 %package clients-gui
151 Summary:        Clients for gpsd with an X interface
152 Summary(pl.UTF-8):      Aplikacje klienckie z interfejsem X
153 Group:          Applications/System
154 Requires:       %{name}-libs = %{version}-%{release}
155 Requires:       xorg-lib-libXt >= 1.0.0
156
157 %description clients-gui
158 xgps is a simple test client for gpsd with an X interface. It displays
159 current GPS position/time/velocity information and (for GPSes that
160 support the feature) the locations of accessible satellites.
161
162 xgpsspeed is a speedometer that uses position information from the
163 GPS.
164
165 %description clients-gui -l pl.UTF-8
166 xgps to prosty klient testowy dla gpsd z interfejsem X. Wyświetla
167 bieżące informacje GPS o położeniu, czasie i prędkości oraz (w
168 przypadku GPS-ów obsługujących to) położenia dostępnych satelitów.
169
170 xgpsspeed to prędkościomierz używający informacji o położeniu z GPS-a.
171
172 %prep
173 %setup -q
174 %patch0 -p1
175 sed -i -e 's#/usr/lib/libusb-\*\.so#/usr/%{_lib}/libusb-*.so#g' configure*
176
177 %build
178 %{__libtoolize}
179 %{__aclocal}
180 %{__autoconf}
181 %configure CPPFLAGS="-I/usr/include/ncurses $(pkg-config --cflags-only-I libusb-1.0)" \
182         %{?with_dbus:--enable-dbus} \
183         %{!?with_x:--without-x}
184
185 %{__make} -j1
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_datadir}/%{name}}
190 install -d $RPM_BUILD_ROOT{%{udevdir},/etc/{udev/rules.d,sysconfig}}
191
192 %{__make} -j1 install \
193         DESTDIR=$RPM_BUILD_ROOT
194
195 install gpsd.hotplug gpsd.hotplug.wrapper $RPM_BUILD_ROOT%{udevdir}
196 #install        gpsd.udev $RPM_BUILD_ROOT/etc/udev/rules.d/25-gpsd.rules
197 #install        gpsd.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/gpsd
198 install dgpsip-servers $RPM_BUILD_ROOT%{_datadir}/gpsd/dgpsip-servers
199
200 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
201 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
202 %py_postclean
203
204 %clean
205 rm -rf $RPM_BUILD_ROOT
206
207 %post   libs -p /sbin/ldconfig
208 %postun libs -p /sbin/ldconfig
209
210 %files
211 %defattr(644,root,root,755)
212 %doc README INSTALL COPYING TODO AUTHORS
213 %attr(755,root,root) %{_sbindir}/gpsd
214 %attr(755,root,root) %{_bindir}/gpsmon
215 %{_mandir}/man8/gpsd.8*
216 %{_mandir}/man1/gpsmon.1*
217 %attr(755,root,root) %{udevdir}/gpsd.hotplug
218 %attr(755,root,root) %{udevdir}/gpsd.hotplug.wrapper
219 #/etc/udev/rules.d/25-gpsd.rules
220 #%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/gpsd
221 %dir %{_datadir}/%{name}
222 %{_datadir}/gpsd/dgpsip-servers
223
224 %files libs
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libgpsd.so.*.*.*
227 %attr(755,root,root) %ghost %{_libdir}/libgpsd.so.0
228 %attr(755,root,root) %{_libdir}/libgps.so.*.*.*
229 %attr(755,root,root) %ghost %{_libdir}/libgps.so.19
230 %attr(755,root,root) %{_libdir}/libQgpsmm.so.*.*.*
231 %attr(755,root,root) %ghost %{_libdir}/libQgpsmm.so.19
232
233 %files devel
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_bindir}/gpsdecode
236 %attr(755,root,root) %{_libdir}/libgps.so
237 %attr(755,root,root) %{_libdir}/libgpsd.so
238 %{_libdir}/libgps.la
239 %{_libdir}/libgpsd.la
240 %{_includedir}/gps.h
241 %{_includedir}/gpsd.h
242 %{_includedir}/libgpsmm.h
243 %{_pkgconfigdir}/libgps.pc
244 %{_pkgconfigdir}/libgpsd.pc
245 %{_mandir}/man1/gpsdecode.1*
246 %{_mandir}/man3/libgps.3*
247 %{_mandir}/man3/libgpsd.3*
248 %{_mandir}/man3/libgpsmm.3*
249 %{_mandir}/man5/rtcm-104.5*
250 %{_mandir}/man5/srec.5*
251
252 %files static
253 %defattr(644,root,root,755)
254 %{_libdir}/libgps.a
255 %{_libdir}/libgpsd.a
256
257 %files -n python-gps
258 %defattr(644,root,root,755)
259 %attr(755,root,root) %{_bindir}/gpscat
260 %attr(755,root,root) %{_bindir}/gpsfake
261 %attr(755,root,root) %{_bindir}/gpsprof
262 %{py_sitescriptdir}/gpscap.py[co]
263
264 %dir %{py_sitedir}/gps
265 %attr(755,root,root) %{py_sitedir}/gps/*.so
266 %{py_sitedir}/gps/*.py[co]
267 %{py_sitedir}/*.egg*
268
269 %{_mandir}/man1/gpscat.1*
270 %{_mandir}/man1/gpsfake.1*
271 %{_mandir}/man1/gpsprof.1*
272
273 %files clients
274 %defattr(644,root,root,755)
275 %attr(755,root,root) %{_bindir}/gpsctl
276 %attr(755,root,root) %{_bindir}/cgps
277 %attr(755,root,root) %{_bindir}/gpspipe
278 %{?with_dbus:%attr(755,root,root) %{_bindir}/gpxlogger}
279 %{_mandir}/man1/gpsctl.1*
280 %{_mandir}/man1/cgps.1*
281 #%{_mandir}/man1/cgpxlogger.1*
282 %{_mandir}/man1/gps.1*
283 %{_mandir}/man1/gpspipe.1*
284
285 %if %{with x}
286 %files clients-gui
287 %defattr(644,root,root,755)
288 %attr(755,root,root) %{_bindir}/lcdgps
289 %attr(755,root,root) %{_bindir}/xgps
290 %attr(755,root,root) %{_bindir}/xgpsspeed
291 %{_mandir}/man1/lcdgps.1*
292 %{_mandir}/man1/xgps.1*
293 %{_mandir}/man1/xgpsspeed.1*
294 %endif
This page took 0.049674 seconds and 3 git commands to generate.