]> git.pld-linux.org Git - packages/gpsd.git/blob - gpsd.spec
2cd43c5fb2988ec5b2e3e52b2a31ab93eaaf27bc
[packages/gpsd.git] / gpsd.spec
1 # TODO
2 # - at this time package do not build with dbus support
3 #   I do not need it ...
4 # Conditional build:
5 %bcond_without  dbus    # build without dbus support
6
7 #
8 Summary:        Service daemon for mediating access to a GPS
9 #Summary(pl):
10 Name:           gpsd
11 Version:        2.30
12 Release:        1
13 License:        BSD
14 Group:          Daemons
15 Source0:        http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
16 # Source0-md5:  dde177174878e8ae6db15f8010da46dd
17 Patch0:         %{name}-ncurses.patch
18 URL:            http://gpsd.berlios.de/
19 BuildRequires:  ncurses-devel
20 BuildRequires:  X11-devel
21 BuildRequires:  openmotif-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 %if %{?with_dbus}
25 BuildRequires:  dbus-devel
26 BuildRequires:  dbus-glib-devel
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _libx11dir      %{_prefix}/lib/X11
31 %define         _appdefsdir     %{_libx11dir}/app-defaults
32
33 %description
34 gpsd is a service daemon that mediates access to a GPS sensor
35 connected to the host computer by serial or USB interface, making its
36 data on the location/course/velocity of the sensor available to be
37 queried on TCP port 2947 of the host computer. With gpsd, multiple GPS
38 client applications (such as navigational and wardriving software) can
39 share access to a GPS without contention or loss of data. Also, gpsd
40 responds to queries with a format that is substantially easier to
41 parse than NMEA 0183. A client library is provided for applications.
42
43 After installing this RPM, gpsd will automatically connect to USB
44 GPSes when they are plugged in and requires no configuration. For
45 serial GPSes, you will need to start gpsd by hand. Once connected, the
46 daemon automatically discovers the correct baudrate, stop bits, and
47 protocol. The daemon will be quiescent when there are no clients
48 asking for location information, and copes gracefully when the GPS is
49 unplugged and replugged.
50
51 %package -n gpsd-devel
52 Summary:        Client libraries in C and Python for talking to a running gpsd or GPS
53 Group:          Development/Libraries
54 Requires:       gpsd
55
56 %description -n gpsd-devel
57 This package provides C header files for the gpsd shared libraries
58 that manage access to a GPS for applications; also Python modules. You
59 will need to have gpsd installed for it to work.
60
61 %package -n gpsd-clients
62 Summary:        Clients for gpsd with an X interface
63 Group:          Applications/System
64 Requires:       openmotif-libs
65 Requires:       gpsd
66
67 %description -n gpsd-clients
68 xgps is a simple test client for gpsd with an X interface. It displays
69 current GPS position/time/velocity information and (for GPSes that
70 support the feature) the locations of accessible satellites.
71
72 xgpsspeed is a speedometer that uses position information from the
73 GPS. It accepts an -h option and optional argument as for gps, or a -v
74 option to dump the package version and exit. Additionally, it accepts
75 -rv (reverse video) and -nc (needle color) options.
76
77 cgps resembles xgps, but without the pictorial satellite display. It
78 can run on a serial terminal or terminal emulator.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 %{__aclocal}
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure %{?without_dbus: --enable-dbus}
90 %{__make}
91 %{__python} -c "import compiler;compiler.compileFile('gps.py')"
92 %{__python} -c "import compiler;compiler.compileFile('gpsfake.py')"
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/hotplug/usb,%{py_sitedir},%{_appdefsdir},%{_datadir}/gpsd/}
97 #install -d $RPM_BUILD_ROOT
98 #install -d $RPM_BUILD_ROOT/%{_sysconfdir}/hotplug/usb
99 #install -d $RPM_BUILD_ROOT/%{py_sitedir}
100 #install -d $RPM_BUILD_ROOT/%{_appdefsdir}
101 #install -d $RPM_BUILD_ROOT/%{_datadir}/gpsd/
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 install gps.pyc gpsfake.pyc $RPM_BUILD_ROOT/%{py_sitedir}/
107 install gpsd.hotplug gpsd.usermap $RPM_BUILD_ROOT/%{_sysconfdir}/hotplug/usb/
108 install xgps.ad $RPM_BUILD_ROOT/%{_appdefsdir}/xgps
109 install xgpsspeed.ad $RPM_BUILD_ROOT/%{_appdefsdir}/xgpsspeed
110 install dgpsip-servers $RPM_BUILD_ROOT/%{_datadir}/gpsd/dgpsip-servers
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post -n gpsd
116 /sbin/ldconfig
117
118 %postun -n gpsd
119 /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README INSTALL COPYING TODO AUTHORS HACKING
124 %attr(755,root,root) %{_sbindir}/gpsd
125 %attr(755,root,root) %{_bindir}/gpsprof
126 %attr(755,root,root) %{_bindir}/sirfmon
127 %{_libdir}/libgps.la
128 %attr(755,root,root) %{_libdir}/libgps.so*
129 %{_libdir}/libgps.a
130 %{_mandir}/man8/gpsd.8*
131 %{_mandir}/man1/gpsprof.1*
132 %{_mandir}/man1/sirfmon.1*
133 %{_sysconfdir}/hotplug/usb/gpsd.hotplug
134 %{_sysconfdir}/hotplug/usb/gpsd.usermap
135 %{_datadir}/gpsd/dgpsip-servers
136 %{py_sitedir}/gps.pyc
137
138 %files -n gpsd-clients
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_bindir}/xgps
141 %attr(755,root,root) %{_bindir}/xgpsspeed
142 %attr(755,root,root) %{_bindir}/cgps
143 %attr(755,root,root) %{_bindir}/gpspipe
144 %{?without_dbus: %attr(755,root,root) %{_bindir}/gpxlogger}
145 %{_mandir}/man1/xgps.1*
146 %{_mandir}/man1/gpspipe.1*
147 %{?without_dbus: %{_mandir}/man1/gpxlogger.1*}
148 %{_appdefsdir}/xgps
149 %{_appdefsdir}/xgpsspeed
150
151 %files -n gpsd-devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/gpsfake
154 %attr(755,root,root) %{_bindir}/rtcmdecode
155 %attr(755,root,root) %{_bindir}/gpsflash
156 %{py_sitedir}/gpsfake.pyc
157 %{_includedir}/gps.h
158 %{_includedir}/libgpsmm.h
159 %{_includedir}/gpsd.h
160 %{_mandir}/man1/gpsfake.1*
161 %{_mandir}/man1/rtcmdecode.1*
162 %{_mandir}/man1/gpsflash.1*
163 %{_mandir}/man3/libgps.3*
164 %{_mandir}/man3/libgpsmm.3*
165 %{_mandir}/man3/libgpsd.3*
166 %{_mandir}/man5/rtcm-104.5*
167 %{_mandir}/man5/srec.5*
This page took 0.027617 seconds and 2 git commands to generate.