]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- updated
[packages/gpac.git] / gpac.spec
1 #
2 # Conditional build:
3 %bcond_with     amr
4 %bcond_without  faad
5 %bcond_without  ffmpeg
6 %bcond_without  freetype
7 %bcond_without  jpeg
8 %bcond_without  js
9 %bcond_without  mad
10 %bcond_without  png
11 %bcond_without  xvid
12 #
13 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
14 Summary(pl):    GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
15 Name:           gpac
16 Version:        0.2.4
17 Release:        0.1
18 License:        GPL
19 Group:          Applications
20 Source0:        http://dl.sourceforge.net/gpac/%{name}-%{version}.tar.gz
21 # Source0-md5:  cbbea28e99c23d1839d38c54c2cc090a
22 Source1:        http://www.3gpp.org/ftp/Specs/archive/26_series/26.073/26073-530.zip
23 # Source1-md5:  705f6993fbf890e92eb7a331e7c716d1
24 Patch0:         %{name}-install.patch
25 URL:            http://gpac.sourceforge.net/
26 BuildRequires:  SDL-devel
27 #BuildRequires: wxWidgets-devel
28 %{?with_faad:BuildRequires:     faad2-devel}
29 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
30 %{?with_freetype:BuildRequires: freetype-devel}
31 %{?with_js:BuildRequires:       js-devel}
32 %{?with_jpeg:BuildRequires:     libjpeg-devel}
33 %{?with_mad:BuildRequires:      libmad-devel}
34 %{?with_png:BuildRequires:      libpng-devel}
35 %{?with_xvid:BuildRequires:     xvid-devel}
36 Requires:       SDL
37 #Requires:      wxWidgets
38 %{?with_faad:Requires:  faad2}
39 %{?with_ffmpeg:Requires:        ffmpeg}
40 %{?with_freetype:Requires:      freetype}
41 %{?with_js:Requires:    js}
42 %{?with_jpeg:Requires:  libjpeg}
43 %{?with_png:Requires:   libpng}
44 %{?with_mad:Requires:   libmad}
45 %{?with_xvid:Requires:  xvid}
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         _noautoreq   libm4systems.so
49
50 %description
51 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
52 14496-1) developed from scratch in ANSI C.
53
54 The main development goal is to provide a clean (a.k.a. readable by as
55 many people as possible), small and flexible alternative to the MPEG-4
56 Systems reference software (known as IM1 and distributed in ISO/IEC
57 14496-5). The MPEG-4 Reference software is indeed a very large piece
58 of software, designed to verify the standard rather than provide a
59 small, production-stable software. GPAC is written in ANSI C for
60 portability reasons (embedded platforms and DSPs) with a simple goal:
61 keep the memory footprint as low as possible. The project will at term
62 provide player(s), systems encoders and publishing tools for content
63 distribution.
64
65 %description -l pl
66 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
67 stworzona od zera w ANSI C.
68
69 G³ównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
70 dla jak najwiêkszej liczby ludzi), ma³ej i elastycznej alternatywy dla
71 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
72 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
73 jest bardzo du¿± porcj± kodu, zaprojektowan± raczej do zweryfikowania
74 standardu ni¿ dostarczenia ma³ej, stabilnej wersji produkcyjnej. GPAC
75 jest pisany w ANSI C ze wzglêdu na przeno¶no¶æ (platformy wbudowane i
76 DSP) z prostym celem: wymagaæ tak ma³o pamiêci, jak to tylko mo¿liwe.
77 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzêdzia
78 do publikacji w celu dystrybucji materia³ów.
79
80 %prep
81 %setup -q -n gpac
82 %if %{with amr}
83 mkdir -p Plugins/amr_dec/AMR_NB
84 cd Plugins/amr_dec/AMR_NB
85 # XXX: (conditional?) SourceN?
86 unzip -j %{_sourcedir}/26073-530.zip
87 unzip -j 26073-530_ANSI_C_source_code.zip
88 %endif
89 chmod a+x configure
90
91 %build
92 %configure \
93         --enable-oss-audio \
94         %{?with_amr: --enable-amr-nb} \
95         %{!?with_faad: --disable-faad} \
96         %{!?with_ffmpeg: --disable-ffmpeg} \
97         %{!?with_freetype: --disable-ft} \
98         %{!?with_jpeg: --disable-jpeg} \
99         %{!?with_js: --disable-js} \
100         %{!?with_mad: --disable-mad} \
101         %{!?with_png: --disable-png} \
102         %{!?with_xvid: --disable-xvid}
103
104 %{__make} \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         bindir=$RPM_BUILD_ROOT%{_bindir} \
112         libdir=$RPM_BUILD_ROOT%{_libdir} \
113         mandir=$RPM_BUILD_ROOT%{_mandir} \
114         plugdir=$RPM_BUILD_ROOT%{_libdir}/gpac \
115         real_plugdir=%{_libdir}/gpac \
116         prefix=$RPM_BUILD_ROOT/usr
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS BUGS Changelog COPYING README TODO
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_libdir}/*
129 %{_mandir}/man1/*
This page took 0.03714 seconds and 4 git commands to generate.