]> git.pld-linux.org Git - packages/gpac.git/blob - gpac.spec
- dropped SourceX-size
[packages/gpac.git] / gpac.spec
1 #
2 # Conditional build:
3 %bcond_with     amr
4 %bcond_without  faad
5 %bcond_without  ffmpeg
6 %bcond_without  freetype
7 %bcond_without  jpeg
8 %bcond_without  js
9 %bcond_without  mad
10 %bcond_without  png
11 %bcond_without  xvid
12 #
13 Summary:        GPAC - an implementation of the MPEG-4 Systems standard (ISO/IEC 14496-1)
14 Summary(pl):    GPAC - implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
15 Name:           gpac
16 Version:        0.2.1
17 Release:        1
18 License:        GPL
19 Group:          Applications
20 Source0:        http://dl.sourceforge.net/gpac/%{name}-%{version}.tar.gz
21 # Source0-md5:  3a3e193e805ab177f44514ca3289b461
22 Source1:        http://www.3gpp.org/ftp/Specs/archive/26_series/26.073/26073-530.zip
23 # Source1-md5:  705f6993fbf890e92eb7a331e7c716d1
24 URL:            http://gpac.sourceforge.net/
25 BuildRequires:  SDL-devel
26 #BuildRequires: wxWidgets-devel
27 %{?with_faad:BuildRequires:     faad2-devel}
28 %{?with_ffmpeg:BuildRequires:   ffmpeg-devel}
29 %{?with_freetype:BuildRequires: freetype-devel}
30 %{?with_js:BuildRequires:       js-devel}
31 %{?with_jpeg:BuildRequires:     libjpeg-devel}
32 %{?with_mad:BuildRequires:      libmad-devel}
33 %{?with_png:BuildRequires:      libpng-devel}
34 %{?with_xvid:BuildRequires:     xvid-devel}
35 Requires:       SDL
36 #Requires:      wxWidgets
37 %{?with_faad:Requires:  faad2}
38 %{?with_ffmpeg:Requires:        ffmpeg}
39 %{?with_freetype:Requires:      freetype}
40 %{?with_js:Requires:    js}
41 %{?with_jpeg:Requires:  libjpeg-6b}
42 %{?with_png:Requires:   libpng}
43 %{?with_mad:Requires:   libmad}
44 %{?with_xvid:Requires:  xvid}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 GPAC is an implementation of the MPEG-4 Systems standard (ISO/IEC
49 14496-1) developed from scratch in ANSI C.
50
51 The main development goal is to provide a clean (a.k.a. readable by as
52 many people as possible), small and flexible alternative to the MPEG-4
53 Systems reference software (known as IM1 and distributed in ISO/IEC
54 14496-5). The MPEG-4 Reference software is indeed a very large piece
55 of software, designed to verify the standard rather than provide a
56 small, production-stable software. GPAC is written in ANSI C for
57 portability reasons (embedded platforms and DSPs) with a simple goal:
58 keep the memory footprint as low as possible. The project will at term
59 provide player(s), systems encoders and publishing tools for content
60 distribution.
61
62 The current GPAC release (0.2.1) is far from being complete but
63 already covers a very large part of the standard, and can probably be
64 seen as the most advanced and robust 2D MPEG-4 Player available
65 worldwide (its 3D side is not to be neglected though).
66
67 %description -l pl
68 GPAC to implementacja standardu MPEG-4 Systems (ISO/IEC 14496-1)
69 stworzona od zera w ANSI C.
70
71 G³ównym celem tworzenia jej jest dostarczenie czystej (tzn. czytelnej
72 dla jak najwiêkszej liczby ludzi), ma³ej i elastycznej alternatywy dla
73 wzorcowego oprogramowania MPEG-4 Systems (znanego jako IM1 i
74 rozprowadzanego w ISO/IEC 14496-5). Wzorcowe oprogramowanie MPEG-4
75 jest bardzo du¿± porcj± kodu, zaprojektowan± raczej do zweryfikowania
76 standardu ni¿ dostarczenia ma³ej, stabilnej wersji produkcyjnej. GPAC
77 jest pisany w ANSI C ze wzglêdu na przeno¶no¶æ (platformy wbudowane i
78 DSP) z prostym celem: wymagaæ tak ma³o pamiêci, jak to tylko mo¿liwe.
79 Projekt docelowo dostarczy odtwarzacz(e), kodery systemowe i narzêdzia
80 do publikacji w celu dystrybucji materia³ów.
81
82 Aktualne wydanie GPAC (0.2.1) jest dalekie od ukoñczenia, ale ju¿
83 pokrywa bardzo du¿± czê¶æ standardu i prawdopodobnie mo¿na je
84 traktowaæ jako najbardziej zaawansowany i bogaty dwuwymiarowy
85 odtwarzacz MPEG-4 (aspekt trójwymiarowy jednak nie ma pozostaæ
86 zlekcewa¿ony).
87
88 %prep
89 %setup -q -n gpac
90 %if %{with amr}
91 mkdir -p Plugins/amr_dec/AMR_NB
92 cd Plugins/amr_dec/AMR_NB
93 # XXX: (conditional?) SourceN?
94 unzip -j %{_sourcedir}/26073-530.zip
95 unzip -j 26073-530_ANSI_C_source_code.zip
96 %endif
97
98 %build
99 %configure \
100         --enable-oss-audio \
101         %{?with_amr: --enable-amr-nb} \
102         %{!?with_faad: --disable-faad} \
103         %{!?with_ffmpeg: --disable-ffmpeg} \
104         %{!?with_freetype: --disable-ft} \
105         %{!?with_jpeg: --disable-jpeg} \
106         %{!?with_js: --disable-js} \
107         %{!?with_mad: --disable-mad} \
108         %{!?with_png: --disable-png} \
109         %{!?with_xvid: --disable-xvid}
110
111 %{__make} \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         bindir=$RPM_BUILD_ROOT%{_bindir} \
119         libdir=$RPM_BUILD_ROOT%{_libdir} \
120         mandir=$RPM_BUILD_ROOT%{_mandir}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc AUTHORS BUGS Changelog COPYING README TODO
131 %attr(755,root,root) %{_bindir}/*
132 %attr(755,root,root) %{_libdir}/*
133 %{_mandir}/man1/*
This page took 0.11105 seconds and 4 git commands to generate.