]> git.pld-linux.org Git - packages/google-gadgets.git/blob - google-gadgets.spec
- updated to 0.11.0
[packages/google-gadgets.git] / google-gadgets.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk     # without gtk support
4 %bcond_without  qt      # without qt support
5 %bcond_without  gadgets # without gadgets
6
7 %define         rev     r1084
8
9 # use this to get latest rev:
10 # svn export http://google-gadgets-for-linux.googlecode.com/svn/trunk/ google-gadgets-for-linux
11 Summary:        Google Gadgets for Linux
12 Name:           google-gadgets
13 Version:        0.11.0
14 Release:        1
15 License:        Apache License v2.0
16 Group:          X11/Applications
17 #Source0:       %{name}-for-linux-%{version}-%{rev}.tar.bz2
18 Source0:        http://google-gadgets-for-linux.googlecode.com/files/%{name}-for-linux-%{version}.tar.bz2
19 # Source0-md5:  714b65738f4edeae361e2b164088c50d
20 Source1:        %{name}-for-linux-gtk.desktop
21 Source2:        %{name}-for-linux-qt.desktop
22 Patch0:         %{name}-for-linux-cmake.patch
23 Patch1:         %{name}-for-linux-link_with_qtnetwork.patch
24 Patch2:         %{name}-for-linux-js.patch
25 URL:            http://code.google.com/p/google-gadgets-for-linux/
26 BuildRequires:  NetworkManager-devel >= 0.6.5
27 %if %{with qt}
28 BuildRequires:  QtCore-devel >= 4.4.3
29 BuildRequires:  QtNetwork-devel >= 4.4.3
30 BuildRequires:  QtScript-devel >= 4.4.3
31 BuildRequires:  QtWebKit-devel >= 4.4.3
32 %endif
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 %if %{with gtk}
36 BuildRequires:  cairo-devel >= 1.2.0
37 BuildRequires:  gtk+2-devel >= 2:2.10.0
38 BuildRequires:  startup-notification-devel
39 %endif
40 BuildRequires:  curl-devel >= 7.18.2
41 BuildRequires:  dbus-devel >= 1.0.2
42 BuildRequires:  flex
43 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.0
44 BuildRequires:  libltdl-devel
45 BuildRequires:  librsvg-devel
46 BuildRequires:  libtool >= 2:1.5.22
47 BuildRequires:  libxml2-devel >= 1:2.4.0
48 BuildRequires:  pkgconfig
49 BuildRequires:  qt4-build
50 BuildRequires:  xulrunner-devel >= 1.8
51 BuildRequires:  zip
52 BuildRequires:  zlib-devel >= 1.2.0
53 Requires:       libggadget = %{version}-%{release}
54 Provides:       google-gadgets-for-linux-gadgets = %{version}
55 Obsoletes:      google-gadgets-for-linux-gadgets
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Google Gadgets for Linux provides a platform for running desktop
60 gadgets under Linux, catering to the unique needs of Linux users. It's
61 compatible with the gadgets written for Google Desktop for Windows as
62 well as the Universal Gadgets on iGoogle.
63
64 %package -n libggadget
65 Summary:        Google Gadgets main libraries
66 Group:          Libraries
67 Requires:       dbus >= 1.0.21G
68 Requires:       libltdl
69 Obsoletes:      google-gadgets-for-linux
70
71 %description -n libggadget
72 This package contains the main Google Gadgets libraries, it is
73 required by both the GTK+ and QT versions of Google Gadgets.
74
75 %package -n libggadget-devel
76 Summary:        Google Gadgets main development files
77 Group:          Development/Libraries
78 Requires:       dbus-devel >= 1.0.2
79 Requires:       libggadget = %{version}-%{release}
80
81 %description -n libggadget-devel
82 This package contains the development files assoicated with
83 libggadget, it is needed to write programs that utilise libggadget.
84
85 %description -n libggadget-devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki google-gadgets.
87
88 %package -n libggadget-gtk
89 Summary:        Google Gadgets GTK+ library
90 Group:          Libraries
91 Requires:       cairo >= 1.2.0
92 Requires:       gtk+2 >= 2:2.10.0
93 Requires:       libggadget = %{version}-%{release}
94 Requires:       librsvg >= 1:2.18.0
95
96 %description -n libggadget-gtk
97 This package contains the GTK+ Google Gadgets library, it is required
98 to run the GTK+ version of Google Gadgets.
99
100 %package -n libggadget-gtk-devel
101 Summary:        Google Gadgets GTK+ development files
102 Group:          Development/Libraries
103 Requires:       cairo-devel >= 1.2.0
104 Requires:       gtk+2-devel >= 2:2.10.0
105 Requires:       libggadget-devel = %{version}-%{release}
106 Requires:       libggadget-gtk = %{version}-%{release}
107 Requires:       librsvg-devel >= 1:2.18.0
108
109 %description -n libggadget-gtk-devel
110 This package contains the development files assoicated with
111 libggadget-gtk, it is needed to write GTK+ programs that utilise
112 libggadget.
113
114 %package -n libggadget-qt
115 Summary:        Google Gadgets QT library
116 Group:          Libraries
117 Requires:       QtWebKit >= 4.4.0
118 Requires:       libggadget = %{version}-%{release}
119
120 %description -n libggadget-qt
121 This package contains the QT Google Gadgets library, it is required to
122 run the QT version of Google Gadgets.
123
124 %package -n libggadget-qt-devel
125 Summary:        Google Gadgets QT development files
126 Group:          Development/Libraries
127 Requires:       QtWebKit-devel >= 4.4.0
128 Requires:       libggadget-devel = %{version}-%{release}
129 Requires:       libggadget-qt = %{version}-%{release}
130
131 %description -n libggadget-qt-devel
132 This package contains the development files assoicated with
133 libggadget-qt, it is needed to write QT programs that utilise
134 libggadget.
135
136 %package gtk
137 Summary:        GTK+ Version of Google Gadgets
138 Group:          X11/Applications
139 Requires:       google-gadgets = %{version}-%{release}
140 Requires:       google-gadgets-gst = %{version}-%{release}
141 Requires:       google-gadgets-xul = %{version}-%{release}
142 Requires:       libggadget-gtk = %{version}-%{release}
143 Obsoletes:      google-gadgets-for-linux-gtk
144
145 %description gtk
146 Google Gadgets for Linux provides a platform for running desktop
147 gadgets under Linux, catering to the unique needs of Linux users. It's
148 compatible with the gadgets written for Google Desktop for Windows as
149 well as the Universal Gadgets on iGoogle.
150
151 This package includes the GTK+ version.
152
153 %package qt
154 Summary:        QT Version of Google Gadgets
155 Group:          X11/Applications
156 Requires:       google-gadgets = %{version}-%{release}
157 Requires:       google-gadgets-gst = %{version}
158 Requires:       libggadget-qt = %{version}-%{release}
159 Obsoletes:      google-gadgets-for-linux-qt
160
161 %description qt
162 Google Gadgets for Linux provides a platform for running desktop
163 gadgets under Linux, catering to the unique needs of Linux users. It's
164 compatible with the gadgets written for Google Desktop for Windows as
165 well as the Universal Gadgets on iGoogle.
166
167 This package includes the QT version.
168
169 %package gst
170 Summary:        GStreamer modules for Google Gadgets
171 Group:          X11/Applications
172 Requires:       gstreamer-plugins-base >= 0.10.6
173 Requires:       libggadget = %{version}-%{release}
174
175 %description gst
176 Google Gadgets for Linux provides a platform for running desktop
177 gadgets under Linux, catering to the unique needs of Linux users. It's
178 compatible with the gadgets written for Google Desktop for Windows as
179 well as the Universal Gadgets on iGoogle.
180
181 This package includes the GStreamer modules.
182
183 %package xul
184 Summary:        XULRunner modules for Google Gadgets
185 Group:          X11/Applications
186 Requires:       libggadget = %{version}-%{release}
187 Requires:       xulrunner
188
189 %description xul
190 Google Gadgets for Linux provides a platform for running desktop
191 gadgets under Linux, catering to the unique needs of Linux users. It's
192 compatible with the gadgets written for Google Desktop for Windows as
193 well as the Universal Gadgets on iGoogle.
194
195 This package includes the XULRunner modules.
196
197 %prep
198 %setup -q -n %{name}-for-linux-%{version}
199 %patch0 -p1
200 %patch1 -p1
201 %patch2 -p1
202
203 %build
204 install -d libltdl
205 %{__libtoolize}
206 %{__aclocal} -I autotools
207 %{__autoconf}
208 %{__autoheader}
209 %{__automake}
210 %configure \
211         --disable-ltdl-install \
212         --disable-static \
213         --disable-werror \
214         --with-oem-brand=pld-linux \
215         --with-browser-plugins-dir=%{_libdir}/browser-plugins
216
217 %{__make}
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
222
223 %{__make} install \
224         DESTDIR=$RPM_BUILD_ROOT
225
226 # desync with cmake/ac makefiles
227 mv $RPM_BUILD_ROOT%{_datadir}/mime/packages/{00-,}google-gadgets.xml
228 # desktop files
229 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/ggl-gtk.desktop
230 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/ggl-qt.desktop
231
232 rm -f $RPM_BUILD_ROOT%{_libdir}/google-gadgets/modules/*.la
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %post -n libggadget -p /sbin/ldconfig
238 %postun -n libggadget -p /sbin/ldconfig
239
240 %post -n libggadget-gtk -p /sbin/ldconfig
241 %postun -n libggadget-gtk -p /sbin/ldconfig
242
243 %post -n libggadget-qt -p /sbin/ldconfig
244 %postun -n libggadget-qt -p /sbin/ldconfig
245
246 %files
247 %defattr(644,root,root,755)
248 %doc AUTHORS README NEWS
249 %dir %{_libdir}/google-gadgets
250 %dir %{_libdir}/google-gadgets/modules
251 %attr(755,root,root) %{_libdir}/google-gadgets/modules/analytics-usage-collector.so
252 %attr(755,root,root) %{_libdir}/google-gadgets/modules/curl-xml-http-request.so
253 %attr(755,root,root) %{_libdir}/google-gadgets/modules/dbus-script-class.so
254 %attr(755,root,root) %{_libdir}/google-gadgets/modules/default-framework.so
255 %attr(755,root,root) %{_libdir}/google-gadgets/modules/default-options.so
256 %attr(755,root,root) %{_libdir}/google-gadgets/modules/google-gadget-manager.so
257 %attr(755,root,root) %{_libdir}/google-gadgets/modules/libxml2-xml-parser.so
258 %attr(755,root,root) %{_libdir}/google-gadgets/modules/linux-system-framework.so
259 %dir %{_datadir}/google-gadgets
260 %{_datadir}/google-gadgets/*.gg
261 %{_datadir}/mime/packages/google-gadgets.xml
262 %{_iconsdir}/*/*/*/*.png
263 %{_pixmapsdir}/google-gadgets.png
264
265 %files -n libggadget
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %ghost %{_libdir}/libggadget-1.0.so.0
268 %attr(755,root,root) %{_libdir}/libggadget-1.0.so.*.*.*
269 %attr(755,root,root) %ghost %{_libdir}/libggadget-dbus-1.0.so.0
270 %attr(755,root,root) %{_libdir}/libggadget-dbus-1.0.so.*.*.*
271 %attr(755,root,root) %ghost %{_libdir}/libggadget-js-1.0.so.0
272 %attr(755,root,root) %{_libdir}/libggadget-js-1.0.so.*.*.*
273 %attr(755,root,root) %ghost %{_libdir}/libggadget-npapi-1.0.so.0
274 %attr(755,root,root) %{_libdir}/libggadget-npapi-1.0.so.*.*.*
275 %attr(755,root,root) %ghost %{_libdir}/libggadget-xdg-1.0.so.0
276 %attr(755,root,root) %{_libdir}/libggadget-xdg-1.0.so.*.*.*
277
278 %files -n libggadget-devel
279 %defattr(644,root,root,755)
280 %dir %{_includedir}/google-gadgets
281 %dir %{_includedir}/google-gadgets/ggadget
282 %dir %{_includedir}/google-gadgets/ggadget/dbus
283 %dir %{_includedir}/google-gadgets/ggadget/js
284 %dir %{_includedir}/google-gadgets/ggadget/xdg
285 %dir %{_includedir}/google-gadgets/ggadget/npapi
286 %{_includedir}/google-gadgets/ggadget/*.h
287 %{_includedir}/google-gadgets/ggadget/dbus/*.h
288 %{_includedir}/google-gadgets/ggadget/js/*.h
289 %{_includedir}/google-gadgets/ggadget/xdg/*.h
290 %{_includedir}/google-gadgets/ggadget/npapi/*.h
291 %dir %{_libdir}/google-gadgets/include
292 %dir %{_libdir}/google-gadgets/include/ggadget
293 %{_libdir}/google-gadgets/include/ggadget/sysdeps.h
294 %{_libdir}/libggadget-1.0*.so
295 %{_libdir}/libggadget-dbus-1.0*.so
296 %{_libdir}/libggadget-js-1.0*.so
297 %{_libdir}/libggadget-xdg-1.0*.so
298 %{_libdir}/libggadget-npapi-1.0*.so
299 %if 0
300 %{_libdir}/libggadget-1.0*.la
301 %{_libdir}/libggadget-dbus-1.0*.la
302 %{_libdir}/libggadget-js-1.0*.la
303 %{_libdir}/libggadget-xdg-1.0*.la
304 %{_libdir}/libggadget-npapi-1.0*.la
305 %endif
306 %{_pkgconfigdir}/libggadget-1.0.pc
307 %{_pkgconfigdir}/libggadget-dbus-1.0.pc
308 %{_pkgconfigdir}/libggadget-js-1.0.pc
309 %{_pkgconfigdir}/libggadget-xdg-1.0.pc
310 %{_pkgconfigdir}/libggadget-npapi-1.0.pc
311
312 %files -n libggadget-gtk
313 %defattr(644,root,root,755)
314 %attr(755,root,root) %ghost %{_libdir}/libggadget-gtk-1.0.so.0
315 %attr(755,root,root) %{_libdir}/libggadget-gtk-1.0.so.*.*.*
316
317 %files -n libggadget-gtk-devel
318 %defattr(644,root,root,755)
319 %dir %{_includedir}/google-gadgets/ggadget/gtk
320 %{_includedir}/google-gadgets/ggadget/gtk/*.h
321 %{_libdir}/libggadget-gtk-1.0*.so
322 #%{_libdir}/libggadget-gtk-1.0*.la
323 %{_pkgconfigdir}/libggadget-gtk-1.0.pc
324
325 %files -n libggadget-qt
326 %defattr(644,root,root,755)
327 %attr(755,root,root) %ghost %{_libdir}/libggadget-qt-1.0.so.0
328 %attr(755,root,root) %{_libdir}/libggadget-qt-1.0.so.*.*.*
329
330 %files -n libggadget-qt-devel
331 %defattr(644,root,root,755)
332 %dir %{_includedir}/google-gadgets/ggadget/qt
333 %{_includedir}/google-gadgets/ggadget/qt/*.h
334 %{_libdir}/libggadget-qt-1.0*.so
335 #%{_libdir}/libggadget-qt-1.0*.la
336 %{_pkgconfigdir}/libggadget-qt-1.0.pc
337
338 %files gtk
339 %defattr(644,root,root,755)
340 %attr(755,root,root) %{_bindir}/ggl-gtk
341 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gtk-edit-element.so
342 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gtk-flash-element.so
343 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gtk-system-framework.so
344 %{_desktopdir}/ggl-gtk.desktop
345 %{_desktopdir}/ggl-designer.desktop
346
347 %files qt
348 %defattr(644,root,root,755)
349 %attr(755,root,root) %{_bindir}/ggl-qt
350 %attr(755,root,root) %{_libdir}/google-gadgets/modules/qt-edit-element.so
351 %attr(755,root,root) %{_libdir}/google-gadgets/modules/qt-script-runtime.so
352 %attr(755,root,root) %{_libdir}/google-gadgets/modules/qt-system-framework.so
353 %attr(755,root,root) %{_libdir}/google-gadgets/modules/qt-xml-http-request.so
354 %attr(755,root,root) %{_libdir}/google-gadgets/modules/qtwebkit-browser-element.so
355 %{_desktopdir}/ggl-qt.desktop
356
357 %files gst
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gst-audio-framework.so
360 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gst-video-element.so
361
362 %files xul
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_libdir}/google-gadgets/modules/smjs-script-runtime.so
365 %attr(755,root,root) %{_libdir}/google-gadgets/modules/gtkmoz-browser-element.so
366 %attr(755,root,root) %{_libdir}/google-gadgets/gtkmoz-browser-child
This page took 0.121546 seconds and 4 git commands to generate.