]> git.pld-linux.org Git - packages/google-gadgets.git/blob - google-gadgets.spec
- my md5
[packages/google-gadgets.git] / google-gadgets.spec
1 # use this to get latest rev:
2 # svn export http://google-gadgets-for-linux.googlecode.com/svn/trunk/ google-gadgets-for-linux
3 # TODO:
4 # - add gtk BRs
5 # - update desc
6 # Conditional build:
7 #% bcond_with   debug   # build with debug
8 #% bcond_without        gtk     # without gtk support
9 #% bcond_without        qt      # without qt support
10 #% bcond_without        gadgets # without gadgets
11
12 %define         realname        google-gadgets
13 %define         rev     r1028
14
15 Summary:        google-gadgets-for-linux
16 Name:           google-gadgets-for-linux
17 Version:        0.10.4
18 Release:        0.1
19 License:        Apache License v2.0
20 Group:          X11/Applications
21 #Source0:       %{name}-%{version}-%{rev}.tar.bz2
22 Source0:        http://google-gadgets-for-linux.googlecode.com/files/%{name}-%{version}.tar.bz2
23 # Source0-md5:  0ef0a62e0a575388084a77759b646718
24 Source1:        %{name}-gtk.desktop
25 Source2:        %{name}-qt.desktop
26 Patch0:         %{name}-cmake.patch
27 Patch1:         %{name}-link_with_qtnetwork.patch
28 Patch2:         %{name}-js.patch
29 URL:            http://code.google.com/p/google-gadgets-for-linux/
30 BuildRequires:  QtCore-devel >= 4.4.3
31 BuildRequires:  QtNetwork-devel >= 4.4.3
32 BuildRequires:  QtScript-devel >= 4.4.3
33 BuildRequires:  QtWebKit-devel >= 4.4.3
34 BuildRequires:  cmake >= 2.6.1-2
35 BuildRequires:  curl-devel >= 7.18.2
36 BuildRequires:  dbus-devel >= 1.0.2
37 BuildRequires:  flex
38 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.0
39 BuildRequires:  libltdl-devel
40 BuildRequires:  librsvg-devel
41 BuildRequires:  libtool >= 1.5.22
42 BuildRequires:  libxml2-devel >= 2.4.0
43 BuildRequires:  pkgconfig
44 BuildRequires:  xulrunner-devel >= 1.8
45 BuildRequires:  zip
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 google-gadgets-for-linux.
50
51 %package gadgets
52 Summary:        google-gadgets set
53 Summary(pl.UTF-8):      Zestaw gadżetów google-gadgets
54 Group:          X11/Applications
55 Requires:       %{name} = %{version}-%{release}
56
57 %description gadgets
58 Google-gadgets set.
59
60 %description gadgets -l pl.UTF-8
61 Zestaw gadżetów google-gadgets.
62
63 %package devel
64 Summary:        Header files for google-gadgets library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki google-gadgets
66 Group:          Development/Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description devel
70 Header files for google-gadgets library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki google-gadgets.
74
75 %package static
76 Summary:        Static google-gadgets libraries
77 Summary(pl.UTF-8):      Statyczne biblioteki google-gadgets
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Static google-gadgets libraries.
83
84 %description static -l pl.UTF-8
85 Statyczne biblioteki google-gadgets.
86
87 %prep
88 %setup -q
89 find -name '.svn' | xargs rm -rf
90 %patch0 -p1
91 %patch1 -p1
92 %patch2 -p1
93
94 %build
95 install -d libltdl
96 %{__libtoolize}
97 %{__aclocal} -I autotools
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         --disable-ltdl-install \
103         --disable-static \
104         --disable-werror \
105         --with-oem-brand=pld-linux \
106         --with-browser-plugins-dir=%{_libdir}/browser-plugins
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 # desync with cmake/ac makefiles
117 mv $RPM_BUILD_ROOT%{_datadir}/mime/packages/{00-,}google-gadgets.xml
118 # desktop files
119 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/ggl-gtk.desktop
120 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/ggl-qt.desktop
121
122 rm -f $RPM_BUILD_ROOT%{_libdir}/google-gadgets/modules/smjs-script-runtime.la
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/*
133 %{_datadir}/mime/packages/google-gadgets.xml
134 %dir %{_datadir}/%{realname}
135 %{_datadir}/%{realname}/*.gg
136 %{_desktopdir}/*.desktop
137 %{_iconsdir}/*/*/*/*.png
138 %{_pixmapsdir}/%{realname}.png
139
140 %attr(755,root,root) %{_libdir}/*.so.*.*.*
141 %attr(755,root,root) %ghost %{_libdir}/*.so.0
142 %attr(755,root,root) %{_libdir}/%{realname}/gtkmoz-browser-child
143 %dir %{_libdir}/%{realname}
144 %dir %{_libdir}/%{realname}/modules
145
146 %files gadgets
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/%{realname}/modules/*.so
149
150 %files devel
151 %defattr(644,root,root,755)
152 %dir %{_libdir}/%{realname}/include
153 %dir %{_libdir}/%{realname}/include/ggadget
154 %{_libdir}/%{realname}/include/ggadget/*.h
155 %dir %{_includedir}/%{realname}
156 %dir %{_includedir}/%{realname}/ggadget
157 %{_includedir}/%{realname}/ggadget/*.h
158 %dir %{_includedir}/%{realname}/ggadget/dbus
159 %{_includedir}/%{realname}/ggadget/dbus/*.h
160 %dir %{_includedir}/%{realname}/ggadget/gtk
161 %{_includedir}/%{realname}/ggadget/gtk/*.h
162 %dir %{_includedir}/%{realname}/ggadget/npapi
163 %{_includedir}/%{realname}/ggadget/npapi/*.h
164 %dir %{_includedir}/%{realname}/ggadget/qt
165 %{_includedir}/%{realname}/ggadget/qt/*.h
166 %dir %{_includedir}/%{realname}/ggadget/js
167 %{_includedir}/%{realname}/ggadget/js/*.h
168 %dir %{_includedir}/%{realname}/ggadget/xdg
169 %{_includedir}/%{realname}/ggadget/xdg/*.h
170 %attr(755,root,root) %{_libdir}/*.so
171 %{_pkgconfigdir}/*.pc
172
173 #%files static
174 #%defattr(644,root,root,755)
175 #%{_libdir}/lib*.a
This page took 0.070113 seconds and 4 git commands to generate.