]> git.pld-linux.org Git - packages/google-gadgets.git/blob - google-gadgets.spec
- updated to 0.10.4 r1028
[packages/google-gadgets.git] / google-gadgets.spec
1 # use this to get latest rev:
2 # svn checkout http://google-gadgets-for-linux.googlecode.com/svn/trunk/ google-gadgets-for-linux-read-only
3 # TODO:
4 # - add gtk BRs
5 # - smjs-script-runtime.so: undefined symbol: _ZN7ggadget2js14MassageJScriptEPKcbS2_i
6 # c++filt _ZN7ggadget2js14MassageJScriptEPKcbS2_i
7 # ggadget::js::MassageJScript(char const*, bool, char const*, int)
8 # - update desc
9 # Conditional build:
10 #%bcond_with    debug   # build with debug
11 #% bcond_without        gtk     # without gtk support
12 #% bcond_without        qt      # without qt support
13 #% bcond_without        gadgets # without gadgets
14
15 %define         realname        google-gadgets
16 %define         rev     r1028
17 #
18 Summary:        google-gadgets-for-linux
19 Name:           google-gadgets-for-linux
20 Version:        0.10.4
21 Release:        0.%{rev}.1
22 License:        Apache License v2.0
23 Group:          X11/Applications
24 Source0:        %{name}-%{version}-%{rev}.tar.bz2
25 # Source0-md5:  0dcf2f1e392e44323720ef422a18664c
26 Source1:        %{name}-gtk.desktop
27 Source2:        %{name}-qt.desktop
28 Patch0:         %{name}-cmake.patch
29 Patch1:         %{name}-link_with_qtnetwork.patch
30 URL:            http://code.google.com/p/google-gadgets-for-linux/
31 BuildRequires:  QtCore-devel >= 4.4.3
32 BuildRequires:  QtNetwork-devel >= 4.4.3
33 BuildRequires:  QtScript-devel >= 4.4.3
34 BuildRequires:  QtWebKit-devel >= 4.4.3
35 BuildRequires:  cmake >= 2.6.1-2
36 BuildRequires:  curl-devel >= 7.18.2
37 BuildRequires:  dbus-devel >= 1.0.2
38 BuildRequires:  flex
39 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.0
40 BuildRequires:  libltdl-devel
41 BuildRequires:  librsvg-devel
42 BuildRequires:  libtool >= 1.5.22
43 BuildRequires:  libxml2-devel >= 2.4.0
44 BuildRequires:  pkgconfig
45 BuildRequires:  xulrunner-devel >= 1.8
46 BuildRequires:  zip
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 google-gadgets-for-linux.
51
52 %package gadgets
53 Summary:        google-gadgets set
54 Summary(pl.UTF-8):      Zestaw gadżetów google-gadgets
55 Group:          X11/Applications
56 Requires:       %{name} = %{version}-%{release}
57
58 %description gadgets
59 Google-gadgets set.
60
61 %description gadgets -l pl.UTF-8
62 Zestaw gadżetów google-gadgets.
63
64 %package devel
65 Summary:        Header files for google-gadgets library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki google-gadgets
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description devel
71 Header files for google-gadgets library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki google-gadgets.
75
76 %package static
77 Summary:        Static google-gadgets libraries
78 Summary(pl.UTF-8):      Statyczne biblioteki google-gadgets
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static google-gadgets libraries.
84
85 %description static -l pl.UTF-8
86 Statyczne biblioteki google-gadgets.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 install -d build
95 cd build
96 %cmake \
97         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
98         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
99 %if "%{_lib}" == "lib64"
100         -DLIB_SUFFIX=64 \
101 %endif
102         ../
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
110
111 %{__make} -C build install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 # desktop files
115 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/ggl-gtk.desktop
116 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}/ggl-qt.desktop
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/*
127 %{_datadir}/mime/packages/google-gadgets.xml
128 %dir %{_datadir}/%{realname}
129 %{_datadir}/%{realname}/*.gg
130 %{_desktopdir}/*.desktop
131 %{_iconsdir}/*/*/*/*.png
132 %{_pixmapsdir}/%{realname}.png
133
134 %attr(755,root,root) %{_libdir}/*.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/*.so.0
136 %attr(755,root,root) %{_libdir}/%{realname}/gtkmoz-browser-child
137 %dir %{_libdir}/%{realname}
138 %dir %{_libdir}/%{realname}/modules
139
140 %files gadgets
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/%{realname}/modules/*.so
143
144 %files devel
145 %defattr(644,root,root,755)
146 %dir %{_libdir}/%{realname}/include
147 %dir %{_libdir}/%{realname}/include/ggadget
148 %{_libdir}/%{realname}/include/ggadget/*.h
149 %dir %{_includedir}/%{realname}
150 %dir %{_includedir}/%{realname}/ggadget
151 %{_includedir}/%{realname}/ggadget/*.h
152 %dir %{_includedir}/%{realname}/ggadget/dbus
153 %{_includedir}/%{realname}/ggadget/dbus/*.h
154 %dir %{_includedir}/%{realname}/ggadget/gtk
155 %{_includedir}/%{realname}/ggadget/gtk/*.h
156 %dir %{_includedir}/%{realname}/ggadget/npapi
157 %{_includedir}/%{realname}/ggadget/npapi/*.h
158 %dir %{_includedir}/%{realname}/ggadget/qt
159 %{_includedir}/%{realname}/ggadget/qt/*.h
160 %dir %{_includedir}/%{realname}/ggadget/js
161 %{_includedir}/%{realname}/ggadget/js/*.h
162 %dir %{_includedir}/%{realname}/ggadget/xdg
163 %{_includedir}/%{realname}/ggadget/xdg/*.h
164 %attr(755,root,root) %{_libdir}/*.so
165 %{_pkgconfigdir}/*.pc
166
167 #%files static
168 #%defattr(644,root,root,755)
169 #%{_libdir}/lib*.a
This page took 0.459945 seconds and 4 git commands to generate.