]> git.pld-linux.org Git - packages/gom.git/blob - gom.spec
Release 5 (by relup.sh)
[packages/gom.git] / gom.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # Python (3) binding
4 #
5 Summary:        GObject Data Mapper library
6 Summary(pl.UTF-8):      Biblioteka GObject Data Mapper
7 Name:           gom
8 Version:        0.4
9 Release:        5
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gom/0.4/%{name}-%{version}.tar.xz
13 # Source0-md5:  0cc4debe208cb4c91b013e5e57a99808
14 URL:            https://github.com/GNOME/gom
15 BuildRequires:  gdk-pixbuf2-devel >= 2.0
16 BuildRequires:  glib2-devel >= 1:2.36
17 BuildRequires:  gobject-introspection-devel >= 1.30.0
18 BuildRequires:  gtk-doc >= 1.14
19 BuildRequires:  intltool >= 0.40.0
20 BuildRequires:  meson >= 0.48
21 BuildRequires:  pkgconfig
22 %{?with_python:BuildRequires:   python3-devel >= 1:3.4}
23 %{?with_python:BuildRequires:   python3-pygobject3-devel >= 3.16.0}
24 BuildRequires:  rpmbuild(macros) >= 1.714
25 BuildRequires:  sqlite3-devel >= 3.7
26 Requires:       glib2 >= 1:2.36
27 Requires:       sqlite3 >= 3.7
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 GOM (GObject Data Mapper) is an attempt to make a DataMapper for
32 GObject.
33
34 %description -l pl.UTF-8
35 GOM (GObject Data Mapper) to próba stworzenia DataMappera dla obieków
36 biblioteki GObject.
37
38 %package devel
39 Summary:        Header files for GOM library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GOM
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       glib2-devel >= 1:2.36
44 Obsoletes:      gom-static
45
46 %description devel
47 This is the package containing the header files for GOM.
48
49 %description devel -l pl.UTF-8
50 Ten pakiet zawiera pliki nagłówkowe GOM.
51
52 %package apidocs
53 Summary:        GOM library API documentation
54 Summary(pl.UTF-8):      Dokumentacja API biblioteki GOM
55 Group:          Documentation
56 Requires:       gtk-doc-common
57 BuildArch:      noarch
58
59 %description apidocs
60 GOM library API documentation.
61
62 %description apidocs -l pl.UTF-8
63 Dokumentacja API biblioteki GOM.
64
65 %package -n python3-gom
66 Summary:        Python 3 binding for GOM library
67 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki GOM
68 Group:          Libraries/Python
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       python3-pygobject3 >= 3.16.0
71
72 %description -n python3-gom
73 Python 3 binding for GOM library.
74
75 %description -n python3-gom -l pl.UTF-8
76 Wiązanie Pythona 3 do biblioteki GOM.
77
78 %prep
79 %setup -q
80
81 %build
82 CC="%{__cc}" \
83 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
84 LDFLAGS="%{rpmldflags}" \
85 %meson build \
86         -Denable-gtk-doc=true
87 %meson_build -C build
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %meson_install -C build
93
94 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
95 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS NEWS README TODO
106 %attr(755,root,root) %{_libdir}/libgom-1.0.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libgom-1.0.so.0
108 %{_libdir}/girepository-1.0/Gom-1.0.typelib
109
110 %files devel
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{_libdir}/libgom-1.0.so
113 %{_includedir}/gom-1.0
114 %{_pkgconfigdir}/gom-1.0.pc
115 %{_datadir}/gir-1.0/Gom-1.0.gir
116
117 %files apidocs
118 %defattr(644,root,root,755)
119 %{_gtkdocdir}/gom
120
121 %if %{with python}
122 %files -n python3-gom
123 %defattr(644,root,root,755)
124 %{py3_sitedir}/gi/overrides/Gom.py
125 %{py3_sitedir}/gi/overrides/__pycache__/Gom.cpython-*.py[co]
126 %endif
This page took 0.124213 seconds and 4 git commands to generate.