]> git.pld-linux.org Git - projects/template-specs.git/blob - golang-package.spec
rename go template to golang prefix
[projects/template-specs.git] / golang-package.spec
1 #
2 # Conditional build:
3 %bcond_without  src             # build devel package with sources
4 %bcond_without  tests   # build without tests
5
6 %define         pkgname         template
7 Summary:        -
8 Summary(pl.UTF-8):      -
9 Name:           golang-github-template-%{pkgname}
10 Version:        _
11 Release:        0.1
12 License:        - (enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
13 Group:          Libraries
14 Source0:        %{name}-%{version}.tar.gz
15 # Source0-md5:  -
16 URL:            -
17 BuildRequires:  golang >= 1.3.1
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _enable_debug_packages 0
21 %define         gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
22 %define         gopath          %{_libdir}/golang
23 %define         import_path     github.com/russross/%{pkgname}
24
25 %description
26 A package written in go language
27
28 %package devel
29 Summary:        %{summary}
30 Group:          Development/Languages
31 #Requires:      golang(github.com/../...)
32 Provides:       golang(%{import_path}) = %{version}-%{release}
33 # noarch subpackages only when building with rpm5
34 %if "%{_rpmversion}" >= "5"
35 BuildArch:      noarch
36 %endif
37
38 %description devel
39 %{summary}
40
41 This package contains library source intended for building other
42 packages which use import path with %{import_path} prefix.
43
44 %prep
45 %setup -q
46
47 %build
48 export GOPATH=$(pwd)/vendor
49 install -d $GOPATH
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc AUTHORS CREDITS CHANGES ChangeLog NEWS README THANKS TODO
This page took 0.037932 seconds and 3 git commands to generate.